
EXERCISE 7 – TUTORIAL

Wildfire Mapping with Sentinel-1 & Sentinel-2 using

the SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 Detect wildfires on Sentinel-1 and Sentinel-2 images

 Export subset as image to perform another analysis in QGIS

 Map burned areas and quantify burn severity using Normalised
Burn Ratio index

 Develop a graph for automated processing using Batch processing

 Create Stack and RGB composites for two Sentinel-1 temporal
datasets to observe wildfire burn scars
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1 | Exercise outline



2 | Background

The wildfires around the important riverside port of Rosario, essential for

transporting Argentina's extensive grain harvest, have raised concerns

among local residents and activists.

Fires in the grasslands close to a vital South American river delta present

serious threats to both nearby wetland ecosystems and human well-

being, caution environmental experts. The wildfires around the important

riverside port of Rosario, essential for transporting Argentina's extensive

grain harvest, have raised concerns among local residents and activists.

The Parana River, South America's second-longest river after the

Amazon, experienced its lowest water levels since 1944 in 2021 as

reported by official data. This decline is attributed to multiple cycles of

drought and reduced rainfall in upstream Brazil. In August 2022, the

water level remained exceptionally low. The wildfires, many intentionally

set by farmers preparing the land for new crops, generated a thick haze

that reached Buenos Aires, located approximately 190 miles (300 km)

south of Rosario. Residents were displeased with the presence of soot in

the air, leading popular weather apps to issue forecasts simply describing

the conditions as "smoke."
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Fires in the grasslands

close to a vital South

American river delta

present serious threats

to both nearby wetland

ecosystems and human

well-being, caution

environmental experts.

Wildfires burning in the wetlands of the Paraná River Delta, Argentina, 
19 August, 2022



2.1 Study area and data used

For this exercise, we will use two Sentinel-2 images and two Sentinel-1

GRDH images of the same area in Paraná River Delta, Argentina, using

the Tile Number *20HQJ* downloaded for two days of summer 2022

(before and after the wildfires) from the Dataspace Copernicus Open

Access Hub [@https://dataspace.copernicus.eu/].

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open 2 downloaded products

(unzipped) by double click on the metadata „MTD_MSIL2A.xml“ inside

the folder. The opened products will appear in Product Explorer window.

S2A_MSIL2A_20220730T135711_N0400_R067_T20HQJ_20220730T210856.SAFE.zip

S2A_MSIL2A_20220819T135721_N0400_R067_T20HQJ_20220819T211159.SAFE.zip

A: Detecting wildfires on Sentinel-2 image

1. Select the first product in the Product Explorer window.

2. Right click on the product.

3. Open RGB Image Window.

4. In the pop-up window select ‘Sentinel 2 MSI Natural colors (Red: B4;

Green: B3; Blue: B2)’.

5. Repeat the process for the second product.

6. Tile two opened RGB Windows, e.g. horizontally

7. In the Navigation window, zoom in to the wildfire region and

syhnchronise views to see the same area before and after wildfires

3



Fire + cloud plume map

Do the same process for obtaining the color composition in false colors:

1. Select the first product in the Product Explorer window.

2. Right click on the product.

3. Open RGB Image Window.

4. In the pop-up window select ‘Sentinel 2 MSI Atmospheric penetration

(Red: B12; Green: B11; Blue: B8A)’.

5. Apply color manipulation (stretching) for RGB

6. Repeat the process for the second product.

7. Tile opened RGB Windows, e.g. evenly

8. If necessary, in the Navigation window, zoom in again to the wildfire

region and syhnchronise views to see area before and after wildfires

Now let’s detect the smoke plume:

1. Keep only the Sentinel 2 MSI Atmospheric penetration composition

with visible smoke plume from 19 August open

2. Go to Mask Manager, and scroll down to the Maths masks

3. Select: “scl_cloud_medium_prob“ and “scl_cloud_high_proba“

4. To visualize the masked areas better, lower the transparency(e.g. 0.1)
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Let’s export this View as an image and safe as a GeoTIFF:

Because of multiple S2 spatial sizes, we first have to resample the data.

Resample to highest spatial resolution: 10 m (e.g. B2).

Raster->Geometric->Resampling:

• Keep I/O names

• In Resampling Parameters, select B2 (10 m)
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Let’s create a subset based on the current view

• Display the image. Note that now many more color options are

available. Select MSI Atmospheric penetration

• Make a zoom and add the cloud masks again

• Right-mouse button -> Spatial Subset from View – in the Band Subset

you can select all or only few bands to be exported
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Let’s reproject the image in Latitude & Longitude coordinates

• Raster->Geometric Operations->Reprojection

• Select the default: Geographic Lat/lon (WGS 84)

• Run (writing might take some time)

Now we can export View as GeoTiff

• Right mouse button: Export View as Image

• Select: Full scene, Full resolution, GeoTIFF
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Now we open the output image in QGIS

• We can overlay it to e.g. Google Satellite or Bing aerial image:

• Web->OpenLayers plugin->Google Maps->Google Satellite

• Move the Subset above the satellite

• Play with Transparency: Properties->Transparency (e.g. 80%)
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B: Burned area mapping with Sentinel-2

How to quantify the impact of the Paraná wildfire?

Let’s have look to the before & after images:

• Open RGB Image Window:

• Select: MSI Atmospheric penetration

• Window-> Tile horizontally, zoom in

Let’s create a cloud mask:

• Go to Mask Manager, and scroll down to the Maths masks

• Select: cloud medium & cloud high probability & Thin cirrus

• To visualize them better, lower the transparency (e.g. 0.1)

Now we make a cloud band based on the selected mask

• Band math expression
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We make a cloud band based on the selected mask

• Navigate to Raster - Band Maths

• Name the new mask: clouds

Adding the cloud mask as a band

• On the image, right click-> Band Maths

• Make sure to deactivate “Virtual”. We want to store the data!

• Go to “Edit Expression”

• Select Clouds

Repeat for the second image
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Vizualize all products

• Windows: Tile evenly

• Navigation: zoom all

Tools – Graph Builder

• Add->Raster->Geometric->Resample

• Add->Raster->Geometric->Subset

• Add->Raster->BandMaths

• Add->Raster->BandMerge

• Save your created graph
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Tools – Batch processing

This allows to process both images at the same time.

- Click on Add opened

- Load your graph

- Make sure to refresh
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Resample

• Select a reference band: B2 at 10 m.

• Resampling method: Bilinear

Subset

• Select bands: B3, B8, B12, Cloud_mask

• Select Geographic coordination

• Click on A, zoom in to the area of interest

• Select a yellow box within the red square
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Band Math

• Go to “Edit Expression”

• NBR: Normalized Burn Ratio:

(B8-B12)/(B8+B12)

Band merge

• Keep the source bands: NBR, B3, B8, B12, cloud_mask
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Running and visualizing the NBR band

Try a color table:

• Colour manipulation: Open color table, choose a color gradient, e.g.
„derived from meris_cloud“
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You can also set the position of sliders and color them for better
visualization or change ranges of values in the Table tab.

NBR ranges between -1 and 1. A high NBR value indicates healthy
vegetation. A low value indicates bare ground and recently burnt
areas. Non-burnt areas usually have values close to zero.

Burn severity - dNBR

The difference between the pre-fire and post-fire NBR obtained from the
images is used to calculate the delta NBR (dNBR or ∆NBR), which then can
be used to estimate the burn severity. A higher value of dNBR indicates
more severe damage, while areas with negative dNBR values may indicate
regrowth following a fire. The formula used to calculate dNBR is illustrated

below:

dNBR or ∆NBR = PrefireNBR – PostfireNBR

Go to Raster – Band Maths and Edit Expression
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Recently
burned
areas

Healthy
vegetation



Set the position of sliders and color them for better visualization or change
ranges of values in the Table tab.

NBR ranges between -1 and 1. A high NBR value indicates healthy
vegetation. A low value indicates bare ground and recently burnt

areas. Non-burnt areas usually have values close to zero.

dNBR values can vary from case to case, and so, if possible, interpretation
in specific instances should also be carried out through field assessment;
in order to obtain the best results. However, the United States Geological
Survey (USGS) proposed a classification table to interpret the burn

severity, which can be seen below in the table.
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High
Severity

Unburned



Comparison: Severity map, NDVI and false color composition

To compare different views of the same area and explore it more in detail,

create also NDVI and false color composition. You can observe, that areas
with high NDVI values correspond to the barren areas affected by
wildfires. False color composition also depicts areas affected by fire – these
areas are shown in dark pixels. False color composite B8-B4-B3 of the
Sentinel 2 image (during fire), with superimposed ongoing wildfire sites,

note that the smoke direction is corresponding to the wind direction.
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C: Burned area mapping using Sentinel-1

Load both Sentinel-1 products (pre-fire and post-fire) that you have in tjhe

folder for this exercise by navigating to File - Open Product.
S1A_IW_GRDH_1SDV_20220724T091506_20220724T091531_044240_0547C3_961B.SAFE

S1A_IW_GRDH_1SDV_20220829T091508_20220829T091533_044765_055873_EED3.SAFE

Visualize the input products – open e.g. Intensity_VH for both products by

double-click on it under the Bands folder.

1. Pre-processing

We need to apply identical pre-processing steps to both of our scenes:
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Create subset

There is no need to process the whole image, instead, we can begin by

narrowing down the scene to a more manageable size – creating subset.

This approach will decrease processing time in subsequent stages,

especially when the analysis is concentrated on a specific area rather than

the entire scene.

Select the first product and

Go to the Subset tab and at

“Geo Coordinates” set:

North latitude bound: -33.19

West longitude bound: -58.50

South latitude bound : -33.60

East longitude bound: -60.70

Repeat for the second image.



Thermal noise removal

Navigate to Main Menu – Radar – Radiometric – S-1 Thermal Noise Removal

In the I/O Parameters tab, select the last subset product with applied orbit

file and name the target product. There is no need to save the output as

BEAM-DIMAP (we will save the time this way)

In the Processing Parameters you can select both polarization and make

sure that the “Remove Thermal Noise” option is selected.

Repeat for the second subset image.
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Calibration

With our image now subsetted and with TNR, we must apply image

calibration. This step is necessary to normalize the values in the image into

backscatter values so we can compare multiple images in a time series.

Navigate to Main Menu – Radar – Radiometric – Calibrate

In the I/O Parameters tab, select the product with thermal noise removal

and name the target product. In the case of this final product of

preprocessing, please, save it to your folder for this exercise

In the Processing Parameters select both bands as input and accept all

default settings and then click Run

Repeat for the second image. The saving might take some time.



Speckle Filter

Despeckling removes thermal noise introduced by the sensor from the

image to remove potential sources of error in analysis.

Navigate to Radar > Speckle Filtering Single Product Speckle Filter. In the

Speckle-Filter tab, choose the simple Lee Sigma filter with default window

sizes.

Terrain-Correction

Our data are still in radar geometry, moreover due to topographical

variations of a scene and the tilt of the satellite sensor, the distances can

be distorted in the SAR images. We need to apply Terrain Correction to

compensate for the distortions and reproject the scene to geographic

projection.

Navigate to Main Menu: Radar - Geometric - Terrain Correction - Range-

Doppler Terrain Correction

• In the I/O Parameters tab set as “Source Product” the speckle-filtered

product.

• In “Target Product”, keep the default name and set the Directory

• In the Processing Parameters tab set:

• Digital Elevation Model: SRTM 3Sec (Auto Download)

• Keep defaults values for the other parameters. Click Run.

Approximate processing time: 2.5 minutes.
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Do not forget to save these two output terrain corrected products. We will

need them saved for the next step.

Create stack

Go to Radar > Coregistration > Stack Tools > Create Stack

In the Product-Set-Reader tab select the last three products from the

previous step.
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In the CreateStack tab, select Product Geolocation as Initial Offset Method

(Note: we did not use apply orbit file function, but the product geolocation

is accurate enough for the purpose of our analysis)

In the Write tab, adjust the stack name if needed, adjust the output folder

and click Run. This step will might take few minutes.

After the process is finished, we can see the new final „Stack“ product in

the Product Explorer window.

2 Display RGB time series

Now let´s have a look at some RGB composite of this time series

Right-click on the last „Stack“ product – Open RGB Image Window and

select different band combinations to see the change of backscatter signal

for different dates:
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Right-click on the last „Stack“

product – Open RGB Image

Window and select different band

combinations to see the change of

backscatter for different

acquisitions. For this, select :

Red: Sigma0_VH_slv_24Jul2022

Green:Sigma0_VV_slv2_24Jul2022

Blue: Sigma0_VH_mst_29Aug2022



Explore the final RGB composite to identify wildfires.
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THANK YOU FOR FOLLOWING THE EXERCISE!

Wildfires burn scars


