UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING

EXERCISE 5 - TUTORIAL

Crop Classification with S1 and S2 data using the
SNAP software
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1 | Exercise outline

In this exercise,we will:

e Use radar (Sentinel-1) and optical (Sentinel-2) data to dassify and
analyse different crop types and their health over an area

e Data pre-processing will be perfomed, an then the crop types will
be estimated by classification of the data, based on the Random
Forest algorithm

e Land crops growth and health will be observed using NDVI time
series
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2 | Background

Crop classification using Sentinel-1 and Sentinel-2 data

Crop classification using Sentinel-1 data relies on the radar backscatter
signals obtained from the satellite. The backscatter intensity, polarization,
and texture of the radar imagery are analyzed to distinguish between

different crop types.

Supervised classification methods involve training a classifier with labeled
samples of land cover types, while unsupervised methods group pixels
based on their spectral similarity without prior training. The accuracy of
the land cover classification is validated using ground truth data, and the
results can be refined iteratively to improve accuracy. The final land cover
maps provide valuable information for various applications, including

urban planning, agriculture, forestry, and environmental monitoring.
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2.1 Study area and data used

For this exercise, we will use Sentinel-1 and Sentinel-2 images to explore
fields in Kacik, near Gdansk and Baltic Sea coast northern Poland,
downloaded for year 2023 from the Dataspace Copernicus Open Access
Hub [@https://dataspace.copernicus.eu/].
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Images were acquired towards the beginning of July.

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open Sentinel-1 GRDH downloaded
products with HH and HV polarizations acquired on 11 July 2023 by double click on the
zipped folders. The opened products will appear in Product Explorer window:

S1A_IW_GRDH_1SDV_20230711T050035_20230711T050100_049371_05EFD9_7392.SAFE

Click + to expand the content of product, then expand Bands folder and double click on
Intensity_VV band to visualize it. Depending on your computer's capabilities, this
process could take some time. To minimize the data load, the next step involves
creating a subset that encompasses only a portion of the dataset. You can use
logaritmic scale to see the image better.
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3. Pre-processing

For classification purposes, three bands are utilized per acquisition: VV (or
HH for Sentinel-1), VH, and their ratio VV/VH (or HH/VH for PALSAR). Out
of the 13 bands per Sentinel-2 data acquisition, only the 10 with spatial
resolutions of 10 m or 20 m are utilized.

3.1 Sentinel-1 preprocessing

The Sentinel-1A data were obtained in IW mode and retrieved from the
ESA Scientific Data Hub at https://scihub.copernicus.eu/ in GRDH format.
These data require calibration (converting from Digital Numbers to Radar
Backscattering Coefficient s0) and orthorectification (transforming from
image geometry to a geographical projection) within a geographical
subset. Subsequently, a filter is applied to mitigate Speckle noise, which is
inherent in radar imagery.

Apply orbit file

Satellite positions are recorded using a Global Navigation Satellite System
(GNSS). To ensure the fast delivery of Sentinel-1 products, orbit details
produced by an onboard navigation system are included in the Sentinel-1
products. Subsequently, the Copernicus Precise Orbit Determination (POD)
Service further enhances the accuracy of the orbit positions.

Navigate to Main Menu - Radar - Apply orbit file

In the I/O Parameters tab, select the first product and name the target
product. There is no need to save the output as BEAM-DIMAP (we will save
the time this way)

In the Processing Parameters accept the default settings and select the
option Do not fail if new orbit file not found"

Note: If precise orbits are not yet available for your product, restituted
orbits can be selected which may not be as accurate as the Precise orbits
but will be betterthan the predicted orbits available within the product.

& Apply Orbit File X @ Apply Orbit File 4
File Help File Help

1/ Parameters  Processing Parameters IO Parameters Processing Parameters

SELEREIE Orbit State Vectors: | Sentinel Precise (Auto Download) v
Source;

Polynomial Degree:
[1] S1A_IW_GRDH_15DV_20230711T050035_20230711T050100_048371_05EFDS_7392  ~ | ...

Target Product
MName:
S1A_IW_GRDH_1SDV_20230711T050035_20230711T050100_049371_05EFD9_7392_Crb

BEAM-DIMAP

Directory:
C:\Wsers\Onadillova\s 1A_IW_SLC__15DV_202308_09_Orb_Stack_ifg_deb_dinsar_fit_ML

Open in SNAP

Run Close Run Close
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Speckie Filter

Despeckling removes thermal noise introduced by the sensor from the
image to remove potential sources of error in analysis.

Navigate to Radar > Speckle Filtering > Single Product Speckle Filter:

In the Processing Parameters tab, choose the Lee filter with default
window sizes and click Run.

Note: Selecting the size of the speckle filter depends on the targets (point
target, distributed target) and the target size (for example field sizes).

& Single Product Speckle Filter X @ Single Product Speckle Filte

File Help File Help

1f0 Parameters  processing Parameters 1/0 Parameters Processing Parameters

Source Product [Ampiitude_vH
source: Intensity_VH
[2] S1A_TW_GRDH_15DV_20230711T050035_20230711T050100_043371_05EFD9_7392 Orb ~ | ... \amplitude_vv
Source Bands: [rtensity WV
Target Product
Mame:
S1A_IW_GRDH_15DV_20230711T050035_20230711T050100_049371_05EFDS_7392_Orb_Spk
. Filter: Lee Sigma
[ Eave as? |[BEAM-DIMAR 2 -
------ Number of Looks: il ~
Directory:
— Window Size: 7 -
C:\Users\Onadillova\s 1A_IW_SLC_ 1SDV_202308_09_Orb_Stack_ifg_deb_dinsar_fit_ML
Sigma: 0.9 ~
Open in SNAP Target Window Size: | 33 ~
Run Close Run Close

Open the output of the Lee sigma filter and compare it with the image
before Speckle filtering. Filtered image looks sharpened and without noise
comparing with the image before applying Speckle filter.
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Calibration

S1 Level-1 products are not radiometrically corrected or calibrated, by
defaultl. Radar reflectivity is stored as Digital Numbers (DNs) in S1
products, and must be converted to physical units (radar backscatter).

Navigate to Main Menu - Radar - Radiometric — Calibrate

In the I/O Parameters tab, select the last filtered product and name the
target product.

In the Processing Parameters you can select one or both polarization and
accept all default settings and then click Run

& Calibration X & Calibration x
File Help File Help

[3] 51A_IW_GROH_15DY_202307117050035_20230711T050100_049371_0SEFD9_7392 Orb_Spk  ~ ||t

Target Product
MName:
S1A_IW_GROH_1SDV_20230711T050035_20230711T050100_049371_05EFDS_7392_Orb_Spk_Cal

[ save as: |BEAM-DIMAR ENVISAT Auxiliary File: Latest Auxiliary File
Directory: Save as complex output
C:\Users\Onadillova\51A_TW_SLC__15DV_202308_09_Orb_Stack_ifg_deb_dinsar_fit_ML Output sigma0 band
Open in SNAP [] Cutput gamma0 band
[] Cutput betad band

Terrain-Correction

The last step in our graph for image pre-processing is to apply terrain
correction to the product, ensuring that all the pixels are moved to the
right locations (eg if the nadir angle of the image is off, it will align the
pixels correctly so it is closer to a top-down view of the imagery).

Navigate to Main Menu: Radar - Geometric - Terrain Correction - Range-
Doppler Terrain Correction

In the I/O Parameters tab set as "“Source Product” the last calibrated
product.

In “Target Product”, keep the default name and set the Directory

In the Processing Parameters tab set:

Digital Elevation Model: SRTM 3Sec (Auto Download)

Map Projection: WGS84(DD)

Keep defaults values for the other parameters. Click Run. Approximate
processing time: 2.5 minutes.
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@ Range Doppler Terrain Correction X @ Range Doppler Terrain Correction
File Help File Help

1O Parameters  Processing Parameters 1/ Parameters Processing Parameters
Source Product

Source Bands: Sigmal_vH
Eule= Sigmal_vV
[4] 51A_IW_GRDH_1SDV_20230711T050035_20230711T050100_043371_0SEFDS_7392 Orb_Spk Cal | ...
Target Product
Name:
S1A_IW_GRDH_1SDV_20230711T050035_20230711T050100_043371_05EFDS_7392_Orb_Spk_Cal_TC

Digital Elevation Model:
[]save as: |BEAM-DIMAP

SRTM 35ec (Auto Download) ~
Frtes DEM Resampling Method: BILINEAR_[NTERPOLATION v
C:\Users\Onadilové\S1A_IW_SLC__1SDV_202308_09_Orb_Stack ifg_deb_dinsar_fit_ML M= e T R BILINEAR_INTERPOLATION ™
) Source GR Pixel Spacings (a2 xrg):  10.0(m) x 10.0(m)
Open in SNAP Pixel Spading (m): 10.0

Pixel Spacing (deg): 8.9831528411952156-5

Map Projection:

WGS84(DD)
Mask out areas without elevation Output complex data
Output bands for:
Selected source band [] DEM [ Latitude & Longitude

[ incidence andle from elipsoid [ ] Local incidence angle [ Projected local incidence andle

[] Layover Shadow Mask
[] Apply radiometric normalization
Save Sigma0 band Use projected local inddence angle from DEM
Save Gamma0 band Use projected local inddence angle from DEM

Save Betal band

fuxiliary File (ASAR only):

Latest Auxiliary File

Run Close Run Close

3.1 Create subset

There is no need to process the whole image, instead, we can begin by
narrowing down the scene to a more manageable size - creating subset.
This approach will decrease processing time in subsequent stages,

especially when the analysis is concentrated on a spedcific area rather than
the entire scene.

Go to the Subset tab and at B ooy oo o
“Geo Coordinates” set:

Spatial Subset Band Subset Metadata Subset

. Loading thumbnail i... X
North latitude bound: 54.00 faﬁngmu::nammage

West Iongltude bound: 18_75 Pixel Coordinates Geo Coordinates

_
. Morth latitude bound: 54.00 5
South latitude bound : 53.90 ——— —g
East |OngitUde bound : 18.88 South latitude bound: 53.901%
East longitude bound: 18.88 =

Note: There is no need to e =
wait till thumbnail image will Subsct scene 144.0

. Subset scene height: 1113.0
be created when entering

Source scene width: 49646
COO d . nates Source scene height: 21755
rdl .
[ Fix full width
Use Preview
[ Fix full height

Estimated, raw storage size: 12,3M

0K Cancel Help
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Visualize the output subset by double-click on VH and VV polarization.

[ [6] Sigma0_VH X

¥ O |E [6] sigma0_wW X o =)
- N  » - 3
-~ -%4 ~ o ’i;

Visualize the final subset image using RGB:

Go to Window > Open RGB Image Window (or right-click on the last
product in the Product Explorer and Open RGB window) and select the
band combinations for final RGB image: VH, VV, VV/VH.

[ [6] Dual Pol Ratio Sigma0 VW+VHRGE X l ¥ 3

»u .
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2.4 Image classification

We will perform a random forest dassification. For this we will create some
training data by identifying polygons containing the different crop/land
cover types:

- wheat

- maize

- Rapeseed

- barley

- grassland

- river

Select the last subset product by clicking on it. Navigate to Vector > New
Vector Data Container.

Create new data containers - separate for each type of ice mentioned above.
Start with creating the data container for, e.g. ,wheat".Click OK.

E Mew Vector Data Container >
Mame: wheat
Description:

oK Cancel Help

The newly created vector data container should appear under "Vector
Data" in the Product Explorer. Now let 's start creating training polygons for
these different containers onice type using the Polygon drawing tool:

i o= ™ o \ | = ) GCI CH D@ v:iviviy
SHDELIPIQ A WORL S IBELTE T 0L NVRD@: -
[Product Explorer x [ Pixelinfo | — | [ 6] Dual Pol Ratio Sigmad W+VHRGE X Polygon drawing tool
-8 [6] subset_2_of S1A_IW_GRDH_ISDV_20230711T050035_20230711T050100_049371 0SEFD9_7332_Orb_Spk. ~ | | B -
-2 Metadata . &. -

=-&3 Vector Data
B pins
ground_control_points
B wheat
=& Bands
B sigmao_vH
| B sigmao_w v|
| € >

Ateiqr prpoid

Jzbeuely sahe ([}

aBeuety fsel By

5689: 1 I 0°

Repeat this step and create training polygons forall remaining classes.
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\
-6 [6] subset_2_of S1A_IW_GRDH_1SDV_20230711T050035_20230711T050100_049371_0SEFD3_7392_Orb_Spk A
-3 Metadata
£+ Vector Data
@ pins
@\ ground_control_points
- E wheat
- E maize
i rapeseed
i ﬁ* barley

<

Navigation - [6] RGB X l Colour Manipulation - [6] Dual Pol Ratio Sigma0 VV+VH RGB | World View ‘

SRt
A

® vELLLL .

5689: 1 I 0° -

Wheat (red), maize (violet), rapeseed (light blue), barley (cyan), grassland
(green) and water (blue) training polygons. Save the final product with
your created vector data containers to your folder.

Random ForeSt Image Class'ﬁ Catlon E Random Forest Classifier
NaVIgate to RaSter > CIaSSIﬁ Catlon ProductSet-Reader Random-Forest-Classifier write
> Supervised dassification > | &=

(®) Train and apply dassifier |newClassifier

Ra n d O m FO re St CI ass |f| e r (O Load and apply dassifier |newClassifier X

(C) Train on Raster (@) Train on Vectors

*In the ProductSetReader tab select | =eusteceste
. Evaluate Feature Power Set O
the saved product with vyour _ _ o
.. Min Power Set Size: |2 Max Power Set Size: |7
t ra nin g d a ta . Mumber of training samples | 50pg
Mumber of trees: 10

*In the Random-Forest-Clasiffier
select the classes/training vectors | memnovectrs:
(all polygon vector containers) and
feature bands (select both
Sigma0_VH and Sigma0_W
polarisations) that you’d like to ————
include into image classification. Festure bands:

In the Write tab by default, the
output target is set to the same
directory and appends ,RF" to the
fllena me b &Save @ Help [> Run

«Click RUN.
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2.5 Post-processing

The final product should now appear in the ProductExplorer. Visualize this
output dassified image and dasses by double-click on the layer
,LabeledClasses" under Bands folderin the Product Explorer.

Navigate to Colour Maniulation tab to change the colours of individual crop
type classes and other ones and explore the frequency and distribution of
these classes through the classified image and table.

B [7] LabeledClasses K| ¥ O

iy

PP

Mavigation - [7] LabeledClazsses | Colour Manipulation - [7] LabeledClagses X

Label Colour Value Frequency Description
no data |_|-1 0.000%|no data
wheat | |0 17.4964%
maize ||—|\ 1 6.689%:
rapeseed B 0.453%
barley | |3 25.091%
grassland e 45.439%
river | |5 3.863%
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2.6 Crop types characteristics using spectral indices
Now, let “s explore also Sentinel-2 data for the same area.

+ Navigate to the Copernicus Browser website:

» https://browser.dataspace.copernicus.eu

+ Create the area of interest by using rectangle.

« For the best results, search for Sentinel-2 L2A products with low cloud
cover, e.g. less than 6%.

+ Set the time range from 01-04-2023 to 31-09-2023 to monitor crops
during the growth season. And click on Search.

‘ Opemicus EN Katarina Onadillova v £
BROWSER

VISUALIZE SEARCH

SEARCH CRITERIA:

Product name

DATA SOURCES:

SENTINEL-1 Filters =
SENTINEL-2 Filters =
MsI
L1c
L2A
® 6%

Auxiliary Data File

Immediate @
SENTINEL-3 Filters >
SENTINEL-5P Filters >
SENTINEL-6

TIME RANGE:

From:
< 2023-04-01 > nhoo $:-mmo $

Until;
<

2023-09-30

>

SPYY Leaflet | © OpenStreetiap contributors - Disclaimer, © Sentinel Hub

« Visualise at least one of the images - start e.g. from 10-04-2023 and
select, e.g. NDVI layer.

« At the top right panel select Histogram option.

« Explore NDVI values for the selected image.

Al (et

< 2023-04-10 > 30% n v A

Default v v f o D

Sentinel-2 L2A . * = X v S

RN R R AN Y K

LAYERS: E
£ o =
True color o~ 229
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False color
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o
| ® O

E

+Addto <> A

== Show effects and advanced options X Hide layer < Share

3 =
op & a Abo PpO
. Lat: 53.8306, Lng: 10.0544 3 km

[¥] Leaflet | © OpenStreetMap contributors - Disclaimer, © Sentinel Hub
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https://browser.dataspace.copernicus.eu/

Gpemicus EN v Katarina Onacillova v <
BROWSER -

VISUALIZE SEARCH

2023-04-10

Defauit v v
Sentinel-2 L2A i * = X v
LAYERS:

True color
Sased on bands B¢, 53, 52

False color
Based on bands B3, B4, B2

Highlight Optimized Natural Color
Enhanced natural color visuslizztion

Sentinel-2 L2A - NDVI

¢ NDVI
§ . Based on a combination of bands (B8 - B4...

Normalized Difference Vegetation
I € Index (NDVI)

+Addto <> A

The normalized difference vegetation index is a simple,
but effective index for quantifying green vegetation. It is
a measure of the state of vegetation health based on
how plants reflect light at certain wavelengths. The
value range of the NDVI is -1 to 1. Negative values of
NDVI (values approaching -1) correspond to water.
0 Values close to zero (-0.1to 0.1) generally comespond
-0.1 to barren areas of rock, sand, or snow. Low, positive
02 values represent shrub and grassiand (approximately
o5 02 1o 0.4), while high values indicate temperate and
W " toopical rainforests (values approaching 1)

Frequency

More info here and here.

= Show effects and advanced options R, Hide layer  «& Shar

&

[

l:’ (opermicus  @esa About  Support =1 o ) e
ositinty PP Leiet | © Openstrectifap contbutors - Dissamer & Sentnel b DU O e s e Lat 52,0210, Lng: 18,8985

Then, move to another date, e.g. 27-05-2023 and dick on ,Recalculate™ to
refresh the histogram values for this acquisition date. Explore the NDVI
values during the growth season by visualising histogram for NDVI values
of several dates.

Sentinel-2 L2A - NDVI 10-04-2023 x Sentinel-2 L2A - NDVI 12-05-2023 *

2000 f--obommbee oLl ' !
! 5000 |---b---b---boo-booboolooLooLooLo
1500 f---r---r---r---r 4000 C
& | z |
% 1000 |-+ r e § '
i L 2000 -
500 f---F---- [l e |
L 1000 - -+
0 - 0
046-032-018-004 010 024 038 052 066 080 093 0.14-0030.08 0.19 0.29 040 051 061 0.72 0.83 0.94
Value Value

Sentinel-2 L2A - NDVI 11-06-2023 X Sentinel-2 L2A - NDVI 12-09-2023 *

6000

6000 5000

& & 4000
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g g 3000
'R [T
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1000

0 0

-0.10 0.00 010 0.21 0.31 041 052 062 072 0.82 0.83 -0.31-0.18-0.06 0.06 0.19 0.31 043 0.56 0.68 081 0.93
Value Value
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During the growth season, NDVI (Normalized Difference Vegetation Index)
values typically exhibit fluctuations reflecting changes in vegetation
dynamics. At the beginning of the season (April), NDVI values may be
relatively low as vegetation starts to emerge and develop. As the season
progresses and vegetation becomes more abundant and healthier, NDVI
values tend to increase, reaching their peak during the peak of the growing
season when vegetation is at its fullest and most vibrant (May). This period
is characterized by high NDVI values, indicating dense and healthy
vegetation rich in chlorophyll and other nutrients. After reaching the peak,
NDVI values may start to decline as vegetation undergoes senescence or
experiences stress due to factors such as water scarcity or disease (June-
September). Monitoring NDVI values throughout the growth season
provides valuable insights into vegetation health, growth patterns, and
overall ecosystem dynamics.

THANKYOU FOR FOLLOWING THE EXERCISE!
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