UNIVERSITY COURSE EARTH OBSERVATION APPLICATIONS

EXERCISE 10 — TUTORIAL

Land surface temperature mapping using Sentinel-3
data using SNAP software
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1 | Exercise outline

In this exercise,we will:

learn about the phenomenon Urban Heat Island

use Sentinel-3 LST product to analyse and classify surface
temperature

use land cover / land use band for extraction of land temperature

extract the mean temperature by Pin placing tool and SNAP
Statistics tool

visualize the resulting Urban Heat Island map clipped on an
interesting area
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2 | Background

Urban heat islands are regions within cdties that encounter higher
temperatures compared to their surrounding areas. The presence of
structures like buildings and roads, along with limited greenery, causes
urbanized zones to absorb and release solar heat more efficiently than
natural landscapes. This concentration of structures in urban areas leads
to the formation of "islands" with higher temperatures, where daytime
temperatures can be 1-7°F higher and nighttime temperatures

approximately 2-5°F higher than those in the adjacent areas.

Urban areas, marked by high population and construction density, face
challenges related to waste heat and Urban Heat Islands (UHIs). As cities
expand vertically with skyscrapers, trapped heat from construction
accumulates within UHIs. During nighttime, UHIs retain higher
temperatures due to obstruction of upward heat movement by buildings

and infrastructure, creating a warmer environment.

Furthermore, UHIs exhibit worse air and water quality compared to rural
areas. The dense concentration of pollutants, originating from vehicles,

industry, and human activities, results in lower air quality.
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2.1 Study area and data used

In this exercise, we will analyse Sentinel-3B image acquired during June
2023 and downloaded from the Dataspace Copernicus Open Access Hub
[@https://dataspace.copernicus.eu/].

Navigate to the area of Slovak republic, create an area of interest by
clicking on the icon in the upper right corner of the map and draw a
rectangle as indicated below.

In the search menu on the left specify the following parameters and
press the search button:

Data source: Sentinel-3 - SLSTR - Level-2 LST

Sensing period: From 2023/06/20 to 2023/06/20
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Filter by months.
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Download the day product by clicking on the arrow icon. Note the
different sensing times of the images:

S3B_SL 2 LST__ 20230620T090758_20230620T091058_20230621T0
02041_0179_080_378_2160_PS2_O_NT_004.SEN3 (day acquisiton)

Once downloaded, move it to your folder for this exercise and unzip it.

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and navigate to the folder where
you saved your downloaded products and open the day-time Sentinel-3
product from 2023-06-20:

S3B_SL_2 LST___ 20230620T090758_20230620T091058_20230621T0
02041_0179_080_378_2160_PS2_O_NT_004.SEN3

Open the folder and select the file xfdumanifest.xml. Then, click OK.

In the Product Explorer, expand the product by clicking in the left arrow.
Expand now the Bands folder and double click on the band LST to

visualize it.
E [1] LST - S3B_SL_2_LST___20230620T090758_20230620T091058_20230621T002041_0179_080_378_2160_PS2_O_NT_004.SEN3 - C:\... = O X
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2.3. Subset

The initial phase of the methodology involves reducing the original size
and number of bands in the image. To accomplish this, choose the
Sentinel-3 SLSTR product in the Product Explorer, then proceed to Raster
-> Subset. Within the Spatial Subset tab, select Geo Coordinates and
input the specified values:

North latitude bound: 51.00
West longitude bound: 12.00
South latitude bound: 42.00
East longitude bound: 26.00

In the Band Subset tab, opt for the bands NDVI, biome, fraction, LST,
X_in, y_in, latitude_in, and longitude_in. In the Tie-Point Grid Subset
tab, choose only the bands x_tx, y_tx, latitude_tx, and longitude_tx.
Then, click OK (responding with No to the pop-up flag dataset window).

B spedify Product subset % B Specify Product Subset

Spatial Subset Band Subset Tie-Pont Grid Subset Metadata Subset
Spatial Subset Band Subset Tie-Point Grid Subset Metadata Subset

rl Mnown Gridoed Nomalized Difference Vegetation Indes al |
Ore Gridded Total Column Wa:
S‘ A siom dded de
Pixel Coordinates Geo Coordinates ‘ [ #raction Gridded fractional vegetation cover
North latitude bound: 51,002 Must Gnoded Land Surface Temperature
West longitude bound: 12.00}% [ LST_uncensinty Gridded Land Surface Temperature estimated fotal uncenainty
[] exception Gridded LST pixel exception flags
South latitude bound: 42,005 e i
East longitude bound: 26,005 =
- ] bayes_i
Scene step X: 155 S
= [ clow
Scene step Y: 15 _—
[Je=
Subset scene width: 1247.0 Clee
Subset scene height: 766.0 =
O dual_in  Probability of cloud in pixel (dual view
Source scene width: 1500 =
Source scene height: 1200 () d_single_in Probability of cioud in pixel (single view
O Surface elevation of cetector FOV centre above reference ellipzo
N Pl i i i i b
[JFix full height 7 jongitude_in Longitude of defector FOV centre on the eanth's surface "
< >
v
[Jselectal []Selectnone
Estimated, raw storage size: 101.6M
Estmated, raw storage size: 69.7M
Cancel Help Mox c e
E Specify Product Subset X

Spatial Subset Band Subset Tie-Point Grid Subset Metadata Subset

x_bx Geolocated x (across track) coordinate of detector FOV cenfre ™
y_be Geolocated y (along frack) coordinate of detector FOV centre
latitude_tx Latitude of detector FOV centre on the eanh's surface

Longitude of detector FOV cenire on the earth’s surface

D sat_azimuth_tn Satellite azimuth angle W

[ ]selectall [ ]Select none

Estimated, raw storage size: 22.7M

Cancel Help
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Upon completion, the subset product will be visible in the Product
Explorer. It is essential to save it by right-clicking on it and selecting
Save Product. Confirm the saving process by clicking YES in the ensuing
pop-up window.

2.4 Reprojection

Proceed to reproject the Sentinel-3 SLSTR product using an appropriate
map projection. Navigate to Raster -> Geometric -> Reprojection.

In the I/O Parameters tab, ensure that you choose the subset product as
the input. Modify the output name to e.g.
"S3B_LST_20230620_day_reprojected" and set/confirm that the output
directory.

Within the Reprojection Parameters tab, access the Projection drop-down
menu, and opt for UTM/WGS 84 (Automatic). Subsequently, click on Run.

E Reprojection X E Reprojection X

File Help

1/O Parameters Reprojection Parameters
Source Product
Name:
[2] subset_1_of S3B_SL_2_LST.

20230620T090758_20230620T09105... ~ | ...

Target Product

Name:

S3B_LST_20230620_day_reprojected

Save as:  BEAM-DIMAP v
Directory:

Z:\ESA_ENEUM\exercise_10

Open in SNAP

File Help

1/O Parameters Reprojection Parameters
Coordinate Reference System (CRS)

Geodetic datum: | World

Geodetic System 1984

Projection: Geographic Lat/Lon (WGS 84)

() Predefined CRS select

(O Use CRS of

Output Settings

Preserve resolution

Reproject tie-point grids

No-data value: NaN
[] Add delta lat/lon bands Resampling method: Nearest v
Output Information
Scene width: 1492 pixel Center longitude: 19°36'29"E
Scene height: 732 pixel Center latitude: 46°45'06" N
CRS: WGS84(DD) Show WKT
Run Close Close
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Within the Product Explorer, expand the reprojected product by selecting
the left arrow. Expand the Bands folder, and double-click on the LST band
to view it.

Access the Colour Manipulation tab, choose Basic as the Editor, and click
on the e.g. ,derived from spectrum_large™ color ramp

Product Explorer X | Pixel Info — || [3LsT X \ =]
58 [3] S38_LST_20230620_day_reprojected A ||
[0 Metadata
(2 Index Codings
C] Flag Codings
G Vector Data
&3 Bands
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@ st v
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>
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[[] Load exact values Reverse

Range
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< >

-Y - Lat -—-Llon - Zoom -- Level - Pixel Spacing: --m —-m 2

2.5 Clip by mask

Now let’s focus on the smaller area of interest, e.g. territory of the
Slovak Republic. Choose the last Sentinel-3 reprojected product in the
Product Explorer, then proceed to File — Import - Vector data - ESRI
shapefile and open ,SR_boundaries.shp" file that you have in the folder
for this exercise. Once imported, this layer should appear within the
product Vector data and also on the visualized LST image.
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|55 [3]1538_LST_20230620_day_reprojected A
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Now navigate to Raster - Masks - Land/Sea Mask. In the I/O Parameters
tab you <can rename the output target product to e.q.
"S3B_LST_20230620_day_reprojected_msk" and set the output
directory. In the Processing Parameters select the option ,Use Vector as
Mask™ and ,,SR_boundaries" layer according to which the product will be

clipped.
& Land/Sea Mask x & Land/Sea Mask X
File Help File Help

1/0 Parameters  Processing Parameters IO Parameters Processing Parameters

Source Product

Source Bands: [nDVI =
source: biome
[3] S3B_LST_20230620_day_reprojected LV | fraction
LST
x_in
Target Product v in
Name: latitude_in
S3B_LST_20230620_day_reprojected_msk longitude_in v
Save as: BEAM-DIMAP v (O Mask out the Land
Directory: (C) Mask out the Sea
Z:\ESA_ENEUM\exercise_10 Use SRTM 3sec
Open in SNAP (®) Use Vector as Mask
SR, boundaries v
[] Invert Vector

Extend shoreline by [pixels]:

Close Close

The resulted clipped product of the area of the Slovak Republic can be
reprojected to lacal coordinate system using an appropriate map
projection. Navigate to Raster -> Geometric -> Reprojection.

Product Explorer X | Pixel Info — ||@ st x v O
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« In the I/O Parameters tab, ensure that you choose the last clipped
product as the input. Modify the output name to e.g.
"S3B_LST_20230620_day_reprojected_msk_Krovak" and set/confirm
that the output directory.

« Within the Reprojection Parameters, access the Projection drop-down
menu, and opt for Custom CRS - Krovak. Subsequently, click on Run.

« Within the Product Explorer, expand the final reprojected product by
selecting the left arrow. Expand the Bands folder, and double-click on
the LST band to view it. Access the Colour Manipulation tab, and
choose e.g. ,derived from spectrum_large" color ramp

B Reprojection X [ Reprojection X
File Help File Help
1/O Parameters  Reprojection Parameters 1/O Parameters Reprojection Parameters

Source Product Coordinate Reference System (CRS)

Name: (@) Custom CRS
[4] S3B_LST_20230620_day_reprojected_msk || vue
Geodetic datum:  World Geodetic System 1984 v
Target Product Praojection: Krovak v
Name: Projection Parameters...
S3B_LST_20230620_day_reprojected_msk_Krovak
() Predefined CRS Select
Save as: BEAM-DIMAP v
(O Use CRS of _LST_20230620_day_reprojected
Directory:
Z:\ESA_ENEUM\exercise_10 e Output Settings
Open in SNAP Preserve resolution Reproject tie-point grids
Parameters.. . No-data value: NaM
[] Add delta lat/flon bands Resampling method: | Nearest v
Output Information
Scene width: 1493 pixel Center longitude: 19°55'10E
Scene height: 1072 pixel Center latitude: 46°29'35"N
CRS: Krovak [ World Geodetic System 1984 Show WKT
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Explore the temperatures (in Kelvins). Click on the Pixel info tab and
move the mouse over the images to analyse pixel values.

Product Explorer Pixel Info X —

—| Position ~
Image-X 1171 pixel
Image-Y ' 787 plxel
Longitude ' 21°17'54" E degree
Latitude ' 43°43'35" N'degree
Map-X [-259950.¢02...|m
Map-Y [-1235131.51. . .|m
[+ Time
—| Bands
LST 270.01401K | v

2.6 Add Land Cover Band

After comparing the temperature values (in Kelvin) during the day and
night acquisitions, proceed to close the day product. In order to better
identify the influence of urbanised areas on temperature, subtract the
average temperature of non-urban areas near Kosice.

To facilitate this, create smaller subset of day image - zoom into the
vicinity of the KoSice city, estern Slovakia - right click on the view -
Spatial Subset from View... OK.

Then, open the LST layer from Bands of newly created subset and add a
land cover band to distinguish various land cover and land use types. To
do this, right-click on the day product, choose "Add Land Cover Band,"
navigate to CCILandCover-2015 in the menu, and click OK.

Product Explorer X | — |[@@ 1T x| e g
. - 7
#-(Z3 Flag Codings A ‘ i 1 i i ' "
+#-(C3 Vector Data n ' B Tl -‘ - ' B
- ® - l =
-}-{Z Bands : . 2
B nov o ! - ‘ = ' . %
Ed biome Y .
B fraction L -:J‘ ’L » .'u ‘ .
e - Geomet from WKT
n LST v - ll. J ry
, —— - ui
X | Colou... Uncer..._ Layer... FWOrld...; -—
1
Q B Export Mask Pixels
Q g ! Export View as Google Earth KMZ
Q _ S Export View as Image
Export Colour Palette as File
% . ‘ Export Colour Legend as Image
Rﬂ Spatial Subset from View...
Copy Pixel-Info to Clipboard
1:266.36 I 0 = @ . W
Zoom — Level —- Pixel Spacing: --m --m 3
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E [6] LST - subset_1_of S3B_LST 20230620_day_reprojected_msk_reprojected - not saved - SNAP — O X

File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help Q- Search (Ctrl+1)
[ ¥ GCP oo-a GCP N S
aG oNniEaASe XEroasaNvRYeR: \ IEHEAD
Product Explorer x| = B [e)LsT x ¥ O [ [6) land_cover_CCILandCover-2015... ¥ O =
i n longitude _in A " i g
[l x_tx %
i n y_bx §
B latitude_tx a
B longitude_tx B
Ed land_cover_CClLandCover-2015 , | |+
< >
X:Colo... Unc... :Laye... Worl...: —:
- Zoom — Level —- Pixel Spacing: —m —-m 2

2.7 Mean temperature

After adding the land cover band, the subsequent action involves
calculating the average temperature in the vicinity of KoSice city by
utilizing specific pixel values pinpointed with the Pin tool in SNAP. The
ideal quantity is around 10 control points. Using these control points, it
becomes feasible to calculate an average temperature value.

o eniEate g 0ARI Y

After creating the pins in the image, we can calculate the average value
for the pixels identified by these pins using the Statistics tool in SNAP.
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Close the land cover visualization and navigate to the Analysis ->
Statistics. Choose the option ,Use ROI Mask(s)" and select "pins." Lastly,
click the refresh button.

From the panel on the right side, we can obtain the mean temperature
value (304.2688) for day image by referencing the pins recently inserted
into our image.

Statistics X

LST with ROI-mask pins
#Pixels total: |10
Minimum: |297.4620 | 1.04 300 1
Maximum:  |311,5580 | 0.91
Mean: |304.2688 0.81
Sigma: [3.7730 | 0.7
Median: [304.2140 | N
Coef Variation: 0.0235
ENL: |1806.2072
P75 threshold: [306.2575 | W 0.4
P80 threshold: [306.2579 | 0.3
P85 threshold: 306.6808 0.2
P30 threshold: [306.6808 | -
Max error: [0.0141

X

Use ROI mask(s):

Filter:

B
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[(]sR_boundaries
. 200 ¥ pins
0.61

Pixels

0.51

150 1

Value Threshold

100
Histogram accuracy
Auto accuracy

w

0.11
0.0 - - 0 . -
200 305 310 0 25 r| ) 75 100

Value Percentile (9/)

i3 (2)

We can proceed to utilize the Band Math operator to subtract this value
from the LST measurements. Right-click on the LST_20180802_night
product, choose Band Math, modify the name to UHI_night, uncheck
Virtual, and dick the Edit Expression button. Copy and paste the
provided expression, then click OK:

E Band Maths X

Target product:

[6] subset_1_of_S3B_LST_20230620_day_reprojected_msk_reprojected v

Name: UHI_day_20230620

Description:

Unit:

Spectral wavelength: 0.0

[] virtual (save expression only, don't store data)
Replace NaN and infinity results by NaN
Generate assodated uncertainty band

Band maths expression:
LST-304.3

Load... Save... Edit Expression...

OK Cancel Help
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Close all previous visualizations except for the recently generated
UHI_day_20230620band. Navigate to the Colour Manipulation tab,
choose Basic as the editor, and select the palette. Then, click on the tab
From Data to see the range of the final night UHI. Adjust the Min and
Max values to ranges from 0 to the last value of the dataset (in this case

Product Explorer X — || [8] uHI_day_20230620 X YO g
¥-& [4] $38_LST_20230620_day_reprojected_msk ~ _g
¥-& [5] 53B_LST_20230620_day_reprojected_msk_reprojected ]
- =
+-&= [6] subset_1_of S3B_LST_20230620_day_reprojected_msk Vv =
L
Navigati...  Colo... X | Uncerta... | Layer E... | World ... — 8
Editor: (@) Basic () Sliders () Table @
Scheme Logyg
- none — v

gy

Palette
derived from spectrum_large
__ '
[] Load exact values Reverse
Range
Min: -21,70997¢ Max:| 3.5120057
From Palette From Data
# More Options @
Lon - Zoom - Level - Pixel Spacing: --m --m 2
Product Explorer X — || B8 [6] UHI_day_20230620 X Yo g
+-88 [4] S3B_LST_20230620_day_reprojected_msk ~ &
N -
+-& [5] S3B_LST_20230620_day_reprojected_msk_reprojected ]
+-65 [6] subset_1_of S3B_LST_20230620_day_reprojected_msk “ §
[
Navigati... | Colo... X | Uncerta... | Layer E... | World ... — ‘8
Editor: (®) Basic () Sliders () Table @
Scheme Logyg
-- none - v @l
Palette l[i
derived from spectrum_large ir 3
| T __ 1|
[] Load exact values Reverse
Range
Min: 0.0 Max: 4.0
From Palette From Data
* More Options @
Lon - Zoom - Level —- Pixel Spacing: —m —m D
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2.8 Data export to QGIS

Once the result is ready, we will export it as GeoTIFF and open it in
QGIS. For that, data must be again reprojected to Geographic Lat/Lon.
Then, go to File -> Export -> GeoTIFF. Click on the Subset tab, and in
the Band Subset menu select only the band UHI_day_20230620. Save
the file with the name UHI_night_20230620.tif in the following path and
click Export Product:

B specify Product Subset X

Spatial Subset Band Subset Metadata Subset

] fraction Gridded fractional vegetation cover

~
[:l LST Gridded Land Surface Temperature
D x_in Geolocated x (acrose track) coordinate of detector FOV centre
|:] y_in Geolocated y (along track) coordinate of detector FOV centre
D latitude_in Latitude of detector FOV centre on the earth's surface
[:l longitude_in Longitude of detector FOV centre on the earth's surface
[Jxtx Geolocated x (across track) coordinate of detector FOV centre
D y_tx Geolocated y (along track) coordinate of detector FOV centre
D Iatitude_tx Latitude of detector FOV centre on the earth’s surface
D longitude_tx Longitude of detector FOV centre on the earth’s surface
D land_cover_CClLandCover-2015 CCiLandCover-2015
[[] 1and_cover_cCiLandCover-2015_2 CCiLandCover-2015
v

[Jselectall []Select none

Estimated, raw storage size: 0.0M

Cancel Help

Data import to QGIS
Once the images are processed in SNAP, we will visualize the results in
QGIS. Minimize SNAP and open QGIS.

Import the subset_UHI_day_ 202306 into the panel Layers

Edit image parameters of subset_UHI_night_202306 - Navigate to
Properties of this image and change the color palette. Set the Min/Max
values for the night UHI similar like in the SNAP (0-12).

¥ Vykresl'ovanie pasma -
Typ vykreslovada |Jednopdsmovy pseudofarebny ~
Kanal Kanal 1 (Gray) hd
Min 0 Max 4
» Nastavenie min. / max. hodnoty
Interpolacia Linedrne A

Farebn Skéla L - -

Pripona Stitkovej jednotky

Presnost’ oznacovania 4 b
Hodnota Farba Popis =
O .
— Y4
Syl - OK Cancel Apply Help
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Now navigate to Web - OpenlLayers plugin - Bing maps and add e.q.
Bing aerial with labels. Place the layer UHI_day_20230620 above the
layer of Bing map. Set transparency to the UHI_day_ 20230620 layer
(Properties - Transparency).

Finally, explore the Urban Heat Island in the vicinity of KoSice city and
land use/cover that affects it.
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THANK YOU FOR FOLLOWING THE EXERCISE!
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