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Flood Detection - Spain 2018

Floods account for 40% OF ALL NATURAL DISASTERS WORLDWIDE

Bangladesh
Heavy rain began falling over the
weekend (09 to 10 June, 2018). Cox’s
Bazar has recorded over 300 mm of rain
in 48 hours to 12 June.

More than 13,000 were affected g
by the flooding from the Xe Pian 4
Xe Namnoy dam collapse (
southwestern Laos’ Champassak
province).



Flood Detection - Spain 2018

Floods account for 40% OF ALL NATURAL DISASTERS WORLDWIDE

Catastrophicfloods cause human tragedy, endanger lives and bring heavy economiclosses.

B 5 T

Rivercatchiments affcted by foodeg \ In addition to economic and social

damage, floods can have severe
environmental consequences, for
example when installations holding
large quantities of toxic chemicals are
inundated.

The coming decades are likely to see a
higher flood risk in Europe and greater
economic damage.

Some areas have been more affected
than others.

Between 1998 and 2005 north-western
Romania, south-eastern France, central
and southern Germany, northern Italy,
and eastern England experienced the
highest concentration of repeated

Flood event in April around Zaragoza from April 17th to 19th, 2018,
flooding. due to Ebro river swelling from heavy rain during the previous
weekend.

Credit by https://www.eea.europa.eu/themes/water/water-resources/floods




Active Microwave Remote Sensing (SAR)

Advantage: Day and night measurement (active sensor) in all weather conditions

Previous drawbacks: Expensive imaging, long revisit time

Sentinel 1A/B Copernicus: Free Images (SciHub), short revisit time (6 days over Europe)
(game changer)

Sentinel-1 Constellation Observation Scenario: ‘@m sentinel-1
Revisit & Coverage Frequency

validity start: 10/2016
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E WY Y Y E ?2 gays E : ihotrt I?row.th cyci:, ir:jtensive agriculture
ays ast changing wetlands
* coverage ensured from same, repetitive relative orbits E 4 E * Fast movi?lg iuﬂet glaciers
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Active Microwave Remote Sensing (SAR)

volume scattering Roughness is a relative parameter...

corner reflection
Double-bounce reflection (Ray/EIgh)

h< 8-cosf h:surf mean height variation A: wavelength,
©: incidence angle

sub-surface
scattering
surface

scattering specular reflection

Wind condition can increase the roughness over
water and hence increase SAR backscattering

Dry Soil: Some of the incident radar energy is able to
penetrate into the soil surface, resulting in less
L3 backscattered intensity.

Wet Soil: The large difference in electrical properties
between water and air results in higher backscattered
\ radar intensity.

4

Flooded Soil: Radar is specularly reflected off the
water surface, resulting in low backscattered

ity. The flooded area s dark in the SAR
image.

PP

Courtesy of PTrivero, W. Biamino,“Observing Marine Pollution
with Synthetic Aperture Radar,” 10.5772/9106




S1 data over Xe Pian Xe Namnoy area (Laos)
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PART | : Data Search and Download

Activate Filter panel, select GRD in Product Type options for Sentinel 1
and timespan between April 1stto 13th, 2018.

# Advanced Search Clear  «
»Sort By: Ingestion Date v
e By Descending v
» Sensing period From: |2018/04/01 z= to- [2013109n3 =
» Ingestion period From: = to: =
© Mission: Sentinel-1
Satellite Platform Product Type
| 7] [oeo 7]
Poiarisation Sensor Mode
| || :
Relative Crbit Number (from 1 to 175) Collection

| ]
O  Mission: Sentinel-2
Satellite Platform Product Type

'| | '|

Relative Orbit Number (from 1 to 143) Cloud Cover % (e.9.[0 TO 9.4])

Insert search critena B g

Display 1 to 25 of 94 products. selectAll O <

Order By: Ingestion Date ¥

Request Done: ( footprint."Intersects(POLYGON((-1.5527188143235686
41.625010978820114,-0.9816038481355931
41.625010978820114.-0.9816038481355931

S1A_IW_GRDH_1SDV_20180904T175459_20180904T175524_023552_0290...

Download URL" https#/scihub. 1/Products( beat
Mission: Sentine-1 instrument: SAR-C Sensing Date: 2018-09-04T17:54:59.684Z &

[EE® s18_1W_GROH_1SDV_201800037180229_20180003T180254_012554 01729...
Downioad URL® https://scihub.copemicy roducts('1040cedf-4a34
Mission: Sentinel-1 Instrument: SAR-C Sensing Date: 2016-09-03T18:02:29.118Z £

ISTN LGRS s14_(W_GROH_1SDV_201809037060925_20180903T060950_023530_028F...

Downfoad URL' https-//sciub.
Mission: Sentinel-1 Instrument: SAR-C- Sensing Date: 2016-09-03706:09:25.465Z &

1/Producis(602da973-479!

4 $1B_IW_GRDH_1SDV_20180902T061649_20180902T061714_012532_0171E...

Downioad URL: https//sciiub. Products('951332b2-c40:
Mission: Sentinel-1 Instrument: SAR-C Sensing Date: 2016-09-02706:16:49.356Z &

IS 5 18 _1W_GROH_1SDV_20180829T175431_20180829T175456_012481_01704...
- Download URL: https/5cihub coperni Products| ol v

Products per page:[25 v | <= < page:lzlom > 5>

W close

Expected results

S Xixon

‘Alacant/Alicante
§ X! 7




PART | : Data Search and Download

Different footprint covering the AOI (partial of total coverages).
Find the 4 Orbits

S1B_IW_GRDH_1SDV_20180903T180229_20180903T180254_012554_01729...
= Downioad URL: https#/scihub.copemicus.eu/dhus/odataN 1/Products{’1040ce4f-4334
Mission: Sentinel-1 Instrument: SAR-C Sensing Date: 2018-09-03T1

8:0229.1167 <
€ ¢ ©

S1A_IW_GRDH_1SDV_20180903T060925_20180903T060950_[ ¥ P dar: Detals

S1B_W_GRDH_1SDV. 20180903T180229_20180903T180254_012554 017233 6826

V¥ Summary

A Product
Acquisition Type: NOMINAL

Cycle number: 78

Fomat: SAFE may be usefu
Ingestion Date: 2018-09-0:

JTS footprint: POLYG
40572338 -3 5618:

Mission datatake

Orbit number stop]: 12554

Pass direction: ASCENDING
Phase identifier: 1

Polarisation: VV VH

Product class: S

Product class description: SAR Standard L1 Product
Product composition: Sice

Product levek: L1

Product type: GRD



PART | : Data Search and Download

For this exercise, we will use 2 acquisition of the orbit 8, corresponding to April 6thand 18th, 2018.
The data (in zip format) have been already downloaded in the folder

Orbit 8

Display 1 to 3 of 3 products. selectAll O
Order By: Ingestion Date ¥

Request Done: ( footprint"Intersects(POLYGON((-1.6598028704835124
41.671687692735304.-1.070840561602459 41.671687692735304,-1.070840561602453
42.149826896904045,-1. 6598028704838124 42.149826896904045.-1.6598028704838124

pATAARTAAATAT A~ L - B R

¥ol S1B_IW_GRDH_1SDV_20180418T060820_20180418T060854_010534_013356_CT7A

- Download URL: hitps//scihub.copemicus.eu/dhus/odatalv t/FProducts(7ca3a6c0-8630-4558-9986-20a70bb884ee 1/3vi '—

Mission: Sentinel-1 [nstrument: SAR-C Sensing Date' 2048-04-16T706:08:29.786Z Size. 1.65GB

S1A_IW_GRDH_1SDV_20180412T060917_20180412T060042_021430_024E63_3BD5
Download URL: https+/scihub.copemicus.eu/dhusiodataiv/Products(c84c9273-597 3-45f3-a483-19b0783ded3)/Svalu
Mission: Sentinel-1 Instrument: SAR-C Sensing Date 2048-04-12T706:09:17 356Z Size. 1.65 G8

$1B_IW_GRDH_1SDV_20180406T060829_20180406T060854_010359_012DC0_D47D l

Download URL: https#scihub.copernicus eu/dhus/odata 1/Products{'61963112-9360-4b81-5187-ccdcf06353a0)/8val
Mission: Sentinel-1 Instrument: SAR-C Sensing Date. 2018-04-06T06:08:29.651Z Size: 1.65 GB

Products perpage: |25 v page:| 1 of1 P CLOSE



PART Il : Data Navigation and Preprocess

Open SNAP and EXPLORE data: load the images corresponding to Orbit Number 8 within the folder
../PECS_Slovakia/flood/extra_case_study/S1

S1B_IW_GRDH_1SDV_20180406T060829 20180406T060854 010359 012DCO_D47D
S1B_IW_GRDH_1SDV_20180418T060829 20180418T060854 010534 013356 _C77A

9 (1] Amplitude_VV - S1B_IW_GRDH_1SDV_20180406T060829_20180406T050854_010359_012DCO_D47D - C:\Users\1\Downloads\Flooding_Zaragoza\S1\RelativeOrbit_8\ZIP\S1B_IW_GRDH_1SDV_20180406T060829_20180406T060854_010359_012DC0_DA7D.zip - SNAP = o X

File Edit View Analysis Layer Vector Rester Opticol Radar Tools Window Help
laB InBELeR TER rpAANNYRYER 2 \ MEED

1] Amplitude VW X |

v O [ [ Ampltude W X|

|| Product Explorer X | Pixellnfo | -
|[-8 1] 518_1W_GRDH_1SDV_20180406T060829_20180406T060854_0103¢
(] Metadata
i@ Vector Data
(3] Tie-Point Grids
i@ Quicklooks
£-& Bands
H Ampitude_VH
[ Intensity_VH
B Ampitude_W
[ intensity_w
=& [2)518_IW_GRDH_15DV_20180418T060829_20180418T060854_0105
- Metadata
(@ Vector Data
(] Tie-Point Grids
@ Quickiooks
=& Bands
[ Ampitude_VH
[ Intensity_VH
@ Ampitude_W

Prpoid @

A

webeuely saheq ([

Click + to expand contents
of the layers in Product
Explorer and double click
on Amplitude_VV

sebeuelyisem By

Downloading

X =Y - lat -Llon - Zoom - Level -



PART Il : Data Navigation and Preprocess

Theory pill Sentinel 1 : two pol (VV and VH)
\ Higher return from vegetation
Hiigher return from vertical structure, or surface or (volumetric scattering)

double-bouncetarget -

Lower return from
flooded as well as
flat areas. High

false-positive rate




PART Il : Data Navigation and Preprocess

Despite the name ground or GRD images are not geocoded, but they are images define in a regular grid of the radar
space observation:

Level-1 Ground Range Detected (GRD) products consist of focused SAR data that has been detected, multi-looked and

projected to ground range using an Earth ellipsoid model. Phase information is lost. For more info :
https://sentinel.esa.int/web/sentinel/missions/sentinel- 1/data-products

RAMNGE sampling

I"..i-u
J Topography

Ellipsoid —T S s

GRD sampling



PART Il : Data Navigation and Preprocess

GRD Images
projected onto
reference elipsoide
(no topography)

|
i
i

Terrain Correction Project
data from elipsoide to
geographical coordinated
take into account DEM



PART Il : Data Navigation and Preprocess

Despite the name ground or GRD images are not geocoded, but they are images define in a regular grid of the radar space observation:

Level-1 Ground Range Detected (GRD) products consist of focused SAR data that has been detected, multi-looked and projected to
ground range using an Earth ellipsoid model. Phase information is lost. For more info :

https://sentinel.esa.int/web/sentinel/missions/sentinel- 1/data-products
To convert GRD into geocoded information suited to flood detection, we need to perform some preprocessing steps.

As they must be applied to a collection of GRD images, we use to define a general pre- processing graph

I

AR OBEACENETEH rOAANNVERIOR Z
To be later passed to the Batch Processing Tool

aB SRBLATEeRNERrOQAACNVEOORE

i



PART Il : Data Navigation and Preprocess

GraphBuilder ;ﬁﬂc

[ BTy e

|ld-| gt

Start adding blocks

AOI Subset Definition (Add->Raster->Geometric-> Subset)

Apply precise Orbit file (Add -> Radar -> Apply-Orbit-File)

Remove the Thermal Noise (Add->Radar->Radiometric-
>ThermalNoiseRemoval)

Data Absolute Calibration (Add -> Radar -> Radiometric -
> Calibration)

speckle filtering (Radar -> Speckle Filtering -> Speckle-
Filter

Terrain Correction filtering (Radar -> Geometric ->
Terrain Correction -> Terrain-Correction)



PART Il : Data Navigation and Preprocess

" Read || subset | s/apply-orbit-File : ThermalloiseRemoval

Calibration }—a{s’edde-ﬂltu H Terrain-Corraction H Write J

In the Terrain-Correction tab set Map Projection -> Predefined CRS: AUTO: 42001 — WGS 84 /
Auto UTM. Leave all the other default settings.

In the Speckle-Filter tab, choose the simple Lee Sigma filter with window size of 7x7 pixels In the

Subset tab set the extent of the AOI in pixel coordinates to:

X:0 Y:10000 Sceneend X:26000 SceneendY: 16690



PART Ill : Image Analysis and Water Mask Generation

Binarization: Water/Non-water separation by defining a suited threshold for each image.

Open all two (preprocessed) products [3-4] in the View and then go to Window ->
o Tile Evenly

Select the Sigma0_VV band corresponding to April 18t capture to activate it
0

¢ Select the Color Manipulation tab and click the Stretch Histogram Horizontally @s and then
the logarithmic display g

¢ Move the max, middle and minimum sliders around 0.023,0.015 and 0.009 on the histogram.

ey,
< ar A "‘1".'\;

o }.1



PART Ill : Image Analysis and Water Mask Generation

A binary mask of water and non-water pixels with a thresholding condition.

Define a Waterbody Region of Interest (ROI)

s Define a new ROI (Vector->New Vector Data Container)

W 121 Sigmal WY - [S18_1W_GRDH_5SDV_20180405T0SCE25 201 BOS06T 06065
File [kt View Ansiysis Layer Vector Raster Optical Rader Tooks Wind

a$ %, n s .* New Vector Data Contairer £y

- . e

o Define ROI name (f.i. Water_ROI_Polygon_1) and description (optional)

i' New Vector Data Container X

Nare Weser R01_Polygon|
Descrpbon:

(o] o || o

¢ Define Tool for ROI construction (Polygons Drawing Tool) 9



PART Ill : Image Analysis and Water Mask Generation

¢ Draw polygon and doble-click to close it
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» Highlight Sigma0_VV layer (where ROl is defined), then go to Analysis->Statistics,
select Use Roi Mask and Water_ROI_Polygon.

Sl WY b I mah Winherbedy Sats rel o
ot i 2O N x
e AN o &3 L JH marich
Vareis

e S %

o
<
Cont' bt 0. 485

2

#7 Sewne © x4
Y
P vt £ e
o tvwree ©
Mas v 1w

ek

Vaw NMresdwkd

Ve Percertie (%)
@ 0

¢ Find value for Percentile 99 (move the mouse on the image to get values...)



PART IV : Results Visualization

The final result appears like this

g QGIS 2.18.23 G %
Project Edit View Layer Settings Plugins Vector Raster Proc Help

[Inl= lﬁﬂ&ﬁz r@@ﬁa@ﬂpp}amﬂ.ﬁﬂ%0'%332-8,.'%:ﬁ2@"§i'|ﬂ ===
1# /B %5 sRa~00]=~0@E~sns=[e]e

Sl Brwserhnel

AETRET |
' 4 § Home
; } Favourites
&0/
3 DB2
R +| 5 wssoL
- @ PostGIS
@' i/ SpatiaLite

@ i@ ArcGisFeatureServer
- @ ArcGisMapServer

@, ") ows
i@ Tile Server (XYZ)

,ﬂ 4% WFS
m @ wMs
wid
—
Layers Panel & x

JEVTE-RARO |
B9 4 Sentinel 1

I V] WaterMask S1B IW GRDH 1SDV 20180406T060829...
# V] @' WaterMask S1B_IW_GRDH_1SDV_20180418T060829...

. : . l(

Coordinate [ -0,6387.41.5839 W5 Scale[1:36148  v| g Magnifier[100% = Rotation [0.0 jrmw © EPSG:4326 Q
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