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INFORMATION

SeaMonkey is a free and open source cross-platform Internet suite. SeaMonkey consists of a
web browser, HTML editor (SeaMonkey Composer), and an IRC client (ChatZilla). The SeaMonkey
Composer is a WYSIWG (What You See Is What You Get) HTML editor which enables people who have

little or no prior knowledge of the HTML language to create web pages.

You will need your NEIU NetID and password to upload your web page to ftp.neiu.edu. There is
a step by step tutorial on how to find your NetID and create a password on the SCS Tutorial page. If you
have problems with your NEIU NetID please contact the HELPDESK (x4357) or visit the SCS computer

labs for assistance.

Please refer to SCS’s site (http://neiu.edu/~scs/Downloads.html) to download software.
Student Computing Services provides links to 3rd-party software for your convenience. Student
Computing Services is not responsible for maintaining the software and makes no claims or guarantees
for the software. Computer users are responsible for following the software licensing agreements and

restrictions specific to the software.
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VOCABULARY

Browser..........ccccceeeenneen. A program used to view web pages on the internet
Download ...................... Move a file from a server to your local computer.
FTP Account................... An amount of space on a server allocated to an individual for the

purpose of storing web pages and other files.

FTP.oooeeeeeieeeeee e, (File Transfer Protocol) transfers and exchanges files from desktop to
server.

GIF..oeeeeieeeeee e, (Graphics Interchange Format) is a bitmap image format/ animated
graphics.

HTML.......ccooeeees (Hypertext Markup Language) is the predominant language for

creating web pages.
JPEG ......covveiei, A commonly used method of compression for photographic images.

Server.......ccccevvvveeeeeeennns A computer that stores and serves up information and is linked to
other computers by communication lines.

Upload ........coevvieennne. Move a file from your local computer to a server.

Web Page........cccccuveennns A single page of information on the internet.
Website..........cccecveeennns A collection of related web pages at a common address.

WYSIWYG: ... (What You See is What You Get) is a phrase used to describe a system

in which content during editing looks similar to the final product.
WYSIWYG application... A program such as SeaMonkey Composer that lets you create and edit

documents while seeing them as they will be seen and without having
to know what happens under the hood.
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A web page that is completed and saved on your computer is not viewable on the internet, so it
cannot be viewed by others. In order for the website to be viewable on the internet, you will have to
move your web page to a server. Your FTP account is your allotment of space on the NEIU server where
you can store your web page so that others can see it. SCS provides WinSCP on the PCs and Fetch on the
MACs. Both WinSCP and Fetch software can be downloaded for free.

Before starting your web page, check to see if your FTP account is working properly. The first
step is to check if you can log into your FTP account. Once you have successfully logged in your account
look for a folder named “http.” If you are having problems with your ‘http’ folder or FTP web account,
please contact NEIUport HelpDesk (x4357) or visit the SCS main office located at B-107 (x4390).
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Hostname:  ftp.neiu.edu [([C)[ W) 4ot
Type your
Username: || i

Comect usig: |

¥ Enable encryption
Password: | ypyou

NetlD Password
1 Add to keychain

52
&) (" Cancel ) ( Connect )

115
L1Es
L1504
hIE T ]
11504

Once you have logged into
Fetch FTP you will see a Tatp'
foldar. if you do not have this
folder your FTP account s not

proparly set-up.

Fetch can be
found on the
MAC dock.

Your NEIUport
NetlID is your
Username.

Enter your
Username and
Password.

Once you are
connected to
ftp.neiu.edu,
check if you
have the ‘http’
folder.



WinSCP (PC)

Searching for host ..
Connecting to host .
Authenticating

Llsername:

NetID

Username - fip.neiu.edu

y/

Type your

X

WinSCP can be found on the

desktop.

Your NEIUport NetID is your

Username.

P Enter your Username and
Searching for host...
Connecting to host... Passwo rd .
Authenticating...
Once you are connected to
ftp.neiu.edu check if you have the
‘ ’
http’ folder.
Using keyboard
Password:
| Type your
| oK I s DA |
’
%njeun-&p.naiu.edu-\'\ﬁnSCP [ [@][=]
Local Mark Files Commands Session Options Remote Help
UG- pEe @S -H Defautt - W
&, C: Local Disk @i EMA DR njeun =R W 7 B T
C:AUszers\ManatDownloads Ahomedstudent/nieun
Mame Ext Size Type Changed Attr Mame E)d: Size Changed Rights Cwner
k. Parent directory  1/22/2010 ... r . 1/21/2010 9:42:...  rwxr-xr-x
bin 1/15/2004 11:0... _ rwsr-xr-x
http 1/25/2010 8:26:...  rwxr-xr-x
L[ .eshrc 163 1/15/2004 11:1..  rwsr-xr-x
| | .login 187 1/15/200411:2..  rwxr-xr-x
| | .profile 136 1/15/200411:2...  raxr-xr-x
|| .sh_history 10 1/25/2010 9:12:...  rw-------

Once you have logged into WinSCP FTP you will
see a ‘http’ folder. If you do not have this folder,

your FTP account is not properly set-up.

If you are having problems with your ‘http’
folder or FTP web account, please contact
NEIUport HelpDesk (x4357) or visit the SCS main

office located at B-107 (x4390).
|

OBof 3,052 KiBin Dof 4
& F2Rename |

O0Bof 456 Bin Dof &

23 F5 Copy .3 F6 Move (5 F7 Create Directory 3¢ F8 Delete [ F Properties 1 F10 Quit

g SFTP3

0:2623

4
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Before You Begin Creating Your Web Page

A few recommendations to help you organize your website:
v Plan your web pages and website before you begin.

v' Create a ‘New folder’ or designate a folder on one of your drives on the local computer in which
you will store all your website files. Try to avoid mixing these files with other unrelated files.

This will make it easier to design a web page.

v' Itis recommended that you save all web pages with the “.html” extension. Also use lowercase
letters and avoid spaces in your file names; instead of spaces, use hyphens.

v" Have all images you plan to use saved in your website folder. Use only images that are in “.gif”
or “.jpeg” formats as these work best with most browsers.

Paint.NET

Paint.NET is a free imaging and photo editing software for computers that can run Windows. It features
an innovative user interface with support for layers, unlimited undo, special effects and a wide variety of

useful tools.

[E4 Untitled (100%) - Paint NETv3.5.2 =X R
File Edit View Image Layers Adjustments Effects Utilities Window Help |
e Wl [ S, Window ~ & |8 ™ Units: Pixels - =
Took # - |Brushwidth: © 2~ @ |[Fill. Solid Color - ‘
Tools & History
oy | % New Image |
P
2N
N
& |
Eeo
&L &
2
=
(S|
Colors =]
Primary - Mare >>
% Layers =]
L]
Background v
Q-
"R o il ‘
@ Paintbrush: Left click to draw with primary color, right click to draw with secondary color /800 600 77197, 203

Paint.NET can covert from and to these files: .png, .bmp, .gif, .jpeg, .png, .tiff, and .tga. To convert the
files simply click File > Open Image File=> File = Save As = and select ‘.jpeg’ or ‘.gif’ in the ‘Save as
Type’ field. JPEG format provides the best quality for photo-like images.
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BEGINNING A NEW PAGE

PC
To begin SeaMonkey Composer,
double-click SeaMonkey on the
desktop. If you do not see it on the
desktop click on
Start->Programs—>SeaMonkey.

MACs
SeaMonkey is located on the Dock.
(A dock is where the software
applications are on a MAC.) On the
Dock locate Other Applications, and
you will find SeaMonkey.

MACs and PCs
To Access Composer Click on
File > New = Composer Page

A blank Composer document will
appear on the screen. This is
where you will create your web
page. The Composer is a
WYSIWYG (What You See Is What
you Get). The Composer
resembles what you see when
you create a new word
processing document.
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Edit View Go Bookmarks Tools Window Help
| New :

Open Web Location... Ctrl+5Shift+L
Ctrl+O

Ctrl+M
Ctrl+T

Browser Window

Browser Tab

QOpen File..,

Message Ctri+M

C v Clos c ¥
Recently Closed Tabs e

Recently Closed Windows * Composer Page Ctrl+Shift+N

Close Ctrl+W 7
Send Page...

Send Link...
Save Page As... Ctrl+5
Edit Page Ctrl+E
Upload Eile..,

Page Setup...

Print Preview

Print... Ctrl+P
Work Offline

Exit Ctrl+ @

3 untitled - Compote
T e Eet Insert Fgrmat  Table
T Mew Opem Swe Publsh

-l |y

ook Window Help
Link lImage Table

AR 7 U|E = -

e Print -

Spell o

i [ Bady Tt F[E]x 3w e

# bl | I HTML Tags | €4 Source | 18 Preview
© =10 Bl <bedp



THE SEAMONKEY COMPOSER WINDOW

SeaMonkey Composer is similar to text editors and word processing programs. It has the ability to
format text size, color, font, alignment (left, center, right, and justify) as well as create numbered and
bulleted lists.

SealMonkey Toolbar

’ SeaMonkey Menu ]

rﬂuw-tmww l P E1
T bde bd Yeew jesert Fgewat Taple Jook fiedow |Help

T Mew Opn Seve Publsh e Pt -| Uik mage Table Sped L 4]
Ayt =10 | 2|8 5F U= 1= 5 & sz 1 0 & +— Formatting Toolbar

|

. SeaMonkey Composer Window ,
L L R L e e — SeaMonkey Live Preview Tabs

"L T ===

At the Bottom of the page there are four tabs:

Normal Beginners will want to use the Normal View. This view allows users to see the page
View exactly the way that it will look as a webpage.

HTML Source  Allows users to see the code of the webpage. This view is for those who want to learn
View HTML or already know HTML.

HTML Tags Allows users to see the tags used when formatting text and other features used when
View creating the web page.
Preview Allows users to preview the web page in the SeaMonkey browser.
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INSERTING AND MANIPULATING TEXT

You enter text into the HTML document body by typing in the Composer window. Text will wrap around
the screen just like a word processing program. Pressing the [Enter] key will insert a hard carriage return
and place the cursor at the beginning of the next line.

FONTS, FONT SIZE, AND FONT COLORS

You may change the font, font size, text style, and the text color using the Format Menu. You may also
manipulate the text by using the toolbar.

Manipulating text using the toolbar

i -l A == === = =
EDd}l'TECt .I d’? | A A ‘ B I u - —_— F—_ *_= | =N == — = Ia
‘-a’ and ‘+a’ decrease and increase text size respectively
Manipulating, Font Size, and Font Colors
a untitled - Compaser
-.- File Edit View Insert _ Table Tools Window ﬂel_p _
T Mew Open Save Font b [Table Spell
m = I E R o — = o =
A [BodyTes |0, = g e=(El=z = 2 a
Text Style v
Text Color...

Discontinue Text Styles  Ctrl+Shift+Y

Discontinue Link Ctrl+Shift+ K
Remove Mamed Anchors  Ctrl+Shift+ 4
Paragraph ¢
List K
Increase Indent Ctrl+]
Decrease Indent Ctrl+[

Align r

Positioning grid

Advanced Properties...

Page Colors and Background...

Page Title and Properties...

If you wish to manipulate text which has already been typed, you must select the text first by
highlighting it before changing its size, or color.
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CHANGING THE WEB PAGE COLORS

Eile Edit View Insert [Format] Table Tools Window Help

SeaMonkey Composer
allows you to change the
background of your web

page.

To do this, click
Format -> Page Colors and
Background.

Under Page Colors and Background, you may

Mew

Open

Save Font

Body Text .I‘ ) Size

set the web page to use the Reader’s default

colors or to Use custom colors.

If you want to use custom colors, click on the

colored boxes next to the categories (normal
text, link text, etc...) of the type of text you

wish to change.
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Text Style
Text Color...

Discontinue Text Styles

Discontinue Link

Bemove Mamed Anchors

Paragraph

List

Increase Indent
Decrease Indent

Align

Positioning grid

Advanced Properties...

b Table Spell

: E

-+
[l

Ctrl+Shift+Y
Ctrl+5Shift+E
Ctrl+5Shift+ A

Ctrl+]
Ctrl+[

Page Colers and Background...

Page Title and Properties...

Page Colors and Background

Page Colors

(]

@ i Reader's default colors (Don't et colors in page);

“1 Use custom colors:
Mormal text:
Link text:
Active link text:
Visited link text:

Background:

Background Image:

URL is relative to page location

Mormal text
Link text
Active link text

Visited link text

Choose File...

Adwvanced Edit...

OK

| | cancel |




CHANGING THE WEB PAGE BACKGROUND

Page Colors and Background £

Page Colors

") Reader's default colors (Don't set colors in page)

@ Use gustom colors:

—_— Block Background Color
Normal text: lgf Normal text / =
Link text: . | el .
ot [—' Link text [ =
Active link text: | Il . - _..
Visited link text: - | - . . .

|
Bickpaing — Visited link text === F= ==
HE | TEN

Click on a color or

Background Image:

URL is relative to page location Choose File... ‘ enter an HTML color string
' . (e.g: "#0000fF" or “blue”):
Advanced Edit... SFFEEF _l
[ ok | [ conce | [ ok || cance |

To change the web page background color, select “Background”. Once you have chosen a color, click the

‘OK’ button.

Page Colors and Background 3|

Page Colors
@ Reader's default colors (Don't set colors in page)

Use gustom colors:
Normal text
Link text

Active link text

Visited link text

Background Image:

URL is relative to page location Choose File...
[ Advanced Edit... |
ok | [ Cance |

Select Image File

fganize «

I Favorites
Bl Desktop
& Downloads
. Recent Places

4 Libraries
* Documents
@ Music
e=! Pictures
B videos

#& Homenmnun

() [ » Libraries » Pictures »

MNew folder

Pictures library

Includes: 2 locations

&

abstract

File name:  abstract

= | 3 || Seorch Pictures

Amange by

- | Image Files

Folder =

z

Open |v |

Cancel

J

You may also use an image as the background. To do this simply click ‘Choose Flle’ in the Page Colors
and Background window. Then select the image that you wish to use as the background to your website.

**Note: use the exact file name (abstract.jpg) as opposed to pointing to the image location

(file:
viewing your web page online.**

Page 12 of 23

C:/Users/**** [Pictures/abstract.j

). This will prevent broken links to your image files when




INSERTING AN IMAGE

Eile Edit View Format Table Tools

Window Help

Mew Open [ Image. || Link image Table Spen
Body Text v| Table... \LJ\| = = 8 4= H El = = 5 a
— Link... Ctrl+L
Mamed Anchor...
- Image Properties
Hgrizontal Line - = @
HTML... Location | Dimensions [ Appearance | Link
Characters and Symboals...
Image Location:
Table of Contents... L4 gel e
Break Bel. I 1
reak Below Image(s) URL is ralative tt | Choose Eile...
Tooltip:
@ Alternate text:
Don't use alternate text
Image Preview
Advanced Edit
Cancel | | Help

Position the mouse cursor or use the keyboard (space bar, tabs, enter, or arrow) in the body and where
you want the image to appear. Click the Image button on the SeaMonkey toolbar. Alternately, you may

click on

Insert=> Image from the menu bar. At this point, the Image Properties window will appear as shown

below.

Image Properties

Location | Dimensions | Appearance | Link |

Image Location:

ile:/// C:/Users/Mana/Pictures/new-logo.jpal
URL is relative to page location
Tooltip:

@ Alternate text:

1 Don't use alternate text

Choose File...

Image Preview

Actual Size:
T Width: 362
Height: 176

Advanced Edit...

[ o

| [ concel

J |

Help ]

Image Properties

Location | Dimensions | Appearance | Link|

Image Location:

hew-lego,jpg
URL is relative to page location
Tooltip:

@ Alternate text:

1 Don't use alternate text

Choose File...

Image Preview

==

Adwvanced Edit...

[ ok

| [ conce | |

Help |

Click on the Choose File button to locate the image you wish to insert into the web page. If you already
know the image name, simply type it into the Image Location field.

NOTE: use the exact file name (new-logo.jpg) as opposed to pointing to the image file location
(file///C:/User/**** [Picture/new-logo.jpg), and also use hyphens instead of spaces. This will prevent
broken images when you view your web page. Alternate Text (will not work with all browsers) can be
added to the image properties. This will make a small text box appear whenever the user, places their
mouse cursor over your image. For example, let’s say you inserted a picture of a mouse. You can type in
the alternate text “Squeak.” Every time the mouse cursor is moved over your image, the word “Squeak”
will appear. If you do not want to add alternate text, click the bullet “Don’t use alternate text.”
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Manipulating an Image

You may change the height and
width of an image by double-
clicking on it and choosing the
Dimensions tab. You can assign
custom dimension settings to
enlarge or reduce the image size.

The Appearance tab allows you to
adjust spacing and add solid
borders around images.
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Image Properties

Location | Dimensiens Appearancel Link

1 Actual Size

@ Custom Size Constrain

Height: 176 % of window -

pixels

Image Preview

Advanced Edit...

0K

| | cancel || Hep |

P

Image Properties

Location | Dimensions | Appearance | Linkl

(=l

Spacing Align Text to Image
Left and Right: ixel
==handtg | Pl xyz At the bottom hd
Top and Bottorn: pixels
. ) Image Map
Solid Border: pixels
Remove

Image Preview

Advanced Edit...

0K

| [ cance ||

Help |




ADDING A TABLE

Tables can be used in your webpage to help organize your information. However, tables should not be

used as a layout for the web page.

Tables can be added by clicking on the Table button at the top of the Menu bar.

Mew  Open  Save Publish Browse Print '| Link Image | Table | Spell

Insert Table \EI ‘ |

Size ‘ |

=
Bows: 12

Columns: 2

Border: 1 pixels
[ oK ][ Cancel ]

If you would like your table to span the entire width of the page you may leave the "% of window" at
100, otherwise you have the option to adjust the width. You may also choose the width by "pixels"
although "% of window" is the default width setting. The length is determined by the number of rows in
your table. You can select the border width by changing the amount of pixels that will pad the cells.
After clicking "OK," a border will show up on the SeaMonkey composer page.

Table Properties =X

Table | Cells

Selection

+Previous

Current changes will be applied before

changing the selection.

Click inside the table, go to Format (located in the s Content Alignment
. A [T Height: [7] Vertical: Top -
tool bar) and click on Table Properties. .
[C] Width: [ Horizontal:
Format->Table Properties ] Cell Syle ) Tedt Wrap:

[] Background Color: C] (Let table color show through)
Use checkboxes to determine which properties are applied Advanced Edit...
to all selected cells

ok | [ apply | [ Cancel | [ Hep |
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INSERTING AND MANIPULATING TEXT IN THE TABLE

You may enter text into the table simply by clicking your mouse in the box in which you want to enter

text. The text length will determine the column width. Pressing the [Return] key will insert a hard

carriage return and place the cursor at the beginning of the next line within the table, but note a second

line will be added to the entire row.

You can change the font properties using the Format menu or you can also change the text by using the

tool bar.

CHANGING THE TABLE OR CELL BACKGROUND

To change the Table background, click on the Table
menu and choose Table or Cell Background Color.

The Table or Cell Color window will open. To
select a table background color, click Table, select
a color, and click “OK”. The table background
color will change to the color you selected.

To change the background of a cell, select the cell
you want to change and click in the cell making
sure your cursor is in the proper cell. To change
the cell color, click on the Table menu and choose
Table or Cell Background Color. To select a cell
background color, click Cell(s), select a color, and
click “OK”. The cell background color will change
to the color you selected.
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Tools Window Help

Inzert ¥
Select k
Delete k

Join Selected Cells
Split Cell

Create Table from Selection

Table or Cell Background Celer..,

Table Properties...

Table or Cell Color @

Background for:

Click on a color ar

enter an HTML color string
(e.g.: "#0000ff" or "blue"):

ok || cancel |




INSERTING PICTURES IN THE TABLE

a untitled - Composer

T Eile Edit View

=

MNew  Ope

sotyTed |l # N\ & |B 7 U=

Insert] Format Table Teols Window Help

[
o
O

Save ublish Browse Print -

Link Image Table Spell

s
[

L d
il
U

il
(1]
]
L2
&1

Image Properties

&

| Location | Dimensions | Appeasrance | Link

Image Location:

URL is relative to page location Choose File...

Tooltp:
@ Alternate test:

Don't use alternate text

Image Preview

Advanced Edit..

0K Cancel Help J

e

| # Morral | HTMLTagsl(HTNDSourcel b Previm|

Q@ e Baz

<body> <table> <tbody> <tr> <td=» ==

To insert a picture into a table, select the location, and click Insert from the Main menu. The Image
Properties window will open and you may choose which file you want to insert. Remember to rename
your picture file to it’s orginal name as stated in the “Inserting an Image” section.
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INTERNAL AND EXTERNAL LINKS

One of the most important features of a web page is that it contains links to other sites on the Internet.
Links provide a quick and convenient way to take users to other web pages by simply clicking on them
instead of typing the full address into the location bar.

When clicked, Internal Links take the user to another web page or portion of a web page on the current
website. The method used to create an internal link is similar in concept to external links. The only
difference is that the internal links reference anchors/targets, local files, or local web page files.

Creating an internal or external link involves one of two elements in your web page. In pure HTML, you
may use text or an image to make a link. To begin, choose the text or image that will serve as the link. In
the case of text, highlight the text with your mouse cursor. In the case of an image, click on it once to
select it.

**Note: Internal, External, Anchor, and E-mail Links will not work until your web page has been
published to your NEIU server. Please refer to the “Publishing Your Webpage” section for more details
on how to publish your website. **

|

New  Open  Save Publish Browse Print 'Image Table  Spell ﬂ

v|Bc»d},r'l7T|.l‘‘5;|A+‘Aﬁ|B/Ju| ‘[g
NOftheaStern Link Properties ;JES

a—
S
S

m
[
lil
]
=

*

Link Text
Enter text to di¥play for the link:

Link Location

Enter a web page location, a local file, or select a
Named Anchor or Heading from the popup list:

-
URL is relative to page location | Choose File...

Advanced Edit...

0K Cancel ‘ | Help

r,’j Normal | HTML TagsE<HTP‘IL> Sourcel R Pre'view|
@ e @2 <body> ==

f—— ==

Highlight the text that you want to link -> Select the link button on the tool bar -> The Link Properties
box will open -> Enter a URL from the WWW or Chose a file to a page within your web site that you want
to link to -> Click OK.
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Click on the page
where you want the
anchor to be. Click
Insert -> Named
Anchor

A new window will
appear. In the
Named Anchor
Properties name
your anchor and the
Anchor symbol will
appear on the
webpage.

Highlight the text
you want to be the
link for the anchor.
Click Link ->
#anchorname -> OK.
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[Insert| Format Table Tools Win

Image...
Table...
Link... Ctrl+L
I Mamed énchor... I

Harizontal Line

HTML...

Characters and Symbaols...
Table of Contents... L4

Break Below Image(s)

& untited - &m_

EF: Edit View Insedt Form Ta Toals indow  Help

-— Q\P‘uhﬁsh Browse Pnnt -
,[ cavtet - |I 2N A |BIU|§5

Nam&d Anchor Properties

Link Image Table Spell

Anchor Name:

Illmms
' Univer

| Advanced Edit... |

ok | [ Concel |

Eile Edit View Insert Format Table Tools Window Help

New  Open  Save Publish Browse Plinl}l Link | Image Table Spell

e <M o |2 £ §/1 U] = |[€]

111
e
111
[
[ilul

N(.) eaStern f Link Properties E
Illinois
H xr Link Text
University o

Anchors (2]

Link Location

Enter a web page location, a local file, or select a
MNamed Anchor or Heading from the popup list:

#top| v

[/] URL is relative to page location | Choose File...
Advanced Edit...

| ok ]| cence || Hep |

e —



Adding an e-mail link allows your web page viewers to contact you. The procedure to create an email
link is very similar to creating an external link.

First, highlight or click on the text or image, then click on the link button on the tool bar.

File Edit View Inset Format Table Tools Window Help

Mew  Open  Save Publish Browse Print - | Link Image Table Spell
([Boytes < |l o | #A|[B 5 U|iz 1= 3 =
'y ] -
f Link Properties u

Link Text
Contact Us

Link Location

Enter a web page location, a local file, or select a
Mamed Anchor or Heading from the popup list:

mailto:(enter your e-mail address) -
[] URL is relative to page location | Choose File...

[ T ]

oK | Cancel | | Help |

Type the text you want to link to the email address -> Highlight the text -> Click on the Link button on
the tool bar -> Type in mailto:emailaddress@whatever.com into the Link Location box -> Click OK.
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SAVING YOUR WEB PAGE

B index fileudind = v A [

7 [Ele] Edit View Insert Foimat Table Iools Window Help

New L3 ;]l - Link Image Table Spell o
ps Open Web Location... Ctrl+ Shift+L e e =
gsmmh c:n.o ‘ L U ‘ JENEE R
e SAMPLE WEB PAGE
Sivve Ak,
l Save And Change Character Encoding St u dent
Publish Cuteshites Com puting
PR , Services
Exportto Text.. 1 e/ el A
Browse Page
Send Page...
Page Setup.. o
B Cuep PICTURES
Btk

Northeastern
N :ll:‘u\ni.; i NEIU SCHOOL LOGO AND SCHOOL MOTO
iversity

in the world.

# Normal | TS HTML Tags | {HTHLY Source | p Preview
Q@ L% B <body> =

Be sure to save your work frequently. This
will help ensure that your work will not be
lost in the event of a computer failure or
power outage. To save your web page, click
on File = Save from the SeaMonkey File
menu. If you have not given your web page a
title, you will see the Page Title menu box
appear. After you give your webpage a title,

[ 5 save Page As

» Sample Web Page

Organize + Mew folder
press OK. g +| Name ’ Date modified Type

Bl Desktop @ index 1/25/2010 2:22 AM SeaMonkey
The Internet standard for HTML web & e s |
publication is to have the primary or first s |
web page files called index.html in order to 2 Documents
be recognized by any and all HTML = e
compliant web browsers. Contrary to Lt
popular belief, you should NOT name your o Homegop = [ E
web page home.html. It is acceptable to S”;ﬁiﬁ :|
name your web page index.htm but you
should use a full .html extension on all HTML s [ oma ]

files whenever possible. Be sure to delete
the placeholder home.html that will be in
your http folder or it may interfere with your
new web page. Remember to use lowercase
letters and avoid using spaces, using
hyphenation instead.
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PUBLISHING YOUR WEB PAGE

Once you have finished editing and tweaking your web page, you should publish it to your http folder
and see how it looks in a web browser. To do this, use WinSCP or Fetch.

Please remember that you have to upload all files (web page (index.html), images, sounds and video
clips) to your NEIU account. To do this connect to your FTP account, a window like this one below will
appear. The next step is to double click on all of the files associated with your web page. The files will be
copied from the local computer (the computer you are working on) to your FTP account. To download
files to your FTP account drag your files from the local computer to the ‘http’ folder. It is strongly

suggested that you save your web files and picture together in the same folder and not in different
folders as mentioned earlier in this tutorial.

WinSCP (PC)
& njeun - njeun@ftp.neiu.edu - Winscl’l — ‘ Lm
Local Mark Files Commands Session Options Remote Help
& B oEe m2 R - Default - - |
B Desktop -3 & | njeun @ iE - at ﬂ l:II:E
C:4U zers\ZignatDeskiophs ample ‘\Web Page thome/student/nigun
Mame Ext Size Type Changed Attr MName Ex‘t Size  Changed Rights
& . Parent directory  1/25/2010 ... & . 1/21/2010 9:42:...  rwer-xr-x
=1|imagel0l.jpg 9,239 JPEG Image 1/25/2010 .. a N . bin 1/15/2004 11:0..  rwe-xr-x
index.html 1,245 SeaMenkey Do...  1/25/2010 .. a il ] http 1/25/2010 2:17:...  nwnar-xr-x
=l|new-logo.jpg 70,577 JPEG Image 1/25/2010 ... a I_.é.c:hrc 163 1/15/2004 11:1...  rwser-xr-x
L | legin 187 1/15/2004 11:2...  rwoer-xr-x
L | .profile 136 1/15/2004 11:2...  rwoer-xr-x
L_| .sh_history 2 12/9/2009 5:12... rw-------
LOCAL COMPUTER Pl et
NICIII CCDV/CD
4 T b
0Bof 81,061 Bin Dof 3 0Bof 488 Bin 1of 6
«# F2 Rename 23 F5 Copy .5 F6 Move 5§ FT Create Directory 3 F8 Delete 5 F3 Properties []. FL0 Quit

S SFTP3 0:02:58

Drag and drop your web page, images, sound files, and video files into your http folder.

If you followed these instructions, your web page will be viewable by going to
http://www.neiu.edu/~(your NetlID)
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Once you have connected
to ftp.neiu.edu through
Fetch, click on ‘Put.’ This
will open a new window
that asks you to choose the
items you want to put on
ftp.neiu.edu. Locate your
files (index.html, picture,
videos, etc.) and click on
‘Put.’

If you have done it
correctly you will be able
to see your files in the
‘http’ folder.

Sizw | Date

. he L i 90 1se
'E' i bl HTML doument 1rE8 L2519
:-_ e B i [FEG image BE.8KE L2ss1a

Choose items to put on ftp.neiv.edu:

L.] [ (&] Downloads - (Q search D)

y [# About Downloads.pdf
[3] Fet

Lel>] (e8]

¥ DEVICES

E ipisk
@ Remote ...
¥ SHARED
b-104-...
=] h-107-

Put as:

Format: | Automatic

If a file already exists: [ Replace existing file

"1 Show hidden files

(Ganee) ()
A

If you followed these instructions, your web page will be viewable by going to
http://www.neiu.edu/~(your NetID)
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