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EXERCISE 1 – TUTORIAL

Radar Earth Observation – ESA EO Data Access and

resources, applicat ions, Copernicus OA Hub

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 acquire skills in retrieving satellite imagery from both ESA and 
third-party missions

 conduct specific analyses utilizing the EO Browser

 install ESA SNAP and execute fundamental image operations

 explore the spectral curve of various surface types
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1 | Exercise outline



2 | Background

Most of the ESA's Earth observation datasets are easily accessible online,

free of charge. Users can acquire access by completing a simple

registration process.

The Copernicus Data Space Ecosystem provides full, free and open

access to large amount of Earth observation data, along with scalable

interfaces integrated with the Copernicus Sentinel satellites. This includes a

range of both new and historical Sentinel images, commercial datasets, as well

as Copernicus Contributing Missions.

Sentinel data is also accessible through Copernicus Data and Information

Access Services (DIAS), which are platforms designed to facilitate the

discovery, retrieval, and use of Copernicus satellite data, including data from

the Sentinel missions. There are several DIAS platforms available, each

offering a user-friendly interface and tools for working with the data.

The ESA Hub allows checking searches online by browsing and viewing

product metadata and measurements without downloading them.

Sentinel products are provided for download over HTTP in *.ZIP archive file

format.

Sentinel Hub is a cloud-based platform that provides access to satellite

data, particularly from the ESA Sentinel missions. The platform offers a

variety of services and tools for the retrieval, processing, and analysis of

satellite imagery. It is commonly used by researchers, developers, and

businesses to access Earth observation data for various applications,

including environmental monitoring, agriculture, urban planning, and more.

EO Browser is an online platform developed by Sentinel Hub that allows

users to visualize and explore satellite imagery, particularly from the

Copernicus Sentinel missions. Sentinel Hub provides the backend

infrastructure and access to the satellite data, while EO Browser serves as

the user interface for interacting with that data.

ESA not only provides satellite data from its own Earth Observation (EO)

satellite resources, but also facilitates access to Third Party Missions

(TPMs), which are non-ESA EO missions. Integrating data from these

diverse sources is crucial for enhancing the sustainability of satellite

services, expanding the scope of monitored parameters, and promoting

scientific development. Researchers and students alike can request third-

party data, but it's important to be aware of licensing conditions,

especially for users in certain countries, where national legislation on data

access may apply.
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3 | How to access ESA data

To access data from the European Space Agency (ESA), user can use

various platforms and tools provided by ESA. Here are some key sources:

Earth Online Portal

The Earth Online Portal serves as a gateway to a diverse range of Earth

observation resources. It includes a directory for discovering missions and

datasets, offering convenient access to satellite data, operational updates,

events, and tools to enhance data utilization.

Sentinel Online

The Sentinel online platform offers technical details about the Copernicus

Sentinel missions and allows systematic access to processed data, which is

readily accessible on the website. User registration is required for access.

Copernicus Contributing Missions Online

To obtain data with higher resolution, users can visit the Copernicus

Contributing Missions website. This platform offers comprehensive

information on all Contributing Missions that provide data complementing

the Copernicus Sentinels, addressing the requirements of the Copernicus

Services. Eligible users can access the data for free upon registration and

confirmation of their user category.
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• Since 24 January 2023 a new Copernicus Data Space Ecosystem has been

launched to provide free and open access to Earth Observation data from

all Sentinel satellites with new features for visualisation and data

processing.

• The previous Copernicus Data Hub distribution service that has been

providing access to Copernicus data is offering access to Sentinel data with

a gradual ramp-down of the operations capacity and data offering.

• Sentinel Data are also available via the Copernicus Data and

Information Access Services (DIAS) through several platforms.

4 | Copernicus Data Space Ecosystem

https://dataspace.copernicus.eu/
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The Copernicus Data Space Ecosytem allows us to access a wide range of

Earth observation data from the Copernicus Sentinel missions and more.

The Copernicus Data Space Ecosytem provides tools for easy discovery,

visualization and download which will be continuously upgraded.
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4.1. Registration and login

• We can register a new user or log in as an existing user to the portal.

• The Copernicus Data Space Ecosytem allows us to browse and visualize

satellite images freely, but we need to register and create an account to

be able to download them.
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After registration and login, it is possible to visualize or search EO data
products within portal. We can choose various satellite platforms, product
types, polarizations, and sensing modes for individual satellites:

Visualize or Search
options

Search by 
Product ID

Select data
source and set 
advanced filters

(see slide x)

Search area of interest

Search by date of image 
sensing or filter by months

Select Map background

Select area of interest

Advanced options
for analysis and 

visualization

Search by Date, 
select % of the

cloud cover

Choose Sentinel 
mission and data

product

Visualize data as 
color composition
or spectral index

Or create your own
color composition
or spectral index
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Levels of product types

- unprocessed raw data

- (Single Look Complex) contains complex images with amplitude and

phase in the slant range by azimuth imaging plane, in the image

plane of satellite data acquisition

- (Ground Range Detected) consists of focused SAR data that has been

detected, multi- looked and projected to ground range using an Earth

ellipsoid model

- (Ocean) provide geo-located geophysical products derived from

Level-1 for wind, wave and currents applications

The available Sentinel-1 data includes products

from the Sentinel-1 satellite constellation, including

Sentinel-1A (operational since 2014) and Sentinel-

1B (operational from 2016 to 2022)

Determines wheter the data was recorded during a

descending orbit (flight direction: north-south) or

an ascending orbit (flight direction: south-north)

The Relative Orbit Number is the number of full

orbits since the relative orbit 1 to the end of a cycle

Sentinel-1 operates in 4 instrument acquisition

modes: Stripmap (SM), Interferometric Wide Swath

(IW), Extra-Wide Swath (EW), Wave (WV)

Depending on the acquisition mode, different

swaths and identifiers are possible

Determines with which polarisation the data was

acquired. The first letter indicates the polarisation

when sending the signal, the second letter when

receiving the signal. Data can be acquired in single

polarisation HH or VV or in dual polarisation HHHV

or VVVH depending on the instrument mode

E.g. Sentinel-1 C-SAR - SAR Instrument that provides an all-weather, day
and night imagery at C-band at high and medium resolutions for land,
coastal zones and ice observations.
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4.2.Search results

After defining the search criteria, we get the results that can be further 

viewed, analysed or downloaded.

Image preview
(if available)

Main product 
information

Metadata
information

Image 
download
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EO Browser, developed by Sentinel Hub, is an online platform that

empowers users to explore and visualize satellite imagery from Earth

observation (EO) missions, with a focus on the Copernicus program.

Offering an intuitive and user-friendly interface, the platform is widely

utilized for educational, research, and environmental monitoring

purposes. Key features encompass direct access to Copernicus Sentinel

data, enabling users to visualize and analyze imagery within the browser.

Customization options allow users to tailor their view by adjusting

parameters like date and cloud cover, catering to specific research needs.

The platform's educational utility is evident in its use in educational

settings, introducing students to Earth observation and remote sensing

through its accessible interface. Additionally, EO Browser facilitates time-

lapse creation for monitoring changes in the Earth's surface over time.

EO Browser is a valuable tool for those interested in exploring and

understanding satellite imagery for a wide range of applications,

including environmental monitoring, agriculture, forestry, and urban

planning.

5 | Sentinel Hub - EO Browser

https://apps.sentinel-hub.com/eo-browser/

Registration or Log in
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Data source
selection

Selection of time
range of data
acquisition

Search the area
of interest

Log in

Area of interest

Marking the point of interest

Area measurement

Image download

Creating 3D view

Creating histogram view

Creating video sequences

After the search,the selected image can be visualised in the browser.

Images that meet
the search criteria

Visualization of the
selected image
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5.1.Optical data

In the visualisation tab, we can change the view mode (available are 

visualization options in the form of color compositions and spectral indices).

True color composition (R-G-B)

Normalised difference vegetation index (NDVI)
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Other visualization options

Available color compositions:

• True colour (bands: Red-Green-Blue)

• False colour (bands: NIR-Red-Green)

• Highlight Optimized Natural Color

• False colour (urban) (bands: 12-11-4)

• SWIR (bands: 12-8A-4)

Available spectral indices:

• NDVI - for vegetation monitoring

• NDWI - for water monitoring

• NDSI - for snow monitoring  

• Moisture index - for moisture monitoring

Available classifications:

• Scene classification map - classification

display based on ESA algorithms

+ Available custom visualization

We can also use a visualisation for custom color combinations or spectral

indices of default bands or the scripting tool and use additional datasets.
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An important visualisation tool of EO Browser is the Timelapse function.

We can choose multiple images filtered by date or month and select one

image per orbit, day, week, month or year. We can set prefered tile coverage

and % of cloud cover. Then we can select all or only some images and

play, download or share the timelapse visualisation.

Select/deselect image
Play a video, select transition mode, 

download or share your created timelapseSelect time range

The resulting timelapse of images from the Landsat 7 satellite showing the 
disappearance of the Aral Sea by 2020
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5.2.Radar data

When displaying radar data, we have the option to choose from 

various types of visualizations.

In accordance with specific requirements, the terrain can be displayed

using different polarizations, cross- polarizations, and corrections.
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6 | Sentinel Application Platform (SNAP)

https://step.esa.int/main/download/snap-download/

ESA Sentinel Application Platform (SNAP) is a software toolkit developed

by the European Space Agency (ESA) for processing and analyzing Earth

observation data, particularly data from the Sentinel satellites. SNAP is

part of the Sentinel Toolbox and is freely available to the public. It

provides a user-friendly interface and a comprehensive set of tools also

for working with a variety of other remote sensing data.

SNAP is widely used in the scientific community and by remote sensing

professionals for a variety of applications, including land cover mapping,

environmental monitoring, and disaster response. It is an open-source tool,

and its modular architecture allows for the integration of plugins and

additional functionalities.
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After installing and starting the software, we can open an image using 
File – Open Image or by Import option:
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Open image as RGB 

color composition

Display image in different polarizations
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Upon opening an image, users can explore the image data through

the Product Explorer window. This encompasses opening RGB

composite images, navigating metadata, inspecting spectral bands,

and reviewing image masks. In the case of radar images,

amplitude or intensity can be visualized in various polarizations.

In the bottom-left Window Group, we can see 4 tools:

• Navigation tool – to navigate within the opened image

• Colour Manipulation – to view the histogram for the opened image and

manipulate individual channels or assign new colours to the image

• Uncertainty Visualisation – to visualise the uncertainty information

associated with a band shown in an image view

• World View – to see the position of our selected image

Navigation tool Colour Manipulation World View
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To simultaneously view and compare multiple opened images, utilize the

Tile function (e.g. "Tile Horizontally" or „Tile Vertically“).

Ensure that the cursor is visible and that simultaneous manipulation of all

images is possible by navigating to the Navigation tab and verifying that

the following is checked:

synchronises views across multiple image windows

synchronises cursor positions across multiple image windows

20



For localization purposes, we can add various pins to different pixels and

add the description to them (View –Tool Windows – Pin Manager or by

clicking on the icon of Pin placing tool

To observe spectral information of these various pins, we can use the

tool Spectrum View
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In addition to providing users with data from its own Earth observing (EO)

satellites, the European Space Agency (ESA) has played a significant role

in providing access to Earth Observation missions not under ESA

ownership or operation—referred to as Third Party Missions (TPM). With a

history spanning over 45 years, the TPM program involves a series of

Earth Observation-focused satellites owned by various commercial and

public organizations worldwide. The TPM initiative currently includes over

50 missions, contributing data from more than 60 instruments to support

users engaged in research and development endeavors.

7.1. Access to TPM data

Users have the ability to explore and download Earth Observation (EO)

data from the extensive catalog of missions operated and supported by

the European Space Agency through the ESA EO Catalogue (EO-CAT):

• https://eocat.esa.int/sec/#data-services-area

User can find here:

 mission, instrument and product news and descriptions;

 collection descriptions;

 data access links;

 information on selected Earth/environmental topics and applications
of satellite data

Data are also accessible through the TPM L-OADS web interface:

• https://tpm-ds.eo.esa.int/collections/

For more information, see the lecture: 1. Radar Earth Observation and

evolution – current and next generation missions, ESA EO Data Access

and resources, applications

7 | Third party missions

https://earth.esa.int/eogateway/missions/third-party-missions

THANK YOU FOR FOLLOWING THE EXERCISE!
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EXERCISE 2 – TUTORIAL

SAR for Land Applicat ions 1 – SAR basics for Land

monitoring using SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 Learn how to retrieve a land-use / land cover (LULC) classification
based on Sentinel-1 image products

 Explore different types of analysis for the detection of discrete land
cover classes.

 Use supervised and unsupervised classification algorithms to
classify the satellite image into classes

1 | Exercise outline
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Mapping land cover using Sentinel-1 data

Mapping land cover using Sentinel-1 data relies on the radar backscatter

signals obtained from the satellite. The backscatter intensity, polarization,

and texture of the radar imagery are analyzed to distinguish between

different land cover types. Supervised classification methods involve

training a classifier with labeled samples of land cover types, while

unsupervised methods group pixels based on their spectral similarity

without prior training. The accuracy of the land cover classification is

validated using ground truth data, and the results can be refined

iteratively to improve accuracy. The final land cover maps provide valuable

information for various applications, including urban planning, agriculture,

forestry, and environmental monitoring.

2 | Background

2

Source: https://eo4society.esa.int/event/7th-advanced-training-course-radar-polarimetry/



2.1 Study area and data used

For this exercise, we will use two Sentinel-1 images of the same area in

northern Poland, downloaded for year 2023 from the Dataspace

Copernicus Open Access Hub [@https://dataspace.copernicus.eu/].

However, the feature space of S1 data, referring to the number of

variables available for predicting target classes, is restricted when

compared to optical data. As a result, this tutorial utilizes two images

captured in the same year but during different seasons. This approach

enables the characterization of surfaces based on their temporal

attributes to some extent. Consequently, Image 1 was obtained during

the month with minimal precipitation (February), while Image 2 was

acquired towards the beginning of July, a period associated with the

highest precipitation.
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2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open 2 Sentinel-1 GRDH

downloaded products with HH and HV polarizations acquired on 5

February and 11 July 2023 by double click on the zipped folders. The

opened products will appear in Product Explorer window:

S1A_IW_GRDH_1SDV_20230205T050029_20230205T050054_047096_05A661_3C7A.zip

S1A_IW_GRDH_1SDV_20230711T050035_20230711T050100_049371_05EFD9_7392.zip

Click + to expand e.g. the content of product [1] from 5 February 2023,

then expand Bands folder and double click on Intensity_VV band to

visualize it. Depending on your computer's capabilities, this process could

take some time. To minimize the data load, the next step involves

creating a subset that encompasses only a portion of the dataset.

Note: The image appears inverted because it was captured during an

ascending pass.

4
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3.1 Pre-processing

We need to apply identical pre-processing steps to both of our scenes:

Create a subset

There is no need to process the whole image, instead, we can reduce the

loaded data to a more manageable size – creating subset. This approach

will decrease processing time in subsequent stages, especially when the

analysis is concentrated on a specific area rather than the entire scene.

Navigate to Raster – Subset tab

and at Switch to “Geo Coordinates”

Enter the following numbers:

North latitude bound: 54.70

West longitude bound: 20.60

South latitude bound: 54.10

East longitude bound: 16.90

Confirm with Run and repeat the step

for the second S1 image.

Apply orbit file

Navigate to Main Menu – Radar – Apply orbit file

In the I/O Parameters tab, select the first product and name the target

product. There is no need to save the output as BEAM-DIMAP (we will save

the time this way)

In the Processing Parameters accept the default settings and select the

option „Do not fail if new orbit file not found“

Repeat for the second image.
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Note: If precise orbits are not yet available for your product, restituted

orbits can be selected which may not be as accurate as the Precise orbits

but will be better than the predicted orbits available within the product

Radiometric calibration

Navigate to Main Menu – Radar – Radiometric - Calibrate

In the I/O Parameters tab, select the product from the previous step

(_Orb) as a source product. For the target product name, add _Cal at the

end of the name as suggested In the case of this final product of

preprocessing, please, save it to your folder for this exercise

In the Processing Parameters accept all default settings and then click

Run.

Repeat for the second image. The saving might take some time.

Note: Thermal Noise Removal is not applied in this tutorial but should be

considered when working with larger subsets or entire images.
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3.2 Coregistration

After both images were radiometrically calibrated in the previous step, the

coregistration brings both into one stack. Image coregistration is the

process that involves aligning two or more images geometrically, ensuring

that corresponding pixels depict the same area on the Earth's surface.

While orbit state vectors alone can suffice to coregister images, for precise

offset tracking, additional data from a digital elevation model (DEM) is

necessary to enhance coregistration accuracy.

Navigate to Main Menu – Radar – Coregistration – Coregistration

In the ProductSet-Reader tab, load the last two preprocessed products

(calibrated and with orbit files applied)

In the Write tab name the target product and set the directory to save it

Leave all other settings as predefined

Note: If the coregistration fails it is advisable to increase the number of

GCPs and also to have the initial coarse offset estimated by the operator.

In addition to verifying the accuracy of the residuals, it is advisable to

visually inspect the stack's quality. One way to do this is by creating an

RGB representation of both the master and slave products, which helps

determine if the images are properly aligned.

Right click on the output stack product

– Open RGB Image Window:

Choose February VV for the red channel,

February VH for the green channel,

and July VV for the blue channel.
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Magnify an area featuring distinct surfaces, such as the boundary between

land and water. The RGB image should be vivid and well-defined, except

for alterations in land cover or scattering mechanisms that may have

transpired between the first and second image acquisitions. In the figure,

rivers, roads, and agricultural fields are distinctly depicted in all colors.

White pixels represent high backscatter in all three bands (urban areas),

while black pixels denote low backscatter values in all three bands (water).

Blue pixels signify a slightly shifted shoreline in July compared to February.

Speckle Filter

Despeckling removes thermal noise introduced by the sensor from the

image to remove potential sources of error in analysis.

Navigate to Radar > Speckle Filtering Single Product Speckle Filter. In the

I/O Parameters select the last stack product and in the Speckle-Filter tab,

choose the simple Lee Sigma filter with default window sizes.
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You can compare the image pre and post-filtering by doule-click on the

VV polarizations anfd utilizing the Split Window feature found in the

toolbar. As usual, different types of filters will yield somewhat varied

outcomes.

Sigma0 VV before (left) and after (right) application of a speckle filter

Terrain-Correction

Navigate to Radar – Geometric – Terrain Correction – Range Dopler Terrain

Correction. The last step in our graph for image pre-processing is to apply

terrain correction to the product, ensuring that all the pixels are moved to

the right locations (eg if the nadir angle of the image is off, it will align the

pixels correctly so it is closer to a top-down view of the imagery).

Our data are still in radar geometry, moreover due to topographical

variations of a scene and the tilt of the satellite sensor, the distances can

be distorted in the SAR images. We need to apply Terrain Correction to

compensate for the distortions and reproject the scene to geographic

projection.

Navigate to Main Menu: Radar - Geometric - Terrain Correction - Range-

Doppler Terrain Correction

In the I/O Parameters tab set as “Source Product” the velocity product.

In “Target Product”, keep the default name and set the Directory

In the Processing Parameters tab set:

Digital Elevation Model: SRTM 1Sec HGT (AutoDownload)

9



Map Projection: In this tutorial, we opt for WGS84 as the Map Projection,

which relies on geographic coordinates (latitude and longitude). However,

for subsequent utilization in a geographic information system (GIS),

projected coordinate systems like UTM (Automatic) could also be chosen.

Keep defaults values for the other parameters. Click Run.

Geocoded image product after Terrain Correction
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Conversion to dB scale

Sigma0_VV values typically fall within the range of 0 to 1, with mean

backscatter values of 0.07 (VV) and 0.02 (VH). This indicates a prevalence

of dark pixels and a scarcity of bright pixels with higher values, resulting in

diminished visual contrasts from a statistical perspective.

To rectify this and achieve a more standardized distribution of values, the

logarithmic function is applied to the radar image. This transformation

converts pixel values into a logarithmic scale, enhancing contrasts by

shifting brighter values towards the mean while expanding the range of

darker values (as depicted in Figure 18, on the right). The calibrated dB

data typically spans from approximately -35 to +10 dB.

To execute this transformation, right-click on each of the four terrain-

corrected bands and choose Linear to/from dB. Confirm by selecting Yes

to generate a virtual band, denoted by the symbol and the "_db" suffix.

These virtual bands are not physically stored on the hard drive but can still

be displayed based on the underlying mathematical expression.

Sigma0 VV before (top) and after (bottom) conversion to dB scale
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Unsupervised classification

An unsupervised classification serves as an effective method for identifying

and grouping pixels that share similar characteristics.

To initiate the K-Means Cluster Analysis, navigate to Raster >

Classification > Unsupervised Classification and select the terrain-

corrected stack as the input product. In the second tab, specify the

number of clusters as e.g. 5, choose all dB bands as the source bands, and

confirm by clicking Run. This process may take several minutes as the

classifier iterates 30 times, utilizing random cluster centers within the

multi-dimensional feature space to identify pixels with similar properties.

The output is a product with a single band (class_indices), where each

pixel is assigned to one of the 5 clusters. While these clusters may not

directly represent semantic land cover classes, they exhibit homogeneity in

terms of their backscatter characteristics.

Double click to open the „class_indices“ band under Bands folder. Zoom

into the area and explore the most frequent classes and their distribution.
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As depicted in Figure, you can utilize the Color Manipulation tab to allocate

colors and even labels to these clusters, enabling you to assess how well

they align with general land use and land cover classifications.

The benefit of employing an unsupervised classification lies in its

independence from prior knowledge about the study area or the data, yet

it effectively groups pixels with similar traits. However, the drawback is

that the usefulness of the result heavily depends on the chosen number of

classes. As illustrated in the example, water is segmented into five distinct

classes (3-7), whereas urban areas are consolidated into a single class (8).

If there is overlap between classes, it may be necessary to opt for a higher

number of clusters and then merge them afterward. Conversely, having too

many classes can complicate the identification of patterns within the data.

Supervised classification

Now, we will perform the one type of supervised classification – Random

forest classification. For this we will create some training data by

identifying polygons containing the different land cover types:

• Select the last subset product by clicking on it. Navigate to Vector > New

Vector Data Container.

• Create new data containers – e.g. for 5 different classes.

• Start with creating the data container for, e.g. „class1“.Click OK.

The newly created vector data container should appear under "Vector

Data" in the Product Explorer. Now let´s start creating training polygons for

these different containers on ice type using the Polygon drawing tool:

13
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Random forest classifier

Navigate to Raster > Classification >

Supervised classification >Random

Forest classifier

• In the Random-Forest-Classifier

select the all Training vectors that we

have created.

• Select at least two Feature bands

(poalrisations)

• Click on RUN.

The output final product should be now

opened in the Product Explorer

Window. Double-click on the

„LabeledClasses“ band under Bands

folder to visualize it.

Compare the results of supervised and unsupervised classification.

For more information, see the lecture: 2. SAR remote sensing for land

applications 1 – SAR basics

THANK YOU FOR FOLLOWING THE EXERCISE!

https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_02.pdf


EXERCISE 3 – TUTORIAL

SAR for Land Applicat ions 2 – Interferometric SAR

data processing, using SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 Learn how to retrieve Digital elevation model (DEM)

 Perform necessary data processing for making an interferogram

 Understand the information content in SAR interferometric images

1 | Exercise outline
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Deformation Mapping and Change Detection using Sentinel-1 data

DEM generation with Sentinel-1 data offers a powerful method for deriving

accurate and detailed elevation information over large areas, especially in

regions with limited ground survey data or challenging terrain conditions.

DEM generation with Sentinel-1 data involves acquiring pairs of SAR

images, processing them into interferograms, unwrapping the

interferometric phase to obtain absolute phase values, removing the

topographic phase contribution, converting the corrected phase into

elevation values using appropriate algorithms, assessing the quality of the

generated DEM, refining it if necessary, validating the accuracy, and

utilizing the DEM for visualization and various applications such as terrain

analysis and environmental monitoring.

Sentinel-1 derived DEMs find applications in topographic mapping,

hydrological modeling for water flow and flood risk assessment,

environmental monitoring for changes like erosion and landslides, natural

resource management for agriculture and forestry, disaster management for

assessing terrain accessibility and planning evacuation routes, infrastructure

planning for designing roads and bridges, climate change studies for

analyzing impacts on coastal erosion and glacier retreat, and remote sensing

applications including orthorectification and 3D visualization.

2 | Background

Satellites constantly monitor

Earth from space, providing vital

data essential for rapid land

cover change assessment and

disaster management. The radar

on board the Copernicus

Sentinel-1 mission can detect

ground conditions and penetrate

clouds, functioning day and night.
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2.1 Study area and data used

For this exercise, we will use two Sentinel-1 SLC images of the same area

for High Tatras, Slovakia, downloaded from the Dataspace Copernicus

Open Access Hub [@https://dataspace.copernicus.eu/].

To ensure successful DEM generation, selecting image pairs with specific

properties is crucial. These include:

• A short temporal baseline, minimizing the time between acquisitions

to reduce temporal decorrelation risks, particularly over changing

surfaces like vegetation or water areas. Sentinel-1 radar (C-band) is

susceptible to decorrelation, especially over vegetation, so image pairs

with minimal vegetation cover are preferable.

• A suitable perpendicular baseline, ideally between 150 and 300

meters, to capture topographic variations effectively through parallax-like

effects. Smaller baselines may not produce pronounced topographic

effects, while larger ones can lead to decorrelation.

• Consideration of the primary mission focus of Sentinel-1 for

deformation retrieval rather than DEM generation, resulting in

predominantly short baselines below 30 meters. Finding image pairs with

short temporal and large perpendicular baselines can be challenging.

• Ensuring suitable atmospheric conditions, avoiding images acquired

during rainy periods or with high water vapor content in the atmosphere

to minimize phase delays and maintain measurement quality.
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2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open 2 downloaded products

by double click on the zipped folders. The opened products will appear in

Product Explorer window.

S1A_IW_SLC__1SDV_20230721T162703_20230721T162731_049524_05F481_08D0.SAFE.zip

S1A_IW_SLC__1SDV_20230802T162703_20230802T162731_049699_05F9EC_E68C.SAFE.zip

To access the information within the product, double-click on it to reveal

the directories, which include:

• Metadata: containing parameters pertaining to orbit and data.

• Tie Point Grids: providing interpolation data for latitude/longitude,

incidence angle, etc.

• Quicklooks: presenting a visible image of the entire scene in radar

coordinates.

• Bands: consisting of complex values for each subswath "i" and "q",

along with intensity

Select intensity image for swath IW1 VV – double click on it to View it

Note: Each SAR image is flipped north—south it maintains the same

orientation as its acquisition (in this case, ascending track).

Check baseline information

As previously mentioned, the quality of DEM generation relies heavily on

the characteristics of the satellite images, particularly the spatial

arrangement of the satellites during acquisition, termed the

perpendicular baseline. A larger perpendicular baseline yields more

detailed interferograms, enhancing the representation of elevation

changes. For instance, a perpendicular baseline of 151 meters, as

illustrated in Figure 8, produces denser fringe patterns, facilitating better

terrain change description compared to baselines of 67 meters or 27

meters.

The time interval between the first and second images, known as the

temporal baseline, also significantly impacts interferogram quality.

Shorter temporal baselines, ideally around 6 or 12 days for Sentinel-1

data, minimize phase decorrelation issues, particularly over natural

surfaces. As illustrated in Figure 9, longer temporal baselines result in

poorer interferogram quality, particularly over areas with natural

surfaces, where reliable height information cannot be extracted. If such

areas dominate the interferogram, DEM extraction becomes unfeasible.

To examine the baseline details of your image pair, navigate to Radar >

Interferometric > InSAR Stack Overview.
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Initially, select "Add Opened" to import the two Sentinel-1 products into

the list above, where their acquisition date, track, and orbit information

should appear.

Next, click on "Overview" to access their metadata.

In the lower list, you'll find details such as:

• the perpendicular baseline (Bperp) in meters,

• the temporal baseline (Btemp) in days,

• the modelled coherence ranging from 0 to 1,

• the height ambiguity indicating the height difference represented by

one color cycle in the interferogram,

• the mean Doppler centroid frequency difference.

5

Figure: Effect of the perpendicular baseline on the interferogram (Braun 2021) 



2.3 Coregistration

To utilize the phase difference between the acquisitions, it is necessary to

initially construct a stack comprising both products. Image coregistration

makes use of image statistics to align both products at sub-pixel accuracy.

While orbit state vectors alone can suffice to coregister images, for precise

offset tracking, additional data from a digital elevation model (DEM) is

necessary to enhance coregistration accuracy.

Navigate to Main Menu – Radar – Coregistration – S1 TOPS Coregistration

–S1 TOPS Coregistration

In the Read tab, select the 20230721 SLC product and in the Read(2) tab

select the 20230802 SLC product

In TOPSAR-Split and TOPSAR-Split(2) tabs select Subswath: IW1

Polarizations:VV

In the Apply Orbit File and Apply Orbit File(2) tabs select leave default

parameters and uncheck „Do not fail if new orbit is not found“ option
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In the Back-Geocoding select SRTM 1Sec HGT (AutoDownload)

In the Write tab, select the directory to save your processing outputs

Note: SRTM data is accessible only within the latitudinal range of 60° North

to 54° South. If your area falls outside this coverage, alternative DEMs

with AutoDownload functionality can be utilized, or an external DEM stored

as a GeoTiff and projected in geographic coordinates/WGS84 can be

employed.
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Once coregistration is finalized, it is

recommended to visually inspect

the stack's quality. This can be

achieved through an RGB

representation of the reference and

secondary products, indicating if the

images are appropriately aligned:

Right-click on the output

coregistrated product – Open RGB

Image Window

Choose the reference for red and

green channels, and the secondary

image for the blue channel.Click OK.



Zoom into a region with contrasting surfaces, such as the boundary

between land and water. The RGB image should be clear and sharp,

without being overly influenced by one of the images (e.g., appearing

yellow for the reference or blue for the secondary image). The only

acceptable exceptions are changes in land cover or scattering mechanisms

which occurred in the time between the image acquisitions.

2.4 Forming a Raw Interferogram

The next phase of interferometry involves generating an interferogram

using the coregistered SLC images. To do this, follow these steps:

From the main menu bar, go to Radar – Interferometric - Products and

finally select Interferogram Formation.

In the I/O Parameters tab, choose the "Orb_Stack" product that was

generated during the coregistration process.

By default, the output target is set to the same directory and appends "ifg"

to the filename.

For standard processing, there's no need to modify the defaults in the

Processing Parameters tab.
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Raw Interferogram — Phase Image should appear int he View tab.

The interferogram is displayed in a rainbow color scale ranging from -

topography, atmosphere and potential surface deformation (considered

zero). The patterns, also called fringes appear in an interferogram as

cycles of arbitrary colors, with each cycle representing half the sensor’s

wavelength.

2.5 TOPS Debursting

The next stage in interferometry using Sentinel-1 TOPS mode (IWS) data

involves "debursting" or merging the bursts to remove the seamlines, a

step not required with Sentinel-1 or other stripmap SAR data.

To perform debursting, follow these steps:

From the main menu bar, navigate to Radar, then Sentinel-1 TOPS, and

finally S-1 TOPS deburst.

In the I/O Parameters tab, choose the "Orb_Stack_ifg" product generated

during the interferogram formation process. By default, the output

appends "deb" to the filename.

There is no need to make changes in the Processing Parameters tab.
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2.6 Goldstein Phase Filtering

There are two methods to minimize noise in the interferogram: filtering

and multi-looking. While our standard procedure involves applying filtering

initially, it's also possible to opt for multi-looking first.

To begin filtering:

Go to Radar, then Interferometric, then Filtering, and select Goldstein

Phase Filtering from the top main menu bar.

In the I/O Parameters tab, choose the "deb" product generated in the

previous step.

By default, the output name includes "flt."

There's no necessity to adjust the default settings in the Processing

Parameters tab for basic processing.

Create subset (optional)

In the earlier stages of processing, empty pixels along the interferogram's

perimeter may have been created, particularly in regions not overlapped

by both input images. To remove these sections, employ the Subset

function found under Raster. This approach will also decrease processing

time in subsequent stages, especially when the analysis is concentrated on

a specific area rather than the entire scene.
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Double-click on the output

raster in the Bands folder of

the new product to see the

result.



2.7 Phase Unwrapping

Unwrapping in SNAP follows three distinct steps:

1. Export of the wrapped phase (and definition of the parameters)

2. Unwrapping of the phase (performed outside SNAP by snaphu)

3. Import of the unwrapped phase back into SNAP

Export of the wrapped phase

Export your interferogram or your subset interferogram from Sentinel-1

Toolbox to SNAPHU:

From the top main menu bar, navigate to Radar > Interferometric >

Unwrapping > Snaphu Export:

In the Snaphu Export window:

In Read tab, select the product created in the previous step

In Snaphu Export tab, you also need to specify a target folder for exported

files. Create a new target folder for this step by entering a path and new

folder name (e.g. „snaphu_export). If the selection of the directory does

not work, simply copy and paste the path of your working directory into

the text field.

In Snaphu Export tab, select TOPO as Statistical-cost mode and select 200

pixels for Row Overlap and Column Overlap if you want to multilook.

Depending on the number of processors of your computer, you can also

increase the Number of Processors variable.

Select MCF.

Click Run to create the SNAPHU_Export file

The folder now holds files used for phase unwrapping: the coherence

image (*.img) and metadata (*.hdr), the wrapped phase: image (*.img)

and metadata (*.hdr), the unwrapped phase: only the metadata (*.hdr),

because the image (*.img) is first to be created by snaphu in the next

step, a configuration file (snaphu.conf) containing the parameters defined

in the export operator
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Unwrapping of the phase

You should see the wrapped interferogram phase “Phase_ifg*.img”,

coherence “coh_*.img”, and a “snaphu.conf” file.

For the next step, you will need to instal SNAPHU in Windows. SNAPHU is a

tool for phase unwrapping of interferometric information. To use it as an

executable file (*.exe) in Windows it has to be compiled first so all required

drivers (*.dll) are installed correctly. Follow the steps for installation here:

file:///C:/Users/Ona%C4%8Dillov%C3%A1/Downloads/Installation_SNAPH

U_English_ABraun.pdf

To start unwrapping, check the location of the interferogram exported from

SNAP. If snaphu.exe is not in your system’s PATH variable: Copy it in there

as well. It is recommended to store the data and snaphu on the same disk.

Open Command Window Here.

Type snaphu and hit Enter. The help menu should be displayed.

The command to start the unwrapping is shown in the file snaphu.conf.

Open it with a text editor. The beginning of the “snaphu.conf” file shows

the command to call Snaphu
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The Snaphu program can take a long time to run. At the end it writes

unwrapped phase to “Unw_ifg*.img” file

Import of the unwrapped phase

Now, we import the unwrapped phase. From the top main menu bar, select

Radar > Interferometric > Unwrapping, and then Snaphu Import that

converts it back into the BEAM DIMAP format and adds the required.

Read-Phase: should be set to the wrapped product that you

exported(before the export)

Read-Unwrapped-Phase: select the unwrapped phase product: Navigate to

folder where you exported for Snaphu. Select the

“UnwPhase_ifg*.snaphu.hdr” file. Note: The error message will then vanish

if you proceed to the next tab.

SnaphuImport: Leave the option “Do NOT save Wrapped interferogram in

the target product”

unchecked, because it is required in the later step.

Write: To store the imported unwrapped band in a separate product

(recommended), add ‘_unw’ to the end of the output name and click Run.

Finally, a new product is added to the Product Explorer which contains the

the unwrapped phase that we can display.

13



Select the Unw_Phase_ifg band. Double click on this unwrapped phase to

see if the unwrapping was successful. It should be a smooth raster with

little variation except for the areas of expected deformation.

All fringe patterns are summarized to absolute changes. Go to the Colour

Manipulation tab and select “100%” to stretch color scale to full range of

unwrapped data. Unwrapped phase is still in radians. Phase is reference

image minus coregistered image. If reference image is earlier, then

negative phase is land moving toward satellite (negative range change)
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Create subset (optional)

In the earlier stages of processing, empty

pixels along the interferogram's perimeter

may have been created, particularly in

regions not overlapped by both input

images. To remove these sections, employ

the Subset function found under Raster.

This approach will also decrease processing

time in subsequent stages, especially when

the analysis is concentrated on a specific

area rather than the entire scene.



2.8 Phase to elevation

The unwrapped phase data is now a continuous raster, but it has not yet

been converted into a metric measure. To achieve this conversion from

radian units to absolute heights, the Phase to Elevation operator, found

under Radar > Interferometric > Products, is employed. This operator

translates the phase values into surface elevations along the line-of-sight

(LOS) in meters. The LOS represents the direct line between the sensor

and a specific pixel. To ensure accuracy, a Digital Elevation Model (DEM) is

utilized to align the elevation values correctly.

The I/O Parameters tab should be set to the last subset unwrapped

product

Default for target product name is to add “_dem” to the name

Navigate to the Processing Parameters tab and select SRTM 1Sec HGT

(AutoDownload) as the input DEM.
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Now, we can display elevation result. Again, better to stretch colors.

Displacements is now in meters.

Sign was changed so positive displacement is “up” towards satellite

Profile plot
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2.9 Terrain Correction

SNAP calls geocoding with topography “Terrain Correction.” From the top

main menu bar, select Radar, then Geometric, then Terrain Correction, and

then Range-Doppler Terrain Correction.

The I/O Parameters tab should be set to the last elevation product

Default for target product name is to add “_TC” to the name

Under Processing Parameters tab, select the elevation band as the input

Select SRTM 1Sec HGT (AutoDownload) as input DEM.

If you want to export the data as a KMZ file to view it in Google Earth,

WGS84 must be selected as Map Projection (latitude and longitude).

If you want to compare the quality of the InSAR DEM, you can select DEM

as a further output.
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Now, double-click on the „elevation“ raster to display the geocoded

elevation raster output. Product is now evenly spaced in latitude and

longitude and shows the elevation for the study area. You can create

profile to see the elevation diversity.

2.10 Export .kmz to Google Earth

Geocoded products (projected to WGS84) can be exported as a KMZ file to

view in Google Earth (Pro):
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Select an appropriate

color scale and color

ramp from the Color

Manipulation tab.

Right click on the

elevation raster in the

View tab (or navigate

to File > Export >

Other > View As

Google Earth KMZ)

Choose a directory to

save the output .kmz

and provide a fitting

filename, then confirm

with Save.



Open the resulting KMZ file in Google Earth to observe the elevation

patterns overlaid on the satellite image base map.

Compare with LiDAR-derived DEM

Compare your Sentinel-1 derived DEM with Digital Elevation Model (DEM

5.0) with a resolution of 1 meter per pixel created from airborne laser

scanning data by ÚGKK SR. „Source of ALS data: ÚGKK SR“.

Open QGIS and comapre small LiDAR-derived DEM sample with our

resulted DEM derived using Sentinel-1 data. We can observe that there are

small differences in the elevation.
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Comparing Sentinel-1 derived DEMs and LiDAR derived DEMs, LiDAR

typically offers higher precision. This is because LiDAR directly measures

the distance between the sensor and the Earth's surface using laser pulses,

resulting in highly accurate elevation data. On the other hand, Sentinel-1

derived DEMs are generated using synthetic aperture radar (SAR) data,

which can be affected by factors such as vegetation cover and terrain

roughness, potentially leading to less precise elevation measurements

compared to LiDAR. Therefore, in terms of precision, LiDAR derived DEMs

are generally considered more accurate and reliable.

However, Sentinel-1 derived DEMs may be more cost-effective compared to

LiDAR due to the lower cost associated with satellite data acquisition and

processing. In this case, Sentinel-1 data are free of charge, available for

everyone after the registration. Also, for large-scale mapping, monitoring,

or areas with limited budget or accessibility, Sentinel-1 derived DEMs may

be preferable.

For more information, see the lecture: 3. SAR remote sensing for land

applications 2 – Introduction to Interferometric SAR
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EXERCISE 4 – TUTORIAL

Forestry with Sentinel-1: Single Image Analysis and

Time Series to detect forest change using SNAP

software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 Generate Radiometrically Terrain Corrected (RTC) Images from
Sentinel-1 GRD products to monitor forest extent, structure and

biomass

 Perform statistical analyses using Scatterplots, Histogram Analysis,
Profile Plot etc.

 Process SAR data with SNAP using single-date and multi-temporal
processing and generate time series analysis of multi-temp dataset

 Emphasize the critical role of SAR in sustainable resource
management and forest conservation

1 | Exercise outline

1



Forestry Mapping with Sentinel-1 data

Sentinel-1 synthetic aperture radar (SAR) data presents a versatile tool

for comprehensive forestry mapping and monitoring. By analyzing SAR

images acquired at different times, changes in forest cover can be

effectively detected, providing insights into deforestation, reforestation,

and forest degradation.

Sentinel-1 has a significant potential in sustainable forest management

through its ability to detect clear-cut and partial-cut areas, classify forest

types, estimate biomass, and identify disturbances. Regarding climate

change mitigation, the mapping of forest fire scars using Sentinel-1 data

is crucial for understanding a forest's carbon history and accurately

estimating carbon emissions.

Additionally, SAR data allows for the classification of various forest cover

types, aiding in forest management and conservation efforts.

Furthermore, SAR data offers valuable information for assessing habitat

quality and carbon stocks.

2 | Background

2

Source: https://sentinels.copernicus.eu/documents/247904/3428726/Sentinel-
1-2-rubber-plantation-full.jpg



2.1 Study area and data used

For this exercise, we will use two Sentinel-1 GRDH images using dual

polarization (VV/VH) acquired in interferometric wide swath mode for the

area in Paraguay, downloaded from the Dataspace Copernicus Open

Access Hub [@https://dataspace.copernicus.eu/].

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open one of the downloaded

products by double click on the zipped folders. The opened products will

appear in Product Explorer window. The Navigation and World View tabs

above the preview window can help you to locate the scene.

S1B_IW_GRDH_1SDV_20210510T092747_20210510T092812_026840_0334D4_5415.SAFE

To access the information within the product, double-click on it to reveal

the directories, open the Metadata folder and double click on Abstracted

Metadata.

If you open one of the bands of the image by double clicking the band

name, you can see also information on the pixels in the scene by

opening the tab Pixel Info (next to Product Explorer) and sliding the

mouse over the pixels of interest.
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A: SINGLE-DATE ANALYSIS

Create a subset

There is no need to process the whole image, instead, we can reduce the

loaded data to a more manageable size – creating subset. This approach

will decrease processing time in subsequent stages, especially when the

analysis is concentrated on a specific area rather than the entire scene.

You can define the subset area by either zooming into the region of

interest or by defining pixel or geographic coordinates. In this exercise we

use the following geographic coordinates, that you can enter manually:

Navigate to Raster – Subset tab

and at Switch to “Geo Coordinates” in Spatial Subset tab

Enter the following numbers:

North latitude bound: -22.774

West longitude bound: -60.334

South latitude bound: -23.278

East longitude bound: -61.631

Confirm with OK.
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The new subset will appear in your Product Explorer window. You can

open one of its bands by double-click on the selected band if you expand

Bands folder within the product.
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Apply orbit file

• Navigate to Main Menu – Radar – Apply orbit file

• In the I/O Parameters tab, select the subset product and name the

target product. There is no need to save the output as BEAM-DIMAP

• In the Processing Parameters accept the default settings and select the

option „Do not fail if new orbit file not found“

Note: If precise orbits are not yet available for your product, restituted

orbits can be selected which may not be as accurate as the Precise orbits

but will be better than the predicted orbits available within the product.

Apply radiometric correction

• Go to Radar > Radiometric > Calibrate and select the result product from

previous step

• Under the Processing Parameters tab select both polarizations and select

the Output beta0 band option. The radiometric correction is necessary

to remove any image-dependent radiometric bias.
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Radiometric Terrain Flattening

• Flatten Terrain

• Go to Radar > Radiometric > Radiometric Terrain Flattening

• Under Processing Parameters select SRTM 1Sec HGT (Auto Download)

• For DEM Resampling Method, use Bicubic_interpolation

The output of this process will be transformed Beta0 into Gamma0

Multilooking

Go to Radar > Multilooking:

In “Processing Parameters” multilook the image by a factor 5x5 - change

“Number of Range Looks” and “Number of Azimuth Looks” both to 5. If the

"GR Square pixel" option is enabled, an equal number of looks will be

applied in both the azimuth and range directions.
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Create elevation band

Go to Raster > DEM Tools >

> Add Elevation Band:

• Select the appropriate elevation

band to add to the image, e.g.

SRTM 3 sec (AutoDownload)

• After having added the elevation

band, go to Radar > Geometric >

Terrain Correction > SAR Simulation

and run the SAR simulation.
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Terrain Correction

Go to Radar > Geometric > Terrain Correction > Range-Doppler Terrain

Correction

• In the I/O Parameters select the last simulated product

• Under Processing Parameters tab select:

- Digital Elevation Model: SRTM 3Sec (Auto Download)

• - DEM Resampling Method: Bilinear Interpolation

- Check the “Mask out areas without elevation” box

- Check the “Apply radiometric normalisation” box

Convert gamma0 to dB

In the Product Explorer select first the Gamma0_VH band, then go to

Raster > Data Conversion > Linear to/from dB and repeat with the

Gamma0_VV band.

This will create two Virtual bands (with a V icon). Right click on each >

Convert Band to transform them.

Compute difference image from gamma0 [dB]: VV-VH

Open Raster > Band Maths:

Name it “Gamma0-VV_VH”. Click on ‘Edit Expression’ and enter the

expression Gamma0_VV_dB – Gamma0_VH_dB

Convert virtual raster
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Display as RGB view

Go to Window > Open RGB Image Window (or right-click on the last

product in the Product Explorer and Open RGB window) and select:

Red: the difference band „Gamma0_VV_VH“

Green: „Gamma0_VH_db“

Blue: „Gamma0_VV_db“
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Statistical analysis

Scatterplot

Open Analysis > Scatter Plot and in the right panel select the

Gamma0_VH_dB as X-axis input and Gamma0_VV_dB as Y-axis input,

then click the Refresh View button.

Histogram

Select e.g. the Gamma0_VH_dB band and open Analysis > Histogram.

Click the Refresh View button.
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Profile Plot

Select the Gamma0_VV_VH band. In the toolbar select the Polygon or the

Line tool and draw a shape on your region of interest. Open Analysis >

Profile Plot. This operation can be done for any of the other bands.
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B: MULTITEMPORALANALYSIS

Load both Sentinel-1 products by navigating to File - Open Product.

Build a pre-processing graph

Use the graph builder tool to create workflow for data processing:

Go to Tools>GraphBuilder

Right click and add, in the order below, each of the preprocessing steps:

The first tool is Read

Add>Radar>Apply-Orbit-File and keep pre-defined parameters. Check „Do

not fail if new orbit file is not found“

Add>Radar>Radiometric>Calibration and select Output beta0 band

Add>Radar>Radiometric>Terrain Flattening will add terrain flattening

Add>Radar>Geometric> Terrain Correction>Terrain Correction

The last tool is Write

Click on each tool, and connect them by dragging the red arrows from one

tool to the next, respecting the order above

Then got to File>Save Graph to save the workflow as a XML file.
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Batch processing

Navigate to Tools > Batch Processing:

Using the Add opened symbol select the files you want to process.
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Using the Load Graph button, load the .xml-file you just saved

Adjust the output folder, click Run.

Note: this step might take several minutes/hours to run.
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View the output product, e.g. by doulble-click on Gamma0_VH terrain

corrected band.

Create stack

Go to Radar > Coregistration > Stack Tools > Create Stack

In the CreateStack tab, select Product Geolocation as Initial Offset Method

In the Write tab, adjust the stack name if needed, adjust the output folder

and click Run. This step will might take few minutes.
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Convert bands to dB

In the Product Explorer select the processed Gamma0_VH band, then go to

Raster > Data Conversion > Linear to/from dB and repeat with the

Gamma0_VV band.
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Display an RGB

Right-click on the last product – Open RGB Image Window and select

different band combinations to see the change of backscatter between

different acquisitions. Explore values over forest area and fields.
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Time Series Analysis (using single scenes, not a stack)

Tool cannot use a stack, it needs single images instead

Navigate to View > Tool Windows > Radar > Time Series to open the Time

Series tab at the bottom left of your SNAP window.

Click on Settings (top right of Time Series tab) and add individual (pre-

processed) images. Click Apply.

Using the time series tab, hover your mouse over the area to see

the behaviour of single pixels over or use Pin Manager to see the behaviour

of the selected Pins.

Explore values to identify forest area and fields.

For more information, see the lecture: 4. SAR remote sensing for forestry
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EXERCISE 5 – TUTORIAL

Crop Classificat ion with S1 and S2 data using the

SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 Use radar (Sentinel-1) and optical (Sentinel-2) data to classify and
analyse different crop types and their health over an area

 Data pre-processing will be perfomed, an then the crop types will
be estimated by classification of the data, based on the Random
Forest algorithm

 Land crops growth and health will be observed using NDVI time
series

1 | Exercise outline
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Crop classification using Sentinel-1 and Sentinel-2 data

Crop classification using Sentinel-1 data relies on the radar backscatter

signals obtained from the satellite. The backscatter intensity, polarization,

and texture of the radar imagery are analyzed to distinguish between

different crop types.

Supervised classification methods involve training a classifier with labeled

samples of land cover types, while unsupervised methods group pixels

based on their spectral similarity without prior training. The accuracy of

the land cover classification is validated using ground truth data, and the

results can be refined iteratively to improve accuracy. The final land cover

maps provide valuable information for various applications, including

urban planning, agriculture, forestry, and environmental monitoring.

2 | Background
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2.1 Study area and data used

For this exercise, we will use Sentinel-1 and Sentinel-2 images to explore

fields in Kacik, near Gdansk and Baltic Sea coast northern Poland,

downloaded for year 2023 from the Dataspace Copernicus Open Access

Hub [@https://dataspace.copernicus.eu/].

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open Sentinel-1 GRDH

downloaded products with HH and HV polarizations acquired on 11 July

2023 by double click on the zipped folders. The opened products will

appear in Product Explorer window:

S1A_IW_GRDH_1SDV_20230711T050035_20230711T050100_049371_05EFD9_7392.SAFE

Click + to expand the content of product, then expand Bands folder and

double click on Intensity_VV band to visualize it. Depending on your

computer's capabilities, this process could take some time. To minimize

the data load, the next step involves creating a subset that encompasses

only a portion of the dataset.
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3. Pre-processing

For classification purposes, three bands are utilized per acquisition: VV (or

HH for Sentinel-1), VH, and their ratio VV/VH (or HH/VH for PALSAR). Out

of the 13 bands per Sentinel-2 data acquisition, only the 10 with spatial

resolutions of 10 m or 20 m are utilized.

3.1 Sentinel-1 preprocessing

The Sentinel-1A data were obtained in IW mode and retrieved from the

ESA Scientific Data Hub at https://scihub.copernicus.eu/ in GRDH format.

These data require calibration (converting from Digital Numbers to Radar

Backscattering Coefficient s0) and orthorectification (transforming from

image geometry to a geographical projection) within a geographical

subset. Subsequently, a filter is applied to mitigate Speckle noise, which is

inherent in radar imagery.

Apply orbit file

Satellite positions are recorded using a Global Navigation Satellite System

(GNSS). To ensure the fast delivery of Sentinel-1 products, orbit details

produced by an onboard navigation system are included in the Sentinel-1

products. Subsequently, the Copernicus Precise Orbit Determination (POD)

Service further enhances the accuracy of the orbit positions.

Navigate to Main Menu – Radar – Apply orbit file

In the I/O Parameters tab, select the first product and name the target

product. There is no need to save the output as BEAM-DIMAP (we will save

the time this way)

In the Processing Parameters accept the default settings and select the

option „Do not fail if new orbit file not found“

Note: If precise orbits are not yet available for your product, restituted

orbits can be selected which may not be as accurate as the Precise orbits

but will be better than the predicted orbits available within the product.
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Speckle Filter

Despeckling removes thermal noise introduced by the sensor from the

image to remove potential sources of error in analysis.

Navigate to Radar > Speckle Filtering > Single Product Speckle Filter:

In the Processing Parameters tab, choose the Lee filter with default

window sizes and click Run.

Note: Selecting the size of the speckle filter depends on the targets (point

target, distributed target) and the target size (for example field sizes).

Open the output of the Lee sigma filter and compare it with the image

before Speckle filtering. Filtered image looks sharpened and without noise

comparing with the image before applying Speckle filter.
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Calibration

S1 Level-1 products are not radiometrically corrected or calibrated, by

default1. Radar reflectivity is stored as Digital Numbers (DNs) in S1

products, and must be converted to physical units (radar backscatter).

Navigate to Main Menu – Radar – Radiometric – Calibrate

In the I/O Parameters tab, select the last filtered product and name the

target product.

In the Processing Parameters you can select one or both polarization and

accept all default settings and then click Run

Terrain-Correction

The last step in our graph for image pre-processing is to apply terrain

correction to the product, ensuring that all the pixels are moved to the

right locations (eg if the nadir angle of the image is off, it will align the

pixels correctly so it is closer to a top-down view of the imagery).

Navigate to Main Menu: Radar - Geometric - Terrain Correction - Range-

Doppler Terrain Correction

In the I/O Parameters tab set as “Source Product” the last calibrated

product.

In “Target Product”, keep the default name and set the Directory

In the Processing Parameters tab set:

Digital Elevation Model: SRTM 3Sec (Auto Download)

Map Projection: WGS84(DD)

Keep defaults values for the other parameters. Click Run. Approximate

processing time: 2.5 minutes.
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3.1 Create subset

There is no need to process the whole image, instead, we can begin by

narrowing down the scene to a more manageable size – creating subset.

This approach will decrease processing time in subsequent stages,

especially when the analysis is concentrated on a specific area rather than

the entire scene.
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Go to the Subset tab and at

“Geo Coordinates” set:

North latitude bound: 54.00

West longitude bound: 18.75

South latitude bound : 53.90

East longitude bound : 18.88

Note: There is no need to

wait till thumbnail image will

be created when entering

coordinates.



Visualize the final subset image using RGB:

Go to Window > Open RGB Image Window (or right-click on the last

product in the Product Explorer and Open RGB window) and select the

band combinations for final RGB image: VH, VV, VV/VH.
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Visualize the output subset by double-click on VH and VV polarization.



2.4 Image classification

We will perform a random forest classification. For this we will create some

training data by identifying polygons containing the different crop/land

cover types:

– wheat

- maize

- Rapeseed

- barley

- grassland

- river

Select the last subset product by clicking on it. Navigate to Vector > New

Vector Data Container.

Create new data containers – separate for each type of ice mentioned above.

Start with creating the data container for, e.g. „wheat“.Click OK.

The newly created vector data container should appear under "Vector

Data" in the Product Explorer. Now let´s start creating training polygons for

these different containers on ice type using the Polygon drawing tool:

Repeat this step and create training polygons for all remaining classes.
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Wheat (red), maize (violet), rapeseed (light blue), barley (cyan), grassland

(green) and water (blue) training polygons. Save the final product with

your created vector data containers to your folder.
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Random Forest image classification

Navigate to Raster > Classification

> Supervised classification >

Random Forest Classifier

• In the ProductSetReader tab select

the saved product with your

training data.

• In the Random-Forest-Clasiffier

select the classes/training vectors

(all polygon vector containers) and

feature bands (select both

Sigma0_VH and Sigma0_VV

polarisations) that you’d like to

include into image classification.

• In the Write tab by default, the

output target is set to the same

directory and appends „RF" to the

filename.

•Click RUN.



2.5 Post-processing

The final product should now appear in the ProductExplorer. Visualize this

output classified image and classes by double-click on the layer

„LabeledClasses“ under Bands folder in the Product Explorer.

Navigate to Colour Maniulation tab to change the colours of individual crop

type classes and other ones and explore the frequency and distribution of

these classes through the classified image and table.
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2.6 Crop types characteristics using spectral indices

Now, let´s explore also Sentinel-2 data for the same area.

• Navigate to the Copernicus Browser website:

• https://browser.dataspace.copernicus.eu

• Create the area of interest by using rectangle.

• For the best results, search for Sentinel-2 L2A products with low cloud

cover, e.g. less than 6%.

• Set the time range from 01-04-2023 to 31-09-2023 to monitor crops

during the growth season. And click on Search.

• Visualise at least one of the images – start e.g. from 10-04-2023 and

select, e.g. NDVI layer.

• At the top right panel select Histogram option.

• Explore NDVI values for the selected image.
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Then, move to another date, e.g. 27-05-2023 and click on „Recalculate“ to

refresh the histogram values for this acquisition date. Explore the NDVI

values during the growth season by visualising histogram for NDVI values

of several dates.
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During the growth season, NDVI (Normalized Difference Vegetation Index)

values typically exhibit fluctuations reflecting changes in vegetation

dynamics. At the beginning of the season (April), NDVI values may be

relatively low as vegetation starts to emerge and develop. As the season

progresses and vegetation becomes more abundant and healthier, NDVI

values tend to increase, reaching their peak during the peak of the growing

season when vegetation is at its fullest and most vibrant (May). This period

is characterized by high NDVI values, indicating dense and healthy

vegetation rich in chlorophyll and other nutrients. After reaching the peak,

NDVI values may start to decline as vegetation undergoes senescence or

experiences stress due to factors such as water scarcity or disease (June-

September). Monitoring NDVI values throughout the growth season

provides valuable insights into vegetation health, growth patterns, and

overall ecosystem dynamics.

For more information, see the lecture: 5. SAR and optical remote sensing

for precision agriculture 1
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EXERCISE 6 – TUTORIAL

Crop Classificat ion with S1 time series data using the

SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 Use radar Sentinel-1 data to classify and analyse time-series for
different types of crop fields

 Data pre-processing will be perfomed, an then the crop types will
be estimated by classification of the data, based on the Random
Forest algorithm

 Land crops growth and health will be observed using RGB
composites and backscatter values of different crop types using
time series

1 | Exercise outline
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Crop classification using Sentinel-1 time-series

Crop classification using Sentinel-1 data involves the analysis of radar

backscatter signals to differentiate between different types of crops based

on their unique radar signatures.

Sentinel-1 data, with its frequent revisit times and all-weather capability,

is particularly useful for crop classification as it provides consistent and

reliable information regardless of weather conditions.

Crop classification using Sentinel-1 data relies on the radar backscatter

signals obtained from the satellite. The backscatter intensity, polarization,

and texture of the radar imagery are analyzed to distinguish between

different crop types.

2 | Background

2

CREDIT: ESA/MDA

These images show the same multi-temporal radar composite acquired over the

Flevoland test site in the Netherlands. The grainy appearance of the left image is
characteristic of radar images and often a limiting factor in using them at high
resolution. The right image demonstrates how a new mathematical technique
based on multiple images, which was improved in the campaign, can dramatically

enhance the appearance of the image and data quality.



2.1 Study area and data used

For this exercise, we will use three Sentinel-1 images to explore fields in

Orleans, France, downloaded for year 2023 from the Dataspace

Copernicus Open Access Hub [@https://dataspace.copernicus.eu/].

2.2. SNAP - Open and explore products

Open SNAP Desktop, click Open Product and open three Sentinel-1 GRDH

downloaded products with HH and HV polarizations acquired on 11 July

2023 by double click on the zipped folders. The opened products will

appear in Product Explorer window:

S1A_IW_GRDH_1SDV_20230308T174046_20230308T174111_047556_05B5EA_6563.SAFE

S1A_IW_GRDH_1SDV_20230519T174049_20230519T174114_048606_05D890_2249.SAFE

S1A_IW_GRDH_1SDV_20230730T174053_20230730T174118_049656_05F897_BEA3.SAFE
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3. Pre-processing

3.1 Create subsets

There is no need to process the whole image, instead, we can begin by

narrowing down the scene to a more manageable size – creating subset.

This approach will decrease processing time in subsequent stages,

especially when the analysis is concentrated on a specific area rather than

the entire scene.
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Go to the Subset tab and at “Geo Coordinates” set:

North latitude bound: 48.10

West longitude bound: 1.40

South latitude bound : 48.20

East longitude bound : 1.50

Note: There is no need to wait till thumbnail image will be created when

entering coordinates.

Save the output subsets to your folder – we will need them for the next step.



3.2 Build a pre-processing graph

Use the graph builder tool to create workflow for data processing:

Go to Tools > GraphBuilder

Right click and add, in the order below, each of the preprocessing steps:

• The first tool is Read

• Add>Radar>Radiometric>Calibration

• Add>Radar>Speckle Filtering>Speckle-Filter

• Add>Radar>Geometric>Terrain Correction>Terrain Correction

• Add>Raster>Data Conversion>LinearToFromdB

• The last tool is Write

Click on each tool, and connect them by dragging the red arrows from one

tool to the next, respecting the order above.
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Leave the default parameters for individual tools, except Speckle-Filter:

- here, select Filter: Lee

Then got to File>Save Graph to save the workflow as a XML file

„crops_graph“.

Batch processing

Navigate to Tools > Batch Processing:

Using the Add opened symbol select the files you want to process.

Using the Load Graph button, load the .xml-file you just saved

6



Adjust the output folder, click Run.

Note: this step might take several minutes to run.

When the process finishes it opens all of the output products in the Product

Explorer window.

Create stack

Go to Radar > Coregistration > Stack Tools > Create Stack

In the Product-Set-Reader tab select the last three products from the

previous step.
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In the CreateStack tab, select Product Geolocation as Initial Offset Method

(Note: we did not use apply orbit file function, but the product geolocation

is accurate enough for the purpose of our analysis)

In the Write tab, adjust the stack name if needed, adjust the output folder

and click Run. This step will might take few minutes.

After the process is finished, we can see the new final „Stack“ product in

the Product Explorer window.

Display RGB time series

Now we can look at some RGB composites of this time series

Right-click on the last „Stack“ product – Open RGB Image Window and

select different band combinations to see the change of backscatter

between one-day acquisition.

Firstly, we can look at polarimetric composite of the same day. For this,

select:

Red: Sigma0_VV_db_mst_08Mar2023

Green: Sigma0_VH_db_mst_08Mar2023

Blue: Sigma0_VH_db_mst_08Mar2023-Sigma0_VV_db_mst_08Mar2023
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Another RGB composition we can generate is to look at images of the same

polarisation but for different dates:

9

Right-click on the last „Stack“

product – Open RGB Image

Window and select different band

combinations to see the change

of backscatter for different

acquisitions. For this, select:

Red:

Sigma0_VH_db_mst_08Mar2023

Green:

Sigma0_VH_db_slv_18May2023

Blue:

Sigma0_VH_db_slv_30Jul2023



Time Series Analysis (using single scenes, not a stack)

Tool cannot use a stack, it needs single images instead

Navigate to View > Tool Windows > Radar > Time Series to open the Time

Series tab at the bottom left of your SNAP window.

Click on Settings (top right of Time Series tab) and add individual (pre-

processed) images. Click Apply.
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Select also polarisation for which you want to explore time-series and click

OK.

Using the time series tab, hover your mouse over the area to see the

behaviour of single pixels over or use Pin Manager (View-Tool Windows-Pin

Manager) to see the behaviour of the selected Pins.

Explore backscatter values of different crop types within the time range.

For more information, see the lecture: 6. SAR and optical remote sensing

for precision agriculture 2
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https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_06.pdf
https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_06.pdf


EXERCISE 7 – TUTORIAL

Wildfire Mapping with Sentinel-1 & Sentinel-2 using

the SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 Detect wildfires on Sentinel-1 and Sentinel-2 images

 Export subset as image to perform another analysis in QGIS

 Map burned areas and quantify burn severity using Normalised
Burn Ratio index

 Develop a graph for automated processing using Batch processing

 Create Stack and RGB composites for two Sentinel-1 temporal
datasets to observe wildfire burn scars

1

1 | Exercise outline



2 | Background

The wildfires around the important riverside port of Rosario, essential for

transporting Argentina's extensive grain harvest, have raised concerns

among local residents and activists.

Fires in the grasslands close to a vital South American river delta present

serious threats to both nearby wetland ecosystems and human well-

being, caution environmental experts. The wildfires around the important

riverside port of Rosario, essential for transporting Argentina's extensive

grain harvest, have raised concerns among local residents and activists.

The Parana River, South America's second-longest river after the

Amazon, experienced its lowest water levels since 1944 in 2021 as

reported by official data. This decline is attributed to multiple cycles of

drought and reduced rainfall in upstream Brazil. In August 2022, the

water level remained exceptionally low. The wildfires, many intentionally

set by farmers preparing the land for new crops, generated a thick haze

that reached Buenos Aires, located approximately 190 miles (300 km)

south of Rosario. Residents were displeased with the presence of soot in

the air, leading popular weather apps to issue forecasts simply describing

the conditions as "smoke."

2

Fires in the grasslands

close to a vital South

American river delta

present serious threats

to both nearby wetland

ecosystems and human

well-being, caution

environmental experts.

Wildfires burning in the wetlands of the Paraná River Delta, Argentina, 
19 August, 2022



2.1 Study area and data used

For this exercise, we will use two Sentinel-2 images and two Sentinel-1

GRDH images of the same area in Paraná River Delta, Argentina, using

the Tile Number *20HQJ* downloaded for two days of summer 2022

(before and after the wildfires) from the Dataspace Copernicus Open

Access Hub [@https://dataspace.copernicus.eu/].

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open 2 downloaded products

(unzipped) by double click on the metadata „MTD_MSIL2A.xml“ inside

the folder. The opened products will appear in Product Explorer window.

S2A_MSIL2A_20220730T135711_N0400_R067_T20HQJ_20220730T210856.SAFE.zip

S2A_MSIL2A_20220819T135721_N0400_R067_T20HQJ_20220819T211159.SAFE.zip

A: Detecting wildfires on Sentinel-2 image

1. Select the first product in the Product Explorer window.

2. Right click on the product.

3. Open RGB Image Window.

4. In the pop-up window select ‘Sentinel 2 MSI Natural colors (Red: B4;

Green: B3; Blue: B2)’.

5. Repeat the process for the second product.

6. Tile two opened RGB Windows, e.g. horizontally

7. In the Navigation window, zoom in to the wildfire region and

syhnchronise views to see the same area before and after wildfires
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Fire + cloud plume map

Do the same process for obtaining the color composition in false colors:

1. Select the first product in the Product Explorer window.

2. Right click on the product.

3. Open RGB Image Window.

4. In the pop-up window select ‘Sentinel 2 MSI Atmospheric penetration

(Red: B12; Green: B11; Blue: B8A)’.

5. Apply color manipulation (stretching) for RGB

6. Repeat the process for the second product.

7. Tile opened RGB Windows, e.g. evenly

8. If necessary, in the Navigation window, zoom in again to the wildfire

region and syhnchronise views to see area before and after wildfires

Now let’s detect the smoke plume:

1. Keep only the Sentinel 2 MSI Atmospheric penetration composition

with visible smoke plume from 19 August open

2. Go to Mask Manager, and scroll down to the Maths masks

3. Select: “scl_cloud_medium_prob“ and “scl_cloud_high_proba“

4. To visualize the masked areas better, lower the transparency(e.g. 0.1)
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Let’s export this View as an image and safe as a GeoTIFF:

Because of multiple S2 spatial sizes, we first have to resample the data.

Resample to highest spatial resolution: 10 m (e.g. B2).

Raster->Geometric->Resampling:

• Keep I/O names

• In Resampling Parameters, select B2 (10 m)
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Let’s create a subset based on the current view

• Display the image. Note that now many more color options are

available. Select MSI Atmospheric penetration

• Make a zoom and add the cloud masks again

• Right-mouse button -> Spatial Subset from View – in the Band Subset

you can select all or only few bands to be exported
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Let’s reproject the image in Latitude & Longitude coordinates

• Raster->Geometric Operations->Reprojection

• Select the default: Geographic Lat/lon (WGS 84)

• Run (writing might take some time)

Now we can export View as GeoTiff

• Right mouse button: Export View as Image

• Select: Full scene, Full resolution, GeoTIFF
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Now we open the output image in QGIS

• We can overlay it to e.g. Google Satellite or Bing aerial image:

• Web->OpenLayers plugin->Google Maps->Google Satellite

• Move the Subset above the satellite

• Play with Transparency: Properties->Transparency (e.g. 80%)
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B: Burned area mapping with Sentinel-2

How to quantify the impact of the Paraná wildfire?

Let’s have look to the before & after images:

• Open RGB Image Window:

• Select: MSI Atmospheric penetration

• Window-> Tile horizontally, zoom in

Let’s create a cloud mask:

• Go to Mask Manager, and scroll down to the Maths masks

• Select: cloud medium & cloud high probability & Thin cirrus

• To visualize them better, lower the transparency (e.g. 0.1)

Now we make a cloud band based on the selected mask

• Band math expression
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We make a cloud band based on the selected mask

• Navigate to Raster - Band Maths

• Name the new mask: clouds

Adding the cloud mask as a band

• On the image, right click-> Band Maths

• Make sure to deactivate “Virtual”. We want to store the data!

• Go to “Edit Expression”

• Select Clouds

Repeat for the second image
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Vizualize all products

• Windows: Tile evenly

• Navigation: zoom all

Tools – Graph Builder

• Add->Raster->Geometric->Resample

• Add->Raster->Geometric->Subset

• Add->Raster->BandMaths

• Add->Raster->BandMerge

• Save your created graph

11



Tools – Batch processing

This allows to process both images at the same time.

- Click on Add opened

- Load your graph

- Make sure to refresh
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Resample

• Select a reference band: B2 at 10 m.

• Resampling method: Bilinear

Subset

• Select bands: B3, B8, B12, Cloud_mask

• Select Geographic coordination

• Click on A, zoom in to the area of interest

• Select a yellow box within the red square
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Band Math

• Go to “Edit Expression”

• NBR: Normalized Burn Ratio:

(B8-B12)/(B8+B12)

Band merge

• Keep the source bands: NBR, B3, B8, B12, cloud_mask
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Running and visualizing the NBR band

Try a color table:

• Colour manipulation: Open color table, choose a color gradient, e.g.
„derived from meris_cloud“

15



You can also set the position of sliders and color them for better
visualization or change ranges of values in the Table tab.

NBR ranges between -1 and 1. A high NBR value indicates healthy
vegetation. A low value indicates bare ground and recently burnt
areas. Non-burnt areas usually have values close to zero.

Burn severity - dNBR

The difference between the pre-fire and post-fire NBR obtained from the
images is used to calculate the delta NBR (dNBR or ∆NBR), which then can
be used to estimate the burn severity. A higher value of dNBR indicates
more severe damage, while areas with negative dNBR values may indicate
regrowth following a fire. The formula used to calculate dNBR is illustrated

below:

dNBR or ∆NBR = PrefireNBR – PostfireNBR

Go to Raster – Band Maths and Edit Expression
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Recently
burned
areas

Healthy
vegetation



Set the position of sliders and color them for better visualization or change
ranges of values in the Table tab.

NBR ranges between -1 and 1. A high NBR value indicates healthy
vegetation. A low value indicates bare ground and recently burnt

areas. Non-burnt areas usually have values close to zero.

dNBR values can vary from case to case, and so, if possible, interpretation
in specific instances should also be carried out through field assessment;
in order to obtain the best results. However, the United States Geological
Survey (USGS) proposed a classification table to interpret the burn

severity, which can be seen below in the table.
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Unburned



Comparison: Severity map, NDVI and false color composition

To compare different views of the same area and explore it more in detail,

create also NDVI and false color composition. You can observe, that areas
with high NDVI values correspond to the barren areas affected by
wildfires. False color composition also depicts areas affected by fire – these
areas are shown in dark pixels. False color composite B8-B4-B3 of the
Sentinel 2 image (during fire), with superimposed ongoing wildfire sites,

note that the smoke direction is corresponding to the wind direction.
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C: Burned area mapping using Sentinel-1

Load both Sentinel-1 products (pre-fire and post-fire) that you have in tjhe

folder for this exercise by navigating to File - Open Product.
S1A_IW_GRDH_1SDV_20220724T091506_20220724T091531_044240_0547C3_961B.SAFE

S1A_IW_GRDH_1SDV_20220829T091508_20220829T091533_044765_055873_EED3.SAFE

Visualize the input products – open e.g. Intensity_VH for both products by

double-click on it under the Bands folder.

1. Pre-processing

We need to apply identical pre-processing steps to both of our scenes:
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Create subset

There is no need to process the whole image, instead, we can begin by

narrowing down the scene to a more manageable size – creating subset.

This approach will decrease processing time in subsequent stages,

especially when the analysis is concentrated on a specific area rather than

the entire scene.

Select the first product and

Go to the Subset tab and at

“Geo Coordinates” set:

North latitude bound: -33.19

West longitude bound: -58.50

South latitude bound : -33.60

East longitude bound: -60.70

Repeat for the second image.



Thermal noise removal

Navigate to Main Menu – Radar – Radiometric – S-1 Thermal Noise Removal

In the I/O Parameters tab, select the last subset product with applied orbit

file and name the target product. There is no need to save the output as

BEAM-DIMAP (we will save the time this way)

In the Processing Parameters you can select both polarization and make

sure that the “Remove Thermal Noise” option is selected.

Repeat for the second subset image.

20

Calibration

With our image now subsetted and with TNR, we must apply image

calibration. This step is necessary to normalize the values in the image into

backscatter values so we can compare multiple images in a time series.

Navigate to Main Menu – Radar – Radiometric – Calibrate

In the I/O Parameters tab, select the product with thermal noise removal

and name the target product. In the case of this final product of

preprocessing, please, save it to your folder for this exercise

In the Processing Parameters select both bands as input and accept all

default settings and then click Run

Repeat for the second image. The saving might take some time.



Speckle Filter

Despeckling removes thermal noise introduced by the sensor from the

image to remove potential sources of error in analysis.

Navigate to Radar > Speckle Filtering Single Product Speckle Filter. In the

Speckle-Filter tab, choose the simple Lee Sigma filter with default window

sizes.

Terrain-Correction

Our data are still in radar geometry, moreover due to topographical

variations of a scene and the tilt of the satellite sensor, the distances can

be distorted in the SAR images. We need to apply Terrain Correction to

compensate for the distortions and reproject the scene to geographic

projection.

Navigate to Main Menu: Radar - Geometric - Terrain Correction - Range-

Doppler Terrain Correction

• In the I/O Parameters tab set as “Source Product” the speckle-filtered

product.

• In “Target Product”, keep the default name and set the Directory

• In the Processing Parameters tab set:

• Digital Elevation Model: SRTM 3Sec (Auto Download)

• Keep defaults values for the other parameters. Click Run.

Approximate processing time: 2.5 minutes.
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Do not forget to save these two output terrain corrected products. We will

need them saved for the next step.

Create stack

Go to Radar > Coregistration > Stack Tools > Create Stack

In the Product-Set-Reader tab select the last three products from the

previous step.
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In the CreateStack tab, select Product Geolocation as Initial Offset Method

(Note: we did not use apply orbit file function, but the product geolocation

is accurate enough for the purpose of our analysis)

In the Write tab, adjust the stack name if needed, adjust the output folder

and click Run. This step will might take few minutes.

After the process is finished, we can see the new final „Stack“ product in

the Product Explorer window.

2 Display RGB time series

Now let´s have a look at some RGB composite of this time series

Right-click on the last „Stack“ product – Open RGB Image Window and

select different band combinations to see the change of backscatter signal

for different dates:
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Right-click on the last „Stack“

product – Open RGB Image

Window and select different band

combinations to see the change of

backscatter for different

acquisitions. For this, select :

Red: Sigma0_VH_slv_24Jul2022

Green:Sigma0_VV_slv2_24Jul2022

Blue: Sigma0_VH_mst_29Aug2022



Explore the final RGB composite to identify wildfires.

For more information, see the lecture: 7. SAR and optical remote sensing

for mapping wildfires
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THANK YOU FOR FOLLOWING THE EXERCISE!

Wildfires burn scars

https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_07.pdf


EXERCISE 8 – TUTORIAL

Sentinel-1 & Sentinel-2 for Snow and Ice using the

SNAP software and EO Browser

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this firstexercise for mapping snow and ice,we will:

 Learn the basic steps to calculate glacier velocity using Sentinel-1
data

 Perform preprocessing of data

 Use velocity vector to see direction and speed of glacier flow

1 | Exercise outline
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Mapping snow and ice using Sentinel-1 and Sentinel-2 data

2 | Background

3

The Greenland ice sheet ranks as the Earth's second-largest mass of ice.
As the climate undergoes changes, there's a notable increase in surface
melting of the ice sheet, leading to a greater discharge of freshwater into
the ocean. This phenomenon significantly contributes to the global rise in

sea levels.

Monitoring glacier velocity is crucial for understanding glacier dynamics
and its impact on global sea levels. Satellite data serves as a valuable tool
for tracking glacier velocity across expansive areas.

Monitoring glacier velocity is crucial for understanding glacier dynamics

and its impact on global sea levels. Satellite data serves as a valuable tool
for tracking glacier velocity across expansive areas. Two primary methods
are commonly employed to measure ice flow speed using satellite data:
SAR interferometry and feature/speckle tracking (utilizing optical or SAR
data) between consecutive acquisitions. This tutorial will focus on the

latter method, specifically applied to Sentinel-1 data.

The Petermann Glacier, a substantial tidewater glacier, drains over 4% of
the Greenland ice sheet via the 90 km long Petermann Fjord, ultimately
terminating in a floating ice tongue spanning an area of approximately
900 km². An estimated 12 billion tonnes of ice are discharged into the

ocean annually, with an approximate ice flow speed of 1 km/year.

Credit: NASA



2.1 Study area and data used

For this exercise, we will use two Sentinel-1 images of the same area in

northern Greenland, downloaded for year 2023 from the Dataspace

Copernicus Open Access Hub [@https://dataspace.copernicus.eu/].

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open 2 Sentinel-1 GRDH

downloaded products with HH and HV polarizations acquired on 26

September and 8 October 2023 by double click on the zipped folders. The

opened products will appear in Product Explorer window:

S1A_IW_GRDH_1SDH_20230926T113616_20230926T113641_050498_061508_2030.zip

S1A_IW_GRDH_1SDH_20231008T113616_20231008T113641_050673_061B09_3507.zip

Click + to expand the contents of product [1] from 26 September 2023,

then expand Bands folder and double click on Intensity_HH band to

visualize it.
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The scene appears to be "mirrored" due to the fact that it was captured

during a descending pass, with the satellite moving from north to south

and looking towards the right (in this case, west). As a result, the view

displays pixels in the order of data acquisition, as the image has not yet

been projected into cartographic coordinates.

3.1 Pre-processing

We need to apply identical pre-processing steps to both of our scenes:

Apply orbit file

Navigate to Main Menu – Radar – Apply orbit file

In the I/O Parameters tab, select the first product and name the target

product. There is no need to save the output as BEAM-DIMAP (we will save

the time this way)

In the Processing Parameters accept the default settings and select the

option „Do not fail if new orbit file not found“

Repeat for the second image.

Thermal noise removal

Navigate to Main Menu – Radar – Radiometric – S-1 Thermal Noise

Removal

In the I/O Parameters tab, select the product with applied orbit file and

name the target product. There is no need to save the output as BEAM-

DIMAP (we will save the time this way)

In the Processing Parameters you can select only HH polarization (or it is

possible within the next step calibration) and make sure that the “Remove

Thermal Noise” option is selected.

Repeat for the second image.
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Calibration

Navigate to Main Menu – Radar – Radiometric – Calibrate

In the I/O Parameters tab, select the product with thermal noise removal

and name the target product. In the case of this final product of

preprocessing, please, save it to your folder for this exercise

In the Processing Parameters you can select only HH polarization and

accept all default settings and then click Run

Repeat for the second image. The saving might take some time.
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If you finish all preprocessing steps, you should have eight products in the

Product Explorer. Open the Bands folder of the last two products, double

click on Sigma_HH for both of the products and Tile them Horizontally. You

can see little differences between these two acquisition dates.

Let´s corregistrate these images and track the offset.

3.2 Coregistration

Image coregistration is the process that involves aligning two or more

images geometrically, ensuring that corresponding pixels depict the same

area on the Earth's surface. While orbit state vectors alone can suffice to

coregister images, for precise offset tracking, additional data from a digital

elevation model (DEM) is necessary to enhance coregistration accuracy.

Navigate to Main Menu – Radar – Coregistration – DEM-Assisted

Coregistration

In the ProductSet-Reader tab, select/leave only the last two preprocessed

products and name the target product

In DEM-Assisted-Coregistration tab set:

“Digital Elevation Model”: ACE30 (Auto Download)

DEM Resampling method: BICUBIC_INTERPOLATION

Resampling Type: BISINC_5_POINT_INTERPOLATION
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In Write tab name the output product and select the directory to save it.

Then, click on RUN. This process may take some time. The resulting

product will include two HH polarizations - "mst" = master (the main/first

image used for co-registration) and "slv" = slave image.

3.1 Create subset

There is no need to process the whole image, instead, we can begin by

narrowing down the scene to a more manageable size – creating subset.

This approach will decrease processing time in subsequent stages,

especially when the analysis is concentrated on a specific area rather than

the entire scene.

Go to the Subset tab and at “Pixel Coordinates” set:

Scene start X: 1000

Scene start Y: 5000

Scene end X: 22000

Scene end Y: 16500
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Open the subset image and compare it with previous product image of the

entire area. Double click on HH polarization rasters in Bands folder to open

them. Tile them e.g. Horizontally to compare them.
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Offset Tracking

Offset Tracking is employed to determine the movement of a feature

between two acquisitions by conducting cross-correlation on designated

Ground Control Points (GCP) within coregistered images (master and slave)

in both slant-range and azimuth directions. The velocity of movement is

subsequently calculated using the offsets derived from the cross-

correlation (refer to NOTE 5). The velocities calculated on the GCP grid are

then interpolated to generate a velocity map. This method is commonly

utilized for estimating glacier motion.

To conduct Offset-Tracking, we must configure various parameters. Initially,

we establish the spacing of the Ground Control Point (GCP) grid in pixels in

the range and azimuth directions. We opt for a spacing of 60 pixels

(equivalent to 600 meters) in both directions, striking a balance between

detail and smoothness in our output. It's worth noting that higher

resolutions entail longer processing times.

Subsequently, we address the dimensions of the Registration Window. The

size of this window hinges on the maximum velocity of the glacier, gleaned

from literature or historical data, and the time span between data

acquisitions. Given that our images were captured 13 days apart and the

maximum speed of the Petermann Glacier is approximately 5 meters per

day, the surface of the glacier could potentially shift by a maximum of 60

meters. Consequently, we maintain the default setting of 128 pixels

(equivalent to 1280 by 1280 meters). Additionally, to mitigate false high

values, we specify the known maximum glacier velocity as 5 meters per

day. Therefore, we need to establish:

Grid Azimuth Spacing (in pixels): 65

Grid Range Spacing (in pixels): 65

Max Velocity (m/day): 5.0
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Offset Tracking

Once the processing finishes, a new product emerges in the Product

Explorer window. Extend the velocity product and click twice on the

Velocity_slv1_08Oct2023 band to unveil it in the View window.

Open Colour Manipulation tab – select sliders and explore velocity values in

m/day in this area.

Add velocity vector to see direction and speed

Navigate to Layer > Layer Manager

From the Layer Manager window, deselect Vector data to remove the grid

Click on the “+” button to open the Add Layer window

In the Add Layer window, click Coregistered GCP Movement Vector and

click on Finish. You will see the velocity vectors displayed on the GCP grid

showing direction and speed.
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Peterman Glacier velocity vectors. Contains modifed Copernicus Sentinel

data 2023

Terrain correction

Our data are still in radar geometry, moreover due to topographical

variations of a scene and the tilt of the satellite sensor, the distances can

be distorted in the SAR images. We need to apply Terrain Correction to

compensate for the distortions and reproject the scene to geographic

projection.

• Navigate to Main Menu: Radar - Geometric - Terrain Correction - Range-

Doppler Terrain Correction

• In the I/O Parameters tab set as “Source Product” the velocity product.

• In “Target Product”, keep the default name and set the Directory

• In the Processing Parameters tab set:

• Digital Elevation Model: ACE30 (Auto Download)

• Map Projection: Click on the tab next to Map projection (WGS84(DD) –

select Predefined CRS and click on “Select”. In “Filter” search for 32621

(EPSG: 32621 – WGS84 / UTM Zone 21N) and when you find it click OK

to both windows.

Keep defaults values for the other parameters. Click Run. Approximate

processing time: 2.5 minutes.
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Visualize

Close Range Doppler Terrain Correction window. Let’s open the terrain

corrected velocity. Expand the new georeferenced product and open the

Velocity_slv1_08Oct2023_HH band by double click on it in View window.

We can stretch the histogram a little in the Colour Manipulation tab (move

the white slider on the right, to approx. 0.45).

For more information, see the lecture: 9. SAR and optical remote sensing

for mapping ice

THANK YOU FOR FOLLOWING THE EXERCISE!

https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_09.pdf
https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_09.pdf


EXERCISE 9 – TUTORIAL

Sentinel-1, Sentinel-2 for Snow and Ice using the

SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 Perform our own sea ice classification using created training data
and Random forest classificator

 Understand the capabilities and limitations of Synthetic Aperture
Radar (SAR) in detecting and monitoring sea ice.

 Discriminate between open water and different types of the sea ice

 Identify areas with varying degrees of ice deformation

 Perform classification using Sentinel-2 data NDSI

1 | Exercise outline
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Mapping snow and ice using Sentinel-1 and Sentinel-2 data

2 | Background

2

Sea ice refers to frozen seawater that
forms when ocean water freezes due to
low temperatures. It typically occurs in
polar regions, such as the Arctic and

Antarctic, where temperatures drop low
enough for the surface of the ocean to
freeze. Sea ice can vary in thickness
and extent, ranging from thin, seasonal
ice that forms and melts each year to

thicker, multi-year ice that persists
through multiple seasons.

Sea ice plays a crucial role in regulating the Earth's climate, reflecting
sunlight back into space and influencing ocean circulation patterns.
Additionally, sea ice provides habitat for various species of marine life and
serves as a platform for indigenous communities and scientific research.

Sea ice encompasses various types, including first-year ice formed during
a single winter season, and multi-year ice, which survives multiple melt
seasons and is thicker and more consolidated. Sea ice can also be
categorized into additional types such as deformed ice, level ice, young
ice, and open water ice:

Deformed Ice: results from the compression and ridging of sea ice due to
the movement and collision of ice floes

Level Ice: refers to relatively flat and uniform sea ice surfaces that have
not undergone significant deformation or ridging

Young Ice: Young ice is newly formed sea ice that has not yet reached its

maximum thickness or strength.

Open Water Ice: describes areas of sea ice where the ice cover has
become fragmented or broken, leaving patches of open water exposed.

Sentinel-1 SAR imagery provides all-weather, day-and-night capability,
allowing for continuous monitoring of sea ice regardless of atmospheric

conditions or sunlight. By analyzing Sentinel-1 SAR images, researchers
can monitor changes in sea ice extent, thickness, and movement over
time, providing valuable information for climate studies, navigation, and
environmental management. Additionally, these data can be used to
detect and monitor other features, such as icebergs, ice floes, enhancing

our understanding of polar environments and their role in the Earth's
climate system.

Sentinel-2 satellite imagery is also valuable for mapping ice due to its
high spatial resolution and multispectral capabilities. By capturing detailed
images of ice-covered regions, Sentinel-2 facilitates the monitoring of ice

extent, ice type classification, glacier movement, and changes in ice
dynamics over time.



2.1 Study area and data used

For this exercise, we will use Sentinel-1 GRDH image and Sentinel-2 L2A

image over the Straight of Denmark between Greenland and Iceland,

downloaded from the Dataspace Copernicus Open Access Hub

[@https://dataspace.copernicus.eu/].

Part A: Sea ice mapping with Sentinel-1

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open downloaded Sentinel-1

GRDH product by double click on it. The opened product will appear in

Product Explorer window. The Worldview window (at the bottom-left

corner) shows the coverage of the image opened. Double click on e.g.

„Intensity_HH“ band within Bands folder to visualize it.

S1A_IW_GRDH_1SDH_20230217T193310_20230217T193335_047280_05AC96_9AFD.SAFE.zip
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2.3 Pre-processing

We need to apply identical pre-processing steps to our scene:

Apply orbit file

Navigate to Main Menu > Radar > Apply orbit file

In the I/O Parameters tab, select the opened product. By default, the

output target is set to the same directory and appends „Orb" to the

filename. There is no need to save the output as BEAM-DIMAP (we will

save the time this way).

In the Processing Parameters accept the default settings and select the

option „Do not fail if new orbit file not found“

Thermal noise removal

Navigate to Main Menu – Radar > Radiometric > S-1 Thermal Noise Removal

In the I/O Parameters tab, select the product with applied orbit file. By

default, the output target is set to the same directory and appends „tnr" to

the filename. There is no need to save the output as BEAM-DIMAP.

In the Processing Parameters keep both HH and HV polarisations and make

sure that the “Remove Thermal Noise” option is selected.
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The image should then look something like this (view e.g. Intensity_HH):

Create subset

There is no need to process the whole image, instead, we can begin by

narrowing down the scene to a more manageable size – creating subset.

This approach will decrease processing time in subsequent stages,

especially when the analysis is concentrated on a specific area rather than

the entire scene.
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Select the last product with

applied Thermal noise removal.

Go to the Subset tab and at

“Pixel Coordinates” set:

Scene start X: 5500

Scene start Y: 3000

Scene end X: 17300

Scene end Y: 15100

Now, the image is prepared for

classification. Open the final

product, e.g. Intensity_HH to

see the output image.



2.4 Image classification

Today we will perform a random forest classification. For this we will create

some training data by identifying polygons containing the different ice

types:

– Deformed Ice

– Level Ice

– Young Ice

– Open Water

Select the last subset product by clicking on it. Navigate to Vector > New

Vector Data Container.

Create four new data containers – separate for each type of ice mentioned

above.

Start with creating the data container for, e.g. deformed_ice“ and repeat this

step for other three types.
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The newly created four vector data containers for each ice type should

appear under "Vector Data" in the Product Explorer.

Now let´s start creating training polygons for these different containers on

ice type using the Polygon drawing tool:

Open both HH and HV polarisations to better identify different types of

ice.by double clicking on them.

Then, click on the icon Tile Horizontally (or navigate to the main menu -

Window and select this option).
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Deformed (Pink), Level (Violet), Young ice (Green) and Open water (Blue)

Sea Ice Polygons. Save the final product with your created vector data

containers to your folder.

8

Random Forest image classification

Navigate to Raster > Classification >

Supervised classification > Random

Forest Classifier

• In the ProductSetReader tab select the

saved product with your training data.

• In the Random-Forest-Clasiffier select

the classes/training vectors (all our

sea ice polygon vector containers)

and feature bands (select both

Intensity_HH and Intenisty_HV

polaristaions) that you’d like to include

into image classification.

• In the Write tab by default, the output

target is set to the same directory and

appends „RF" to the filename.

•Click RUN.



2.5 Post-processing

The final product should now appear in the ProductExplorer. Visualize this

output classified image and classes by double-click on the layer

„LabeledClasses“ under Bands folder in the Product Explorer.

Navigate to Colour Maniulation tab to change the colours of individual sea

ice classes and exlore the frequency of these classes through the classified

image and table.
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Part B: Sea ice mapping with Sentinel-2

2.6 SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open downloaded Sentinel-2

by double-clik on the metadata „MTL.txt“ inside the unzipped folder (or

click on Import Product). The opened product will appear in Product

Explorer window.

S2A_MSIL2A_20230221T140211_N0509_R010_T25WER_20230221T185001.SAFE.zip

Select (by clicking on it) the product in the Product Explorer window. The

Worldview window (at the bottom-left corner) shows the coverage of the

image opened.

Now, let´s visualize the image using True colour composition:

• Right click on the product.

• Open RGB Image Window.

• In the pop-up window select ‘Sentinel 2 MSI Natural colors’ (Red: B4;

Green: B3; Blue: B2)

Now, let´s visualize the image using False colour composition:

• Right click on the product.

• Open RGB Image Window.

• In the pop-up window select ‘Sentinel 2 MSI False Colour-Infrared’

(Red: B8; Green: B4; Blue: B3)

Now, let´s visualize the image using another False colour composition:

• Right click on the product.

• Open RGB Image Window.

• In the pop-up window select ‘Sentinel 2 MSI Atmospheric-Penetration’

(Red: B12; Green: B11; Blue: B8A)

Tile Windows, e.g. Horizontally, to explore the Sentinel-2 image features.
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2.7 Resample

Resample the bands to the pixel size of the VIS bands:

In the main SNAP menu, select Raster > Geometric > Resampling

In the I/O Parameters tab, the source product is set to our only product

in the SNAP, change the name of the target resampled product if needed

Do not save the output product - disable the box “Save as:” (if selected).

In the Processing Parameters tab, use e.g. B2 with 10 m resolution to

resample all the bands to 10 m as output spatial resolution.

2.8 Normalized Difference Snow Index

Next, we will calculate Normalized Difference Snow Index (NDSI) in

SNAP.

The Sentinel-2 NDSI is a ratio of two bands: one in the VIR (Band 3) and

one in the SWIR (Band 11). Values above 0.4 are usually snow. The

Sentinel-2 NSDI can be used to differentiate between cloud and snow

cover as snow absorbs in the short-wave infrared light, but reflects the

visible light, whereas cloud is generally reflective in both wavelengths.

Most potential cloudy pixels have NDSI values in a range between -0.1

and +0.2.

To calculate NDSI, select the last subset product, navigate to the main

SNAP menu and select Raster - Band Maths (deselect the box “Virtual”).
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SNAP menu and select Raster - Band Maths (deselect the box “Virtual”).

Click on Edit Expression to calculate the NDSI using the equation below

and click OK:

ρ(VIS) – ρ(SWIR) / ρ(VIS) + ρ(SWIR)

ρ = Top of atmosphere reflectance

VIS = Visible band (0.56 µm)

SWIR = Short-Wave Infrared Band (1.6 µm)

Replace the bands in the equation with the corresponding bands for

Sentinel 2:

ρ(B3) – ρ(B11) / ρ(B3) + ρ(B11)

Open the output product in the Product Explorer by double click on the

new raster NDSI within Bands folder.

Go to Color Manipulation tab and go to Table – set the thresholds of

slider to three values – minimum value, up to 0.4 (usually pixels with no

snow), higher than 0.4 (usually snow pixels) and maximum value.
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Explore the image: values above 0.4 are usually snow pixels (shades of
grey for the lowest probability of snow and shades of white for the
highest probability of snow). The Sentinel-2 NSDI can be also used to
differentiate between cloud and snow cover as snow absorbs in the

short-wave infrared light, but reflects the visible light, whereas cloud is
generally reflective in both wavelengths.

Most potential cloudy pixels have NDSI values in a range between -0.1
and +0.2. Add 4 new sliders and change their colour to e.g. red to

highlight these values of potentially cloudy pixels.

For more information, see the lecture: 8. SAR and Optical remote sensing

for mapping snow
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https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_08.pdf
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EXERCISE 10 – TUTORIAL

Flood Monitoring with Sentinel-1 & Sentinel-2 using

the SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this firstexercise for mapping floods,we will:

 Detect floods on Sentinel-1 images

 Develop a graph for automated processing using Batch processing

 Create binary mask for flood mapping

1

1 | Exercise outline



2 | Background

However, during severe weather conditions with heavy rainfall and

intense cloud cover, optical remote sensing may struggle to provide

accurate information due to a lack of cloud-free, high-quality images and

difficulty in detecting water under vegetation cover.

Since October 4, 2023, the Myanmar Department of Meteorology and

Hydrology (DMH) has been issuing flood advisory warnings and weather

system alerts regarding water levels in major rivers. Between October 5

and 9, heavy rainfall during the late monsoon season resulted in

extensive flooding in southern Myanmar. On October 9, the DMH reported

that Bago township received an unprecedented 7.87 inches (200

millimeters) of rainfall, the highest recorded in 59 years. By October 10,

the water level of the Bago River rose 4 feet above the danger level,

leading to widespread flooding in urban and suburban areas. The impact

of this flooding has been significant, affecting families, croplands, and

causing displacement of people in areas including Bago City, Yangon, Taik

Kyi, Hlegu, and Hmawbi townships. (DREF OPERATION Myanmar Flood

2023)

Synthetic Aperture Radar (SAR) datasets offer significant benefits in flood

observation as they emit electromagnetic waves that are unaffected by

weather and time of day. The Sentinel-1 satellite, which provides

extensive global data coverage, can effectively detect flooding in

vegetated or urban areas due to its high penetration capability.

2

Floods, a commonly occurring natural

disaster, result in significant damage to

both lives and property. Timely information

on floods is critical for emergency

response. Rapid estimation of flood extent

is essential for disaster risk assessment

and spatial planning. Remote sensing and

satellite imagery play pivotal roles in flood

monitoring and mapping. Optical remote

sensing, for instance, is utilized for

dynamic flood monitoring by exploiting

water's low reflectance in infrared bands

and high reflectance in blue/green bands.



2.1 Study area and data used

For this exercise, we will use two Sentinel-1 GRD images of the same

area near Bago city, Myanmar, downloaded from the Dataspace

Copernicus Open Access Hub [@https://dataspace.copernicus.eu/].

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open 2 downloaded products

by double click on them. The opened products will appear in Product

Explorer window. Go to Windows – Tile them e.g. Horizontally.

S1A_IW_GRDH_1SDV_20230926T232505_20230926T232530_050505_061540_C745.SAFE.zip

S1A_IW_GRDH_1SDV_20231008T232505_20231008T232530_050680_061B43_DCF8.SAFE.zip
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3.1 Pre-processing

We need to apply identical pre-processing steps to both of our scenes:

Apply orbit file

Navigate to Main Menu – Radar – Apply orbit file

In the I/O Parameters tab, select the first product and name the target

product. There is no need to save the output as BEAM-DIMAP (we will save

the time this way)

In the Processing Parameters accept the default settings and select the

option „Do not fail if new orbit file not found“

Repeat for the second image.

Create subset

There is no need to process the whole image, instead, we can begin by

narrowing down the scene to a more manageable size – creating subset.

This approach will decrease processing time in subsequent stages,

especially when the analysis is concentrated on a specific area rather than

the entire scene.

Select the last product with applied

orbit file.

Go to the Subset tab and at “Pixel

Coordinates” set:

Scene start X: 9000

Scene start Y: 4000

Scene end X: 23000

Scene end Y: 16700

Repeat for the second image.
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Thermal noise removal

Navigate to Main Menu – Radar – Radiometric – S-1 Thermal Noise Removal

In the I/O Parameters tab, select the last subset product with applied orbit

file and name the target product. There is no need to save the output as

BEAM-DIMAP (we will save the time this way)

In the Processing Parameters you can select both polarization and make

sure that the “Remove Thermal Noise” option is selected.

Repeat for the second subset image.

5

Calibration

With our image now subsetted and with TNR, we must apply image

calibration. This step is necessary to normalize the values in the image into

backscatter values so we can compare multiple images in a time series.

Navigate to Main Menu – Radar – Radiometric – Calibrate

In the I/O Parameters tab, select the product with thermal noise removal

and name the target product. In the case of this final product of

preprocessing, please, save it to your folder for this exercise

In the Processing Parameters select the VV band as input and accept all

default settings and then click Run

Repeat for the second image. The saving might take some time.



Speckle Filter

Despeckling removes thermal noise introduced by the sensor from the

image to remove potential sources of error in analysis.

Navigate to Radar > Speckle Filtering Single Product Speckle Filter. In the

Speckle-Filter tab, choose the simple Lee Sigma filter with default window

sizes.

Terrain-Correction

Navigate to Radar – Geometric – Terrain Correction – Range Dopler Terrain

Correction. The last step in our graph for image pre-processing is to apply

terrain correction to the product, ensuring that all the pixels are moved to

the right locations (eg if the nadir angle of the image is off, it will align the

pixels correctly so it is closer to a top-down view of the imagery).

Our data are still in radar geometry, moreover due to topographical

variations of a scene and the tilt of the satellite sensor, the distances can

be distorted in the SAR images. We need to apply Terrain Correction to

compensate for the distortions and reproject the scene to geographic

projection.

Navigate to Main Menu: Radar - Geometric - Terrain Correction - Range-

Doppler Terrain Correction

In the I/O Parameters tab set as “Source Product” the velocity product.

In “Target Product”, keep the default name and set the Directory

In the Processing Parameters tab set:

Digital Elevation Model: ACE30 (Auto Download)

Map Projection: Click on the tab next to Map projection (WGS84(DD) –

select Predefined CRS and click on “Select”. In “Filter” search for 32621

(EPSG: 32646 – WGS84 / UTM Zone 46N) and when you find it click OK to

both windows.

Keep defaults values for the other parameters. Click Run. Approximate

processing time: 2.5 minutes.
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3.2 Flood assessment

After execution, your resulting two preprocessed products should contain

a single bands called Sigma0_VV. Open all two (preprocessed)

Sigma0_VVs in the View and then go to Window -> Tile Horizontally

After ensuring that our products feature calibrated backscatter values, it's

time to conduct flood assessments on the data to automatically ascertain

the extent of flooding across the series of images. Areas with low

backscatter indicate wet areas. Since our calibrated images contain

calibrated backscatter coefficients, we can create a binary image from the

products, highlighting areas below a cutoff threshold. Since the River

traverses Bago city, it's crucial not to include recognized water sources in

our flood mapping. To achieve this, we can incorporate the land cover band

into our product in SNAP by right-clicking on the product in Product

Explorer and selecting "Add Elevation Band."
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Additionally, we aim to include an elevation band to prevent

misidentification of high-elevation regions as flooded. To add an elevation

band, right-click on the product and choose "Add Elevation Band," then

select "SRTM 1Sec HGT (Auto Download).„

Your product now should include land cover band and also elevation band

Now that we've added all the required bands, it's time to generate our

new flooding band. Right-click on the product and choose "Band Maths."

Enter the following expression into the text box:

Sigma0_VV < 0.05 && land_cover != 20 && elevation < 10

This will produce a binary mask indicating areas where the backscatter is

below our threshold of 0.05, not categorized as water (Class 210) in land

cover, and with an elevation below 10 meters above sea level.
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Repeat the process for the second Sentinel product. Display the two

masks to check they have been generated correctly. Our output flooding

binary band should look like this (For September 26th – start of flodding

and October 10th - peak of flooding):
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3.3 Export and open binary masks in QGIS

To export this product for viewing in other GIS software and to map the

changes in flooding over time, you need to save our two binary mask

(start of floods and peek of floods) in TIF format in the proper folder

using File-> Export->GeoTiff/BigTiff tool.

To visualize the output of our multi-temporal flood analysis, we will open

the masks saved in GeoTIFF format using QGIS:

In QGIS click on the Add Raster Layer button located in the left panel,

navigate to the folder containing the binary masks in TIFF format, and

click Open (or drag&drop).

Now we open the output image in QGIS

• We can overlay it to e.g. Google Satellite or Bing aerial image:

• Web->OpenLayers plugin->Google Maps->Google Satellite

• Move the Subset above the satellite

• Play with Transparency: Properties->Transparency (e.g. 80%)

As observed, the floodwaters gradually subside over time, yet areas near

the riverbanks remain saturated, displaying low backscatter and thus

continuing to appear flooded.

For more information, see the lectures:

10. SAR and optical remote sensing for mapping floods

11. SAR and optical remote sensing for post-flood assessment and

recovery
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EXERCISE 11 – TUTORIAL

Flood Monitoring with Sentine l-1, Sentinel-2 data

using the SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this secondexercise for mapping floods,we will:

 Detect floods using Sentinel-2 images

 Create NDVI and NDWI spectral indices to explore floods

 Create binary water mask for flood mapping

 Compare results for flood mapping using Sentinel-1 and Sentinel-2 
images
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2 | Background

However, during severe weather conditions with heavy rainfall and

intense cloud cover, optical remote sensing may struggle to provide

accurate information due to a lack of cloud-free, high-quality images and

difficulty in detecting water under vegetation cover.

Since October 4, 2023, the Myanmar Department of Meteorology and

Hydrology (DMH) has been issuing flood advisory warnings and weather

system alerts regarding water levels in major rivers. Between October 5

and 9, heavy rainfall during the late monsoon season resulted in

extensive flooding in southern Myanmar. On October 9, the DMH reported

that Bago township received an unprecedented 7.87 inches (200

millimeters) of rainfall, the highest recorded in 59 years. By October 10,

the water level of the Bago River rose 4 feet above the danger level,

leading to widespread flooding in urban and suburban areas. The impact

of this flooding has been significant, affecting families, croplands, and

causing displacement of people in areas including Bago City, Yangon, Taik

Kyi, Hlegu, and Hmawbi townships. (DREF OPERATION Myanmar Flood

2023)

Besides Synthetic Aperture Radar (SAR) data that we used in the first

part of the exercise for mapping floods, Sentinel-2 satellites are also

extensively used for flood mapping due to their ability to capture high-

resolution optical imagery of the Earth's surface. By analyzing these

images, particularly before and after flood events, analysts can identify

changes in water extent and detect flooded areas. The multispectral

capabilities of Sentinel-2 allow for the differentiation of water bodies from

other land cover types, enabling accurate mapping of flood-affected

areas. Moreover, Sentinel-2's frequent revisits and openly available data

make it a valuable resource for monitoring flood events in near real-time

and supporting disaster response efforts.

2

Floods, a commonly occurring natural

disaster, result in significant damage to

both lives and property. Timely information

on floods is critical for emergency

response. Rapid estimation of flood extent

is essential for disaster risk assessment

and spatial planning. Remote sensing and

satellite imagery play pivotal roles in flood

monitoring and mapping. Optical remote

sensing, for instance, is utilized for

dynamic flood monitoring by exploiting

water's low reflectance in infrared bands

and high reflectance in blue/green bands.



2.1 Mapping floods with Sentinel-2 data

For the second part of this exercise, we will use two Sentinel-2 L2A

images of the same area near Bago city, Myanmar, downloaded from the

Dataspace Copernicus Open Access Hub

[@https://dataspace.copernicus.eu/].

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open 2 downloaded products

(unzipped) by double click on the metadata „MTD_MSIL2A.xml“ inside

the folder. The opened products will appear in Product Explorer window.

Go to Windows – Tile them e.g. Horizontally.

S2B_MSIL2A_20231004T035609_N0509_R004_T46QHE_20231004T070950.SAFE.zip

S2B_MSIL2A_20230924T035539_N0509_R004_T46QHE_20230924T071828.SAFE.zip

1. Select the first product in the Product Explorer window.

2. Right click on the product.

3. Open RGB Image Window.

4. In the pop-up window select e.g. ‘Sentinel 2 MSI False-color Infrared

(Red: B8; Green: B4; Blue: B3)’.

5. Repeat the process for the second product.

6. Tile two opened RGB Windows, e.g. horizontally

7. In the Navigation window, zoom in to the flooded region and

syhnchronise views to see the same area
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2.3 Preprocessing

Resample

Resample the bands to the pixel size of the VIS bands:

In the main SNAP menu, select Raster - Geometric - Resampling

In the I/O Parameters tab, the source product is set to our only product

in the SNAP, change the name of the target resampled product if needed

Do not save the output product - disable the box “Save as:” (if selected).

In the Processing Parameters tab, use e.g. B3 with 10 m resolution to

resample all the bands to 10 m as output spatial resolution.

Resample both of the products.
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Create subset

Click on the resampled product in the Product Explorer, go to the main

SNAP menu and select Raster - Subset…:

Create a subset with the following settings:

Spatial subset - Geo Coordinates:

North latitude bound: 18.00,

West longitude bound : 96.20,

South latitude bound : 17.00,

East longitude bound : 97.00

Keep the remaining parameters as default and click OK

In the end, you should have two resampled subsets. Close original

visualizations and display subsets in False color with Tile Horizontally

option.
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2.4 Image analysis

NDVI

Let´s calculate NDVI for the two subset images.

Navigate to Main Menu: Optical – Thematic Land Processing – Vegetation

Radiometric Indices – NDVI Processor and set parameters:

In the Product Explorer tab double click to open resulted two new NDVI

bands for each date.

Go to Colour Manipulation tab and select appropriate colour palette for

vegetation index. Apply the same colour palette and set the sliders to the

same values for both of the images. Synchronize Cursor Position and

Views activating the two buttons in Navigation tab.

NDVI image has usually values from ˂ -1, 1 ˃, where forested areas are

displayed in values higher than 0.
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NDWI

Let´s calculate also NDWI for the two subset images.

Navigate to Main Menu: Optical – Thematic Land Processing – Water

Radiometric Indices - NDWI Processor and set parameters:

In the Product Explorer tab double click to visualize resulted two new

NDWI layers.

Go to Colour Manipulation tab and select appropriate colour palette for

vegetation index. Apply the same colour palette and set the sliders to the

same values for both of the images. Synchronize Cursor Position and

Views activating the two buttons in Navigation tab.
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2.5 Water Mask Generation

The utilization of both NDVI and NDWI together can be advantageous for

specifically identifying water bodies.

Let´s create a binary mask of water and non-water pixels with a

thresholding condition. Open e.g. False-color composition and define a

Waterbody Region of Interest (ROI)

Define a new ROI (Vector->New Vector Data Container)

Define ROI name (f.e. Water_ROI) and description (optional)

Check in VectorData folder corresponding to the active image to check

the ROI has been created. Define Tool for ROI construction (Polygons

Drawing Tool) and draw polygon over water area e.g. according False-

color Infrared composition and double-click to close it

Export ROI as SHAPE file (f.i. as Water_ROI.shp) – right click on the layer

– Geometry as Shapefile – set the directory for export and close the

visualization

Import SHAPE file to make it available in NDVI and NDWI layers
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Import SHAPE file to make it available in NDVI and NDWI layers:

Select NDVI product - File – Import- Vector data – ESRI Shapefile – and

import your saved Water_ROI polygon

Select NDWI product - File – Import- Vector data – ESRI Shapefile – and

import your saved Water_ROI polygon. Select NDVI and NDWI layers

from Product Explorer panel and visualize them.

Calculate Histogram over ROI for NDVI and NDWI during pre-flood and

during flood events:

click on NDVI layer – Navigate to Analysis->Histogram – activate Use

ROI Mask tab – select Water ROI Polygon mask and press refresh button.
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Repeat for NDWI layer.

Proposed thresholding values

Create masks for NDVI and for NDWI with a combined (AND) condition:

Open Band Maths window from Raster>Band Maths or by selecting any

available layer (f.i. NDWI) and clicking on the mouse’s right button. Edit

the formula by selecting the NDVI and NDWI properly (corresponding to

the same acquisition) and applying the proper thresholds).
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No-flooded NDVI<-0.15 and NDWI > 0.3

Flooded NDVI< 0.1 and NDWI > 0.35



Calculate new masks for pre-flood and flood events.
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2.6 Export and open binary masks in QGIS

To export this product for viewing in other GIS software and to map the

changes in flooding over time, you need to save our two binary mask

(start of floods and peek of floods) in TIF format in the proper folder

using File-> Export->GeoTiff/BigTiff tool.

To visualize the output of our multi-temporal flood analysis, we will open

the masks saved in GeoTIFF format using QGIS:

In QGIS click on the Add Raster Layer button located in the left panel,

navigate to the folder containing the binary masks in TIFF format, and

click Open (or drag&drop).

Now we open the output image in QGIS

• We can overlay it to e.g. Google Satellite or Bing aerial image:

• Web->OpenLayers plugin->Google Maps->Google Satellite

• Move the Subset above the satellite



• Play with Transparency: Properties->Transparency (e.g. 80%)

As observed, the floodwaters gradually subside over time, yet areas near

the riverbanks remain saturated, displaying low backscatter and thus

continuing to appear flooded.

Compare masks retrieved via S1 and S2 using S2-RGB data as (quasi

simultaneous) ground truth.

For more information, see the lectures: 10. SAR and optical remote

sensing for mapping floods, 11. SAR and optical remote sensing for post-

flood assessment and recovery
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EXERCISE 12 – TUTORIAL

Land subsidence mapping using SAR interferometry

(InSAR) using the SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 Explore the role of synthetic aperture radar (SAR) in detecting and

mapping land subsidence using Sentinel-1 data.

 Understand how to process SAR data to obtain information and
understanding of surface deformations

 Emphasise the sensitivity of SAR to small surface changes and
provide a comprehensive view of the subsidence dynamics.

 Learn how to detect displacement by means of band Math
expression and visualize results of displacement in Google Earth.
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2 | Background

Subsidence in Mexico City is a significant issue that has been occurring

for several decades. Excessive groundwater pumping, primarily for

residential and industrial use, has been one of the primary drivers of

subsidence in Mexico City. The groundwater extraction causes the clay

soils to compact, leading to the sinking of the ground surface. The

consequences of subsidence in Mexico City are severe. Infrastructure

such as buildings, roads, and pipelines can suffer damage or even

collapse as the ground sinks unevenly. Subsidence also increases the risk

of flooding during periods of heavy rainfall, as the ground settles below

the level of drainage systems.

Sentinel-1 satellite data through radar interferometry techniques, can

monitor subtle movements of the Earth's surface. With its frequent

revisits and global coverage, Sentinel-1 enables continuous monitoring

over large areas, aiding researchers and policymakers in assessing risks

and implementing mitigation measures for sustainable land management.

2

Land subsidence, the gradual sinking of the

Earth's surface, caused by natural processes

like sediment compaction and human

activities such as groundwater extraction,

poses risks to infrastructure and ecosystems.

Effective monitoring and mitigation strategies

are crucial to address its impacts and ensure

sustainable land use.

Image sources: https://www.science.org/content/article/sinking-mexico-
city-linked-metro-accident-more-come, https://www.esa.int/ESA_Multi-
media/Images/2014/12/Mexico_City_subsidence



2.1 Study area and data used

For this exercise, we will use two Sentinel-1 GRD images of the same

area near Bago city, Myanmar, downloaded from the Dataspace

Copernicus Open Access Hub [@https://dataspace.copernicus.eu/].

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open 2 downloaded products

by double click on them. The opened products will appear in Product

Explorer window.

S1A_IW_SLC__1SDV_20230614T004845_20230614T004912_048975_05E3BC_2DAF.zip

S1A_IW_SLC__1SDV_20230906T004850_20230906T004917_050200_060ACB_D4DD.zip

Right-click on the “Intensity_IW3_VV” band and select Open Image

Window to create and visualize the image of the band (or double-click on

it).
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2.3 Pre-processing

S-1 TOPS Split

As the region of interest falls within 3 bursts of the Sentinel-1 image,

there's no need to process the entire sub-swath with all bursts. Instead,

extraction of Sentinel-1 TOPS bursts will be conducted per acquisition

and per sub-swath. This approach reduces processing time.

Navigate to Radar > Sentinel-1 TOPS > S-1 TOPS Split.

In the I/O Parameters tab, leave the default output name for the target

product name. The system inserts automatically the suffix of the split

process in order to discriminate the split product from the original data.

In the Processing Parameters tab, select the following parameters:

Subswath: IW3 Polarisations: VV Bursts: 3 to 5

In Bursts selection drag arrows to the specified number of bursts. Then

click RUN. Repeat the split process for the second Sentinel-1 image:
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2.4 Co-registration

The first processing step is to apply the orbit files in Sentinel-1 products

in order to provide accurate satellite position and velocity information.

Apply orbit file

Navigate to Main Menu – Radar – Apply orbit file

In the I/O Parameters tab, select the first product and name the target

product. There is no need to save the output as BEAM-DIMAP (we will save

the time this way)

In the Processing Parameters accept the default settings and select the

option „Do not fail if new orbit file not found“

Repeat for the second image.

Save the products with applied orbit files.

Back-Geocoding

Next step will be to co-register the two Sentinel-1 images. For this

reason the second image (slave) will be co-registered with respect to the

first image (master). Sentinel-1 Back Geocoding operator co-registers

two S-1 split products (master and slave) of the same sub-swath using

the orbits of the two products and a Digital Elevation Model (DEM).

Navigate to Radar > Coregistration > S-1 TOPS Coregistration > S-1

Back-Geocoding:

In the ProductSet-Reader click on Add Opened icon and keep only the

products with the applied orbit files (in case there is more products, use

remove icon to delete them).
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Back-Geocoding tab use default parameters, but also check “Output

Deramp and Demod Phase” option.

In the Write tab, select the directory to save your processing outputs.

Enhanced Spectral Diversity

In the next step, the Enhanced Spectral Diversity (ESD) operator is

applied after Back-Geocoding. The ESD method utilizes data from the

overlapping area of adjacent bursts and conducts range and azimuth

corrections for each burst.

Go to Radar > Coregistration > S-1 TOPS Coregistration > Enhanced-

Spectral-Diversity

In the I/O Parameters tab, select the last back-geocoded product.

By default, the output target is set to the same directory and appends

„esd" to the filename.

In the Enhanced-Spectral-Diversity tab use the default parameters.
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2.5 Forming a Raw Interferogram

The next phase involves generating an interferogram using the the

interferometric pair (master and slave), while a coherence image

estimation from the stack of the coregistered complex images is included.

To do this, follow these steps:

From the main menu bar, go to Radar > Interferometric > Products and

finally select Interferogram Formation.

In the I/O Parameters tab, choose the „esd" product that was generated

during the previous step.

By default, the output target is set to the same directory and appends "ifg"

to the filename.

In the Processing Parameters tab set the following parameters:

Coherence Range Window Size: 20

Coherence Azimuth Window Size: 5

TOPS Debursting

The next stage in interferometry using Sentinel-1 TOPS mode (IWS) data

involves "debursting" or merging the bursts - the focused complex burst

images are assembled in azimuth-time sequence to form a unified sub-

swath image, with black-fill borders separating them. There is ample

overlap between neighboring bursts and sub-swaths to guarantee

continuous ground coverage. All burst images in all sub-swaths are

resampled to a consistent pixel spacing grid in both range and azimuth,

while retaining the phase data.

From the main menu bar, navigate to Radar > Sentinel-1 TOPS > S-1

TOPS deburst:

In the I/O Parameters tab, choose the "Orb_Stack_esd" product generated

during the interferogram formation process. By default, the output

appends "deb" to the filename.
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In the TOPSAR-Deburst tab select Polarizations: VV. Click on the „RUN“.

The new product will appear in the Product Explorer window. The

processing might take some time depending on your machine.

Create subset (optional)

In the earlier stages of processing, empty pixels (green pixels on the

interferogram) along the interferogram's perimeter may have been

created, particularly in regions not overlapped by both input images. To

remove these sections, employ the Subset function found under Raster.

This approach will also decrease processing time in subsequent stages,

especially when the analysis is concentrated on a specific area rather than

the entire scene.
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The next step involves removing the topographic phase from the debursted

interferogram using a Digital Elevation Model (DEM).

To proceed with topographic phase removal, follow these steps:

From the main menu bar, navigate to Radar > Interferometric > Products

Topographic Phase Removal:

In the I/O Parameters tab, choose the "Orb_Stack_ifg_deb" product

generated during the deburst step.

By default, the output appends "dinsar" to the filename.

The Processing Parameters tab indicates that the default setting is to

download the SRTM 3-arcsecond DEM, which is suitable for basic

processing. Select the “Output topographic phase band” option and keep

the default parameters.

Multi-Looking and Filtering

There are two methods to minimize noise in the interferogram: filtering

and multi-looking. While standard procedure involves applying filtering

initially, it's also possible to opt for multi-looking first.

Multilooking

Multi-looking involves averaging several pixels in each direction, a process

referred to by radar engineers as "taking multiple looks." This leads to

larger pixels and has the potential to significantly diminish noise.

The extent of multi-looking required depends on the desired spatial

resolution and the spacing of the fringes.

To initiate multi-looking:

From the top main menu bar, select Radar > SAR Utilities > Multilooking.

In the I/O Parameters tab, choose the "dinsar" product generated by the

previous step. By default, "ML" is appended to the output name.

In the Processing Parameters tab set the following parameters:

Number of Range Looks: 8

Number of Azimuth Looks: 2
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Filtering

To begin filtering, navigate to Radar > Interferometric > Filtering >

Goldstein Phase Filtering from the top main menu bar.

In the I/O Parameters tab, choose the „ML" product generated in the

previous step.

By default, the output name includes "flt."



In the Processing Parameters tab set the parameters as defined below:

Adaptive Filter Exponent in (0,1]: 1.0

FFT Size: 128

In this step we have to save the output, which is the multilooked and

filtered differential interferogram.
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2.6 Phase Unwrapping

Unwrapping in SNAP follows three distinct steps:

1. Export of the wrapped phase (and definition of the parameters)

2. Unwrapping of the phase (performed outside SNAP by snaphu)

3. Import of the unwrapped phase back into SNAP

Export of the wrapped phase

Export your interferogram or your subset interferogram from Sentinel-1

Toolbox to SNAPHU:

From the top main menu bar, navigate to Radar > Interferometric >

Unwrapping > Snaphu Export.

In the Snaphu Export window:

In Read tab, select the last “fit” product created by the Goldstein Phase

Filtering step

In Snaphu Export tab specify a target folder for export. Create a new

target folder for this step by entering a path and new folder name (e.g.

„snaphu_export). If the selection of the directory does not work, simply

copy and paste the path of your working directory into the text field.

Also, set the parameters as indicated below:

Statistical-cost mode: DEFO

Initial method: MCF

Number of Tile Rows: 1

Number of Tile Columns: 1

Row Overlap: 0

Column Overlap: 0

Note: The number of tile rows, columns can be changed to e.g. “1”

because we don’t need multiple tiles after multilooking. Depending on the

number of processors of your computer, you can also increase the Number

of Processors variable.
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Click Run to create the SNAPHU_Export file. This step might take some

time depending on your PC.

The folder now holds files used for phase unwrapping:

▪ the coherence: image (*.img) and metadata (*.hdr)

▪ the wrapped phase: image (*.img) and metadata (*.hdr)

▪ the unwrapped phase: only the metadata (*.hdr), because the image

(*.img) is first to be created

by snaphu in the next step.

▪ a configuration file (snaphu.conf) containing the parameters defined in

the export operator
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Unwrapping of the phase

You should see the wrapped interferogram phase “Phase_ifg*.img”,

coherence “coh_*.img”, and a “snaphu.conf” file.

For the next step, you will need to instal SNAPHU in Windows. SNAPHU is a

tool for phase unwrapping of interferometric information. To use it as an

executable file (*.exe) in Windows it has to be compiled first so all required

drivers (*.dll) are installed correctly. Follow the steps for installation here:

file:///C:/Users/Ona%C4%8Dillov%C3%A1/Downloads/Installation_SNAPH

U_English_ABraun.pdf

To start unwrapping, check the location of the interferogram exported from

SNAP. If snaphu.exe is not in your system’s PATH variable: Copy it in there

as well. It is recommended to store the data and snaphu on the same disk.

Open Command Window Here.

Type snaphu and hit Enter. The help menu should be displayed.

The command to start the unwrapping is shown in the file snaphu.conf.

Open it with a text editor. The beginning of the “snaphu.conf” file shows

the command to call Snaphu
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The Snaphu program can take a long time to run. At the end it writes

unwrapped phase to “Unw_ifg*.img” file

Import of the unwrapped phase

Now, we import the unwrapped phase. From the top main menu bar, select

Radar > Interferometric > Unwrapping, and then Snaphu Import that

converts it back into the BEAM DIMAP format and adds the required.

Read-Phase: should be set to the wrapped product that you

exported(before the export)

Read-Unwrapped-Phase: select the unwrapped phase product: Navigate to

folder where you exported for Snaphu. Select the

“UnwPhase_ifg*.snaphu.hdr” file. Note: The error message will then vanish

if you proceed to the next tab.

SnaphuImport: Leave the option “Do NOT save Wrapped interferogram in

the target product” unchecked, because it is required in the later step.

Write: To store the imported unwrapped band in a separate product

(recommended), add ‘_unw’ to the end of the output name and click Run.

Finally, a new product is added to the Product Explorer which contains the

the unwrapped phase that we can display.
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Select the Unw_Phase_ifg band. Double click on this unwrapped phase

to see if the unwrapping was successful. It should be a smooth raster

with little variation except for the areas of expected deformation.

All fringe patterns are summarized to absolute changes. Go to the Colour

Manipulation tab and select “100%” to stretch color scale to full range of

unwrapped data. Unwrapped phase is still in radians. Phase is reference

image minus coregistered image. If reference image is earlier, then

negative phase is land moving toward satellite (negative range change)



2.7 Phase to displacement

We can convert the unwrapped phase to displacements. From the top main

menu bar, select Radar, then Interferometric, then Products, and then

Phase to Displacement.

The I/O Parameters tab should be set to the unwrapped product that you

imported.

Default for target product name is to add “_dsp” to the name

In the Product Explorer window select the “displacement” band from the

new opened product to open the displacement product in the view

window. Displacements is now in meters.
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2.8 Geocoding results—Terrain Correction

Terrain corrections aim to mitigate distortions in SAR images caused by

topographical variations in the scene and the tilt of the satellite sensor.

These corrections seek to ensure that the geometric representation of the

image closely aligns with real-world conditions. SNAP calls geocoding with

topography “Terrain Correction.”

From the top main menu bar, select Radar, then Geometric, then Terrain

Correction, and then Range-Doppler Terrain Correction:

The I/O Parameters tab should be set to the displacement product that

you.

Default for target product name is to add “_TC” to the name

Now, we can display displacement_vv band of geocoded result. Again,

better to stretch colors.

Product is now evenly spaced in latitude and longitude.
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In the Processing Parameters

tab, select the Source Band

(„displacement“).

Set also these parameters as

following:

Pixel Spacing (m): 100

Map Projection: WGS84(DD)

Now, we can display

displacement_vv band of

geocoded result.

Again, better to stretch colors.

Product is now evenly spaced in

latitude and longitude.



A
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Note: By appropriate post-processing of the displacement product (masking

of the incoherent values) more accurate measurements can be produced.

2.9 Export .kmz to Google Earth

Geocoded products (projected to WGS84) can be exported as a KMZ file to

view in Google Earth (Pro):

In the SNAP - right click on the elevation raster in the View tab (or

navigate to File > Export > Other > View As Google Earth KMZ)

Choose a directory and name to save the output .kmz, confirm with Save.

Open the resulting KMZ file in Google Earth (Pro) to observe the elevation

patterns overlaid on the satellite image base map.

For more information, see the lecture: 12. SAR for land subsidence

THANK YOU FOR FOLLOWING THE EXERCISE!

https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_12.pdf


EXERCISE 13 – TUTORIAL

Earthquake deformation with Sentinel-1 using the

SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 Learn the basic physics of SAR interferometry

 Perform necessary data processing for making an interferogram

 Understand the information content in SAR interferometric images

1 | Exercise outline

1

Morocco earthquake deformation
Source: contains modified Copernicus Sentinel data (2023), processed by 

Aristotle University of Thessaloniki and the DIAPASON InSAR service of CNES 
integrated by TRE Altamira on the Geohazard Exploitation Platform GEP/ESA.



Deformation Mapping and Change Detection using Sentinel-1 data

One of the mission's primary functions is to regularly monitor subtle

alterations in the Earth's surface elevation. During an earthquake event,

surface changes are notably more conspicuous compared to gradual

movements such as subsidence or uplift. These radar images enable

scientists to meticulously observe and analyze the specific impacts of

earthquakes on the Earth's land surface.

On Friday 8 September 2023, the powerful 6.8 magnitude earthquake

struck the Atlas Mountains, about 75 km from Marrakech. Tragically, the

earthquake resulted in a significant loss of life, widespread building and

home collapses, and the blockage of roads. Its impact extended to the

extent that buildings even swayed on the country's northern coast.

In response to the Moroccan earthquake, the Copernicus Emergency

Mapping Service was mobilized to facilitate the exchange of satellite data.

2 | Background

Satellites constantly monitor

Earth from space, providing vital

data essential for rapid damage

assessment and disaster

management. The radar on

board the Copernicus Sentinel-1

mission can detect ground

conditions and penetrate clouds,

functioning day and night.
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2.1 Study area and data used

For this exercise, we will use two Sentinel-1 SLC images of the same area

near Marrakech, Morocco, downloaded from the Dataspace Copernicus

Open Access Hub [@https://dataspace.copernicus.eu/].

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open 2 downloaded products

by double click on the zipped folders. The opened products will appear in

Product Explorer window.

S1A_IW_SLC__1SDV_20230830T062919_20230830T062946_050101_06076B_20BE.SAFE.zip

S1A_IW_SLC__1SDV_20230911T062920_20230911T062947_050276_060D5E_D10D.SAFE.zip

To access the information within the product, double-click on it to reveal

the directories, which include:

• Metadata: containing parameters pertaining to orbit and data.

• Tie Point Grids: providing interpolation data for latitude/longitude,

incidence angle, etc.

• Quicklooks: presenting a visible image of the entire scene in radar

coordinates.

• Bands: consisting of complex values for each subswath "i" and "q",

along with intensity (where intensity represents the squared amplitude

and functions as a virtual band).

Select intensity image for swath IW1 VV – double click on it to View it

Note: Each SAR image is flipped north—south it maintains the same

orientation as its acquisition (in this case, ascending track).
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3.2 Coregistration

Image coregistration is the process that involves aligning two or more

images geometrically, ensuring that corresponding pixels depict the same

area on the Earth's surface. While orbit state vectors alone can suffice to

coregister images, for precise offset tracking, additional data from a digital

elevation model (DEM) is necessary to enhance coregistration accuracy.

Navigate to Main Menu – Radar – Coregistration –S1 TOPS Coregistration –

S1 TOPS Coregistration

In the Read tab, select the 20230830 SLC product and in the Read(2) tab

select the 20230911 SLC product

In TOPSAR-Split and TOPSAR-Split(2) tabs select Subswath: IW1

Polarizations:VV

In the Apply Orbit File tab select leave default parameters and uncheck „Do

not fail if new orbit is not found“ option

In the Write tab, select the directory to save your processing outputs
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3.3 Forming a Raw Interferogram

The next phase of interferometry involves generating an interferogram

using the coregistered SLC images. To do this, follow these steps:

From the main menu bar, go to Radar – Interferometric - Products and

finally select Interferogram Formation.

In the I/O Parameters tab, choose the "Orb_Stack" product that was

generated during the coregistration process.

By default, the output target is set to the same directory and appends "ifg"

to the filename.

For standard processing, there's no need to modify the defaults in the

Processing Parameters tab.
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Raw Interferogram — Phase Image should appear int he View tab.

3.4 TOPS Debursting and Topographic Phase Removal

The next stage in interferometry using Sentinel-1 TOPS mode (IWS) data

involves "debursting" or merging the bursts, a step not required with

Sentinel-1 or other stripmap SAR data.

To perform debursting, follow these steps:

From the main menu bar, navigate to Radar, then Sentinel-1 TOPS, and

finally S-1 TOPS deburst.

In the I/O Parameters tab, choose the "Orb_Stack_ifg" product generated

during the interferogram formation process. By default, the output

appends "deb" to the filename.

There is no need to make changes in the Processing Parameters tab.
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The subsequent stage in all interferometry processes involves eliminating

the topographic phase using a Digital Elevation Model (DEM).

To proceed with topographic phase removal, follow these steps:

From the main menu bar, navigate to Radar, then Interferometric, then

Products, and finally Topographic Phase Removal.

In the I/O Parameters tab, choose the "Orb_Stack_ifg_deb" product

generated during the deburst step. If not using TOPS mode, select

"Stack_ifg" instead.

By default, the output appends "dinsar" to the filename.

The Processing Parameters tab indicates that the default setting is to

download the SRTM 3-arcsecond DEM, which is suitable for basic

processing. However, in certain cases, you may require a different DEM.

Viewing Differential Interferogram — Phase Image
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3.5 Filtering and Multi-Looking Interferogram

There are two methods to minimize noise in the interferogram: filtering

and multi-looking. While our standard procedure involves applying filtering

initially, it's also possible to opt for multi-looking first.

To begin filtering:

Go to Radar, then Interferometric, then Filtering, and select Goldstein

Phase Filtering from the top main menu bar.

In the I/O Parameters tab, choose the "dinsar" product generated in the

previous step.

By default, the output name includes "flt."

There's no necessity to adjust the default settings in the Processing

Parameters tab for basic processing.

3.6 Multi-Looking Interferogram

Multi-looking involves averaging several pixels in each direction, a process

referred to by radar engineers as "taking multiple looks." This leads to

larger pixels and has the potential to significantly diminish noise.

The extent of multi-looking required depends on the desired spatial

resolution and the spacing of the fringes.

The Morocco earthquake, with a depth of approximately 18 km, exhibits

widely spaced fringes. Additionally, there is no surface rupture, allowing for

increased spatial averaging without sacrificing the earthquake signal.
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To initiate multi-looking:

From the top main menu bar, select Radar, then SAR Utilities, and finally

Multilooking.

In the I/O Parameters tab, choose the "dinsar_flt" product generated by

the filtering step. By default, "ML" is appended to the output name.

In the Processing Parameters tab, select the Source Bands "i_ifg", "q_ifg",

and "coh". For this scene, 17 range looks are utilized, with the calculation

of 5 azimuth looks resulting in approximately 70 m output pixels.

Do not select the "Phase" band.
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Viewing Multi-Looked Interferograms

Initially, we must generate a new virtual

phase band after multi-looking the

complex interferogram.

To do this:

From the top main menu bar, navigate to

Raster, then Data Conversion, and select

Complex i and q to Phase.

Subsequently, you can display the newly

created phase band.

As a result of this process, the fringes

exhibit significantly reduced noise, and the

aspect ratio has been modified, resulting in

pixels that are approximately square on

the ground. The new image now measures

considerably smaller number of pixels than

the original image.



3.7 Phase Unwrapping

Unwrapping in SNAP follows three distinct steps:

1. Export of the wrapped phase (and definition of the parameters)

2. Unwrapping of the phase (performed outside SNAP by snaphu)

3. Import of the unwrapped phase back into SNAP

Export of the wrapped phase

Export your interferogram or your subset interferogram from Sentinel-1

Toolbox to SNAPHU:

From the top main menu bar, navigate to Radar > Interferometric >

Unwrapping > Snaphu Export.

In the Snaphu Export window:

In Read tab, select the “ML” product created by the multilooking step

In Snaphu Export tab, you also need to specify a target folder for exported

files. Create a new target folder for this step by entering a path and new

folder name (e.g. „snaphu_export). If the selection of the directory does

not work, simply copy and paste the path of your working directory into

the text field.

In Snaphu Export tab, select DEFO as Statistical-cost mode

Select MCF.

Note: You can also change the number of tile rows, columns and number of

processors to e.g. “1” because we don’t need multiple tiles after

multilooking or select 200 pixels for Row Overlap and Column Overlap if

you want to multilook. Depending on the number of processors of your

computer, you can also increase the Number of Processors variable.

Click Run to create the SNAPHU_Export file

10



The folder now holds files used for phase unwrapping:

▪ the coherence: image (*.img) and metadata (*.hdr)

▪ the wrapped phase: image (*.img) and metadata (*.hdr)

▪ the unwrapped phase: only the metadata (*.hdr), because the image

(*.img) is first to be created

by snaphu in the next step.

▪ a configuration file (snaphu.conf) containing the parameters defined in

the export operator

Unwrapping of the phase

You should see the wrapped interferogram phase “Phase_ifg*.img”,

coherence “coh_*.img”, and a “snaphu.conf” file.

For the next step, you will need to instal SNAPHU in Windows. SNAPHU is a

tool for phase unwrapping of interferometric information. To use it as an

executable file (*.exe) in Windows it has to be compiled first so all required

drivers (*.dll) are installed correctly. Follow the steps for installation here:

file:///C:/Users/Ona%C4%8Dillov%C3%A1/Downloads/Installation_SNAPH

U_English_ABraun.pdf

To start unwrapping, check the location of the interferogram exported from

SNAP. If snaphu.exe is not in your system’s PATH variable: Copy it in there

as well. It is recommended to store the data and snaphu on the same disk.

Open Command Window Here.

Type snaphu and hit Enter. The help menu should be displayed.

The command to start the unwrapping is shown in the file snaphu.conf.

Open it with a text editor. The beginning of the “snaphu.conf” file shows

the command to call Snaphu

12

file:///C:/Users/OnaÄ�illovÃ¡/Downloads/Installation_SNAPHU_English_ABraun.pdf


The Snaphu program can take a long time to run. At the end it writes

unwrapped phase to “Unw_ifg*.img” file

Import of the unwrapped phase

Now, we import the unwrapped phase. From the top main menu bar, select

Radar > Interferometric > Unwrapping, and then Snaphu Import that

converts it back into the BEAM DIMAP format and adds the required.

Read-Phase: should be set to the wrapped product that you

exported(before the export)

Read-Unwrapped-Phase: select the unwrapped phase product: Navigate to

folder where you exported for Snaphu. Select the

“UnwPhase_ifg*.snaphu.hdr” file. Note: The error message will then vanish

if you proceed to the next tab.

SnaphuImport: Leave the option “Do NOT save Wrapped interferogram in

the target product”

unchecked, because it is required in the later step.

Write: To store the imported unwrapped band in a separate product

(recommended), add ‘_unw’ to the end of the output name and click Run.

Finally, a new product is added to the Product Explorer which contains the

the unwrapped phase that we can display.
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Select the Unw_Phase_ifg band. Double click on this unwrapped phase to

see if the unwrapping was successful. It should be a smooth raster with

little variation except for the areas of expected deformation.

All fringe patterns are summarized to absolute changes. Go to the Colour

Manipulation tab and select “100%” to stretch color scale to full range of

unwrapped data. Unwrapped phase is still in radians. Phase is reference

image minus coregistered image. If reference image is earlier, then

negative phase is land moving toward satellite (negative range change)
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3.8 Phase to displacement

We can convert the unwrapped phase to displacements. From the top main

menu bar, select Radar, then Interferometric, then Products, and then

Phase to Displacement.

The I/O Parameters tab should be set to the unwrapped product that you

imported.

Default for target product name is to add “_dsp” to the name

Now, we can display displacement band of result. Again, better to stretch

colors. Displacements is now in meters.

Sign was changed so positive displacement is “up” towards satellite

3.9 Geocoding results—Terrain Correction

SNAP calls geocoding with topography “Terrain Correction.” From the top

main menu bar, select Radar, then Geometric, then Terrain Correction, and

then Range-Doppler Terrain Correction.

The I/O Parameters tab should be set to the displacement product that you

imported (or one of the other ML products).

default for target product name is to add “_TC” to the name

Under Processing Parameters tab, select the Source Bands and any

additional Output Bands. You can also choose what DEM to use, output

spacing, and map projection.

Now, we can display displacement_vv band of geocoded result. Again,

better to stretch colors.

Displacements in meters with positive values “up” towards satellite in Line-

of-Sight direction.

Product is now evenly spaced in latitude and longitude.
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3.10 Displacement Profiles

Use the line drawing tool (top bar of SNAP window) to draw a line across

the signal.

Run Analysis > Profile Tool to see displacement along the profile

Remember that InSAR displacements are relative

In this case, displacement far from the signal is about -0.1 m, so that is

probably the “true zero” offset

Maximum is about 0.24 m, but we need to subtract zero offset to get total

displacement of about 0.35 m

For more information, see the lecture: 13. SAR for earthquake monitoring
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THANK YOU FOR FOLLOWING THE EXERCISE!

https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_13.pdf
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