UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING

EXERCISE 11 — TUTORIAL

Flood Monitoring with Sentinel-1, Sentinel-2 data
using the SNAP software
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1 | Exercise outline

In this secondexercise for mapping floods,we will:
e Detect floods using Sentinel-2 images
e Create NDVI and NDWI spectral indices to explore floods
e Create binary water mask for flood mapping

e Compare results for flood mapping using Sentinel-1 and Sentinel-2
images
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However, during severe weather conditions with heavy rainfall and
intense cloud cover, optical remote sensing may struggle to provide
accurate information due to a lack of cloud-free, high-quality images and
difficulty in detecting water under vegetation cover.

Since October 4, 2023, the Myanmar Department of Meteorology and
Hydrology (DMH) has been issuing flood advisory warnings and weather
system alerts regarding water levels in major rivers. Between October 5
and 9, heavy rainfall during the late monsoon season resulted in
extensive flooding in southern Myanmar. On October 9, the DMH reported
that Bago township received an unprecedented 7.87 inches (200
millimeters) of rainfall, the highest recorded in 59 years. By October 10,
the water level of the Bago River rose 4 feet above the danger level,
leading to widespread flooding in urban and suburban areas. The impact
of this flooding has been significant, affecting families, croplands, and
causing displacement of people in areas including Bago City, Yangon, Taik
Kyi, Hlegu, and Hmawbi townships. (DREF OPERATION Myanmar Flood
2023)

Besides Synthetic Aperture Radar (SAR) data that we used in the first
part of the exercise for mapping floods, Sentinel-2 satellites are also
extensively used for flood mapping due to their ability to capture high-
resolution optical imagery of the Earth's surface. By analyzing these
images, particularly before and after flood events, analysts can identify
changes in water extent and detect flooded areas. The multispectral
capabilities of Sentinel-2 allow for the differentiation of water bodies from
other land cover types, enabling accurate mapping of flood-affected
areas. Moreover, Sentinel-2's frequent revisits and openly available data
make it a valuable resource for monitoring flood events in near real-time
and supporting disasterresponse efforts.
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2.1 Mapping floods with Sentinel-2 data

For the second part of this exercise, we will use two Sentinel-2 L2A
images of the same area near Bago city, Myanmar, downloaded from the
Dataspace Copernicus Open Access Hub
[@https://dataspace.copernicus.eu/].

Eomaar gy . O
BROWSER

D esiee X © L 2 O & L

VISUALIZE

SEARCH CRITERIA: ey rlen g

Product name

DATA SOURCES:
SENTINEL-1 Filters =

SENTINEL-2 Filters = g &

MSI

Lic

L2A

—) . 100%
Auxiliary Data File

HEIENON

Immediate @
SENTINEL-3 Filters =>
SENTINEL-5P Filters =

SENTINEL-6

TIME RANGE:

+ B
Erom rnmzmml
[ ] Copermcss ,

Eesa About  Support

i
MMl L=3flet | © OoenStreetMan contritutors - Disclamer. © Sentinel Hub Lat: 16770, Lng: 97.803

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open 2 downloaded products
(unzipped) by double click on the metadata ,MTD_MSIL2A.xml" inside
the folder. The opened products will appear in Product Explorer window.
Go to Windows - Tile them e.g. Horizontally.

S2B_MSIL2A_20231004T035609_N0509_R004_T46QHE_20231004T070950.SAFE.zip
S2B_MSIL2A_20230924T035539_N0509_R004_T46QHE_20230924T071828.SAFE.zip

1. Select the first product in the Product Explorer window.

2. Right click on the product.

3. Open RGB Image Window.

4. In the pop-up window select e.g. ‘Sentinel 2 MSI False-color Infrared
(Red: B8; Green: B4; Blue: B3).

5. Repeat the process for the second product.

6. Tile two opened RGB Windows, e.g. horizontally

7. In the Navigation window, zoom in to the flooded region and

syhnchronise views to see the same area
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2.3 Preprocessing

Resample

Resample the bands to the pixel size of the VIS bands:

In the main SNAP menu, select Raster - Geometric - Resampling

In the I/O Parameters tab, the source product is set to our only product
in the SNAP, change the name of the target resampled product if needed
Do not save the output product - disable the box “Save as:” (if selected).
In the Processing Parameters tab, use e.g. B3 with 10 m resolution to
resample all the bands to 10 m as output spatial resolution.

Resample both of the products.

¥ Resampling 3 | ¥ Resampling X
File Help File Help
1/0 Parameters  Resampling Farameters 1/0 Parameters Resampling Parameters

Source Product Define size of resampled product

Name:
By refer band fr: duct: B3
[1) 528_MSIL2A_20231004T035609_NOS09_ROD4_T46QHE_20231004T070950 = = (b e o bl praan: he
Resulting target width: 10980
Target Product Resulting target height: 10980
Name: () By target width and height: Target width: 10,980 =
528_MSIL2A_20231004T035609_NO509_R0O04_T46QHE_20231004T070950_resampled Target height: 10,980 %
[ save as: |BEAM-DIMAP Width / height ratio: 1.00000
Directory: (0) By pixel resolution {n m): 205
Z:\Pracovnicpnadillova\ESA_EMEUM\exerdse_8 = Resulting target width: 5490

Open in SNAP Resulting target height: 5420

Define resampling algorithm

Upsampling method: Nearest v
Downsampling method: First ~
Flag downsampling method: First ~

[ Advanced Methed Definition by Band

Resample on pyramid levels (for faster imaging)

Run Close Run Close
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Create subset
Click on the resampled product in the Product Explorer, go to the main
SNAP menu and select Raster - Subset...:

Create a subset with the following settings:

Spatial subset - Geo Coordinates:
North latitude bound: 18.00,
West longitude bound : 96.20,
South latitude bound : 17.00,
East longitude bound : 97.00

Keep the remaining parameters as default and click OK
E Specify Product Subset X

Spatial Subset  Band Subset Tie-Point Grid Subset Metadata Subset

Pixel Coordinates  Geo Coordinates
Scene start X: 4000 -5
Scene start Y: 2000 -5
Scene end X: 10900 -5
Scene end ¥: 10900 -5
Scene step X: 15
Scene step s 15
Subset scene width: 6901.0
Subset scene height: 8901.0
Source scene width: 10980
Source scene height: 10980
[ Fis full width
Use Preview
[ Fixe full height
v

Estimated, raw storage size: 15348.1M

Cancel Help

In the end, you should have two resampled subsets. Close original
visualizations and display subsets in False color with Tile Horizontally
option.

B (5] subset_1_of_S2B_MSIL2A_20231004T035609_N0509_R004_TA6QHE_20231004T070950_resampled - [not saved] - SNAP - ] X
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S (5] subset_1_of 528_MSIL2A_20231004T035609_N0509_R0D4_T46QHE _20231004T070950_resampled
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2.4 Image analysis
NDVI

Let “s calculate NDVI for the two subset images.

Navigate to Main Menu: Optical - Thematic Land Processing — Vegetation
Radiometric Indices — NDVI Processor and set parameters:

B novi x B novi ®
File Help File Help
IfO Parameters  Processing Parameters /O Parameters Processing Parameters
S Product
ource Produ Red factor: o
source:
[5] subset_1_of_S2B_MSIL2A_20231004T035609_NOS09_R004_T46Q... || ... NIR factor: 10
Red source band: |B4 w
Target Product MIR source band: |BS w
MName:

E26_MSIL24_20231004_ndvi

[ 5ave as: BEAM-DIMAP
Directory:

Z:\Pracovnicenadllova\ESA_ENEUM\exercse_8

Open in SMAP

In the Product Explorer tab double click to open resulted two new NDVI
bands for each date.

Go to Colour Manipulation tab and select appropriate colour palette for
vegetation index. Apply the same colour palette and set the sliders to the
same values for both of the images. Synchronize Cursor Position and
Views activating the two buttons in Navigation tab. &

B 171 ndvi - S2B_MSIL2A_20231004_ndvi - not saved - SNAP & o X
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NDVI image has usually values from < -1, 1 >, where forested areas are
displayed in values higher than 0.
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NDWI
Let "s calculate also NDWI for the two subset images.

Navigate to Main Menu: Optical - Thematic Land Processing - Water
Radiometric Indices - NDWI Processor and set parameters:

B nowi x B now *
File Help File Help
[/ Parameters  Processing Parameters If0 Parameters Processing Parameters

Source Product
Resample Type: None

SOource:

[5] subset_1_of 528 MSIL2A_20231004T035608... Upsamping Method: [

Downsampling Method: |First

Target Product MIR. factor: 1.0
Mame: NIR factor: 1.0
2B_MSIL2A_20231004_ndwi MIR. source band: B12 w
(] save as: |BEAM-DIMAP NIR. source band: Ba ~
Directory:

Z:\Pracovnici\onacillova\ESA_EMEUM\exercise_8

Open in SNAP

Run Close Close

In the Product Explorer tab double click to visualize resulted two new
NDWI layers.

Go to Colour Manipulation tab and select appropriate colour palette for
vegetation index. Apply the same colour palette and set the sliders to the
same values for both of the images. Synchronize Cursor Position and
Views activating the two buttons in Navigation tab. B
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2.5 Water Mask Generation
The utilization of both NDVI and NDWI together can be advantageous for
specifically identifying water bodies.

Let’s create a binary mask of water and non-water pixels with a
thresholding condition. Open e.g. False-color composition and define a
Waterbody Region of Interest (ROI)

Define a new ROI (Vector->New Vector Data Container)

Vector Raster Optical Radar Tools

Y _
[% Mew Vector Data Container

Define ROI name (f.e. Water_ROI) and description (optional)

H Mew Vector Data Container et

Mame: Water_ROI

Description:

Cancel Help

Check in VectorData folder corresponding to the active image to check
the ROI has been created. Define Tool for ROI construction (Polygons
Drawing Tool) and draw polygon over water area e.g. according False-
color Infrared composition and double-click to close it

B (5] Water_ROI - [subset_1_of_S2B_MSIL2A_20231004T035609_N0509_R004_T46QHE_20231004T070950_resampled] - [not saved] - SNAP - o X
File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help Qr Search (Ctrl+) ‘
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- (] Metadata 5
(@2 Index Codings a
£-&3 Vector Data M
B pns =
i ground_control_points
> Wwater ROI
(3 Tie-Point Grids Open Placemark Window
-3 Bands Geometry as Shape file
(- (3 Masks v

Ctrl+X
<

v

Copy Ctrl+C =
- | World View

Navigation - [§] R... X |C S

Delete

Properties

wNEpALP|

1:56.84 1 o e HO

X =Y = lat —lon — Zoom — Level - Pixel Spacing: —m —-m @

Export ROI as SHAPE file (f.i. as Water_ROI.shp) - right click on the layer
- Geometry as Shapefile - set the directory for export and close the
visualization
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Import SHAPE file to make it available in NDVI and NDWI layers:
Select NDVI product - File — Import- Vector data — ESRI Shapefile - and
import your saved Water_ROI polygon

Select NDWI product - File — Import- Vector data — ESRI Shapefile - and
layers

import your saved Water_ROI polygon. Select NDVI and NDWI

from Product Explorer panel and visualize them.

Product Explorer X | PixelInfo |

Ci-E [8] S26_MSIL2A_20230924_ndvi
- E3 Metadata

- (33 Flag Codings

&3 Vector Data

i i pins

B ground_control_points
& 33 Tie-Point Grids

- E3 Bands

B [E3 Masks

S [3] 525_MSIL2A_20231004_ndwi
- 33 Metadata

& 33 Flag Codings

E2-E3 Vector Data

i * pins

B ground_control_points

E—Ja Bands

Product Explorer X |Pixelinfo |
58 [8]S2B_MSIL2A_20230924 ndvi
@32 Metadata
- (@ Flag Codings
£-@3 Vector Data
-l pins
i~ ground_control_points
i water ROI Polygon
& geometry
(2 Tee-Point Grids
-6 Bands
@ ndvi
@ ndvi_fiags
-0 Masks

E-8 (8] S28_MSIL2A_20231004_ndwi

@ Metadata
- Flag Codings
@3 Vector Data
i~ pins
& ground_control_points
B Water_ROI_Polygon

Calculate Histogram over ROI for NDVI and NDWI during pre-flood and
during flood events:
click on NDVI layer — Navigate to Analysis->Histogram - activate Use
ROI Mask tab - select Water ROI Polygon mask and press refresh button.

Histogram X |
Histogram for ndvi % »
Use ROIL mask:
175
w Water ROI_Paly... - g_;
2 150
o
" 125 #Bins: 512
E- 100 [] Log10 scaled bins
[
=t
g "~ X-Axis
o S0 Auto min/max
=
- 25 Min: |-0.5825
0 iy i Max: |0.6034
-06 -05 04 03 02 01 00 01 02 03 04 05 06 -
ndvi OXesd @
Histogram > |
Histogram for ndvi =B »
700 Use ROI mask:
& 600 Water_ROI_Poly... -« g-;
2 500
Q [l
it #Bins: 512
E- 400 [ Log10 scaled bins
2 300
z K-Axis
g 200 Auto min/max
L 100 Min: |-0.4833
0 Max: |0.6014
0.1 0.0 01 0.2 0.3 0.4 0.5 0.6 -
ndvi e sd @
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Repeat for NDWI layer.

Histogram X|
Histogram for ndwi = B »
Use ROI mask:
w 1207 Water ROI Foly... o =
g 5 -
= 1z .
iT #hins: 512
= 100
; [ Log10 scaled bins
g 751
v ¥-Axis
& 504
o Auto minfmax
| .
L 254 Min: |-0.0834
o A it - L e sl Max: |1.0714
01 00 01 02 03 04 05 06 07 08 0.9 10 1.1 -
ndwi HY&Es @
Histogram
Histogram for ndwi = B »
800 Use ROI mask: =
Tm.l 200 1 Water_ROI Poly... ~ =T
2
2 600 _
it #Bins: 512
£ 5007 [[] Log10 scaled bins
g 400
c
L 2004 X-Axis
o 200 1 Auto minfmax
£ 2
100 A Min: |0.3247
o Max: |0.9937
030 035 040 0,45 050 055 0.60 065 0.70 075 0.80 0.85 0,20 095 1.00 =
ndwi A& E @
Proposed thresholding values
No-flooded NDVI<-0.15 and NDWI >0.3
Flooded NDVI< 0.1 and NDWI > 0.35

Create masks for NDVI and for NDWI with a combined (AND) condition:
Open Band Maths window from Raster>Band Maths or by selecting any
available layer (f.i. NDWI) and clicking on the mouse’s right button. Edit
the formula by selecting the NDVI and NDWI properly (corresponding to
the same acquisition) and applying the proper thresholds).
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Calculate new masks for pre-flood and flood events.

B Band Maths * [ Band Maths X
Target product: Target product:
[a] 52B_MSIL2A_20231004_ndwi ~ [8] S2B_MSIL2A_20230924_ndvi ~
Name: WaterMask_flood Name: WaterMask_flood
Description: Description:
Unit: Unit:
Spectral wavelength: 0.0 Spectral wavelength: 0.0
[ virtual (save expression only, don't store data) [] virtual {save expression only, don't store data)
NaN NaN

Band maths expression: Band maths expression:
$9.ndwi > 0.3 and $7.ndvi < -0.15 §10.ndwi = 0,35 and $8.ndvi < 0.1

Load... Save.. Edit Expressian. . Load... Save... Edit Expression... |

Cancel Help OK Cancel Help

Product Explorer X | Pixel Info — || ] waterMask_pre_flood % ¥ O |[E 5] waterMask_flood % b=

-6 [1] S2B_MSIL2A_20231004T035609_NOS0S_RO04 T46QHE_20231004T
61 & [2] S2B_MSIL2A_20230924T035539_N0S09_RO04_T46QHE_20230924T
@il [3) 525_MSIL2A_20231004T035605_NDS05_ROD4_T46QHE_20231004T
-8 [4] S2B_MSIL24_20230924T035533_NOS03_R004 T46QHE_202309241
i1 & [5] subset_1_of_S2B_MSIL2A_20231004T035609_N05S09_RO04_T46QH
@&l [6] subset_2_of S2B_MSIL2A_20230924T035535_ND509_RO04_T460QH
@B [7] S2B_MSIL2A_20231004_ndvi
i 64 [8] S28_MSIL2A_20230924_ndvi
@& [9] S2B_MSIL24_20231004_ndwi
@68 [10] 528_MSIL2A_20230924 ndwi

aBevel he ([

Ateigr prpoid |

aBeuew isen

< >
Navigatio... X | Colour Mani... | Uncertainty ... |World View —|
.
i
1:176.32 I 00 5 @.
s lat —lon — Zoom — Level — Pixel Spacing: —m —m @

2.6 Export and open binary masks in QGIS
To export this product for viewing in other GIS software and to map the
changes in flooding over time, you need to save our two binary mask
(start of floods and peek of floods) in TIF format in the proper folder
using File-> Export->GeoTiff/BigTiff tool.

To visualize the output of our multi-temporal flood analysis, we will open
the masks saved in GeoTIFF format using QGIS:

In QGIS click on the Add Raster Layer button located in the left panel,
navigate to the folder containing the binary masks in TIFF format, and
click Open (or drag&drop).

Now we open the output image in QGIS

« We can overlay it to e.g. Google Satellite or Bing aerial image:
+ Web->OpenlLayers plugin->Google Maps->Google Satellite

+ Move the Subset above the satellite
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« Play with Transparency: Properties->Transparency (e.g. 80%)

As observed, the floodwaters gradually subside over time, yet areas near
the riverbanks remain saturated, displaying low backscatter and thus
continuing to appear flooded.

Compare masks retrieved via S1 and S2 using S2-RGB data as (quasi
simultaneous) ground truth.

(@ *Untitled Project — QGIS - [m] X
Project Edit View Layer Settings Plugins Vector Raster Database Web Mesh HCMGIS Hyperspectral SCP  Processing Help

DoERRY O*LLRANIFMRA~MNBRENOR %I &
BV, ZRB@ /. : A e R A

v IEb - O ¢ ~Band: 1 ~ » Eg” 2 G -rooisree = i i\é T2
Layers ® ‘:‘ Multiple plugin updates are available \ME{ Q
AW -HRO :
» V| # Google Satellite .
» V| B subset S2B_MSIL2A_20230924, ’ Sentinel-2
» V| B subset_S2B_MSIL2A_20231004, ¥ = '

< ) | |

Vertex Editor
& Legend
?éghm;ﬁd;f"cﬂcﬁmue featine toshow I Flooded/Wet September 24t
Wy a s < b 1 e et v I Flooded/Wet October 4t
Wdeblimada el a
Layers ®

v @BeTo-FAD

[ - Google Satellite

V| " subset_1_of_S1A_IW_GRDH_1SDV_20231008
V| ¥ subset_0_of_S1A_IW_GRDH_1SDV_20230926

»
»

] I »
Vertex Editor ®

Right dlick on an editable feature to show its table of vertices. Legend

When a feature is bound to this panel, dragging a rectangle to
select vertices on the canvas will only select those of the
bound feature.

I Flooded/Wet September 26t
I Flooded/Wet October 8t

For more information, see the lectures: 10. SAR and optical remote
inq f ing floods, ) . _

THANKYOU FOR FOLLOWING THE EXERCISE!
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https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_10.pdf
https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_11.pdf

