
EXERCISE 9 – TUTORIAL

Sentinel-1, Sentinel-2 for Snow and Ice using the

SNAP software

UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING



In this exercise,we will:

 Perform our own sea ice classification using created training data
and Random forest classificator

 Understand the capabilities and limitations of Synthetic Aperture
Radar (SAR) in detecting and monitoring sea ice.

 Discriminate between open water and different types of the sea ice

 Identify areas with varying degrees of ice deformation

 Perform classification using Sentinel-2 data NDSI

1 | Exercise outline
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Mapping snow and ice using Sentinel-1 and Sentinel-2 data

2 | Background
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Sea ice refers to frozen seawater that
forms when ocean water freezes due to
low temperatures. It typically occurs in
polar regions, such as the Arctic and

Antarctic, where temperatures drop low
enough for the surface of the ocean to
freeze. Sea ice can vary in thickness
and extent, ranging from thin, seasonal
ice that forms and melts each year to

thicker, multi-year ice that persists
through multiple seasons.

Sea ice plays a crucial role in regulating the Earth's climate, reflecting
sunlight back into space and influencing ocean circulation patterns.
Additionally, sea ice provides habitat for various species of marine life and
serves as a platform for indigenous communities and scientific research.

Sea ice encompasses various types, including first-year ice formed during
a single winter season, and multi-year ice, which survives multiple melt
seasons and is thicker and more consolidated. Sea ice can also be
categorized into additional types such as deformed ice, level ice, young
ice, and open water ice:

Deformed Ice: results from the compression and ridging of sea ice due to
the movement and collision of ice floes

Level Ice: refers to relatively flat and uniform sea ice surfaces that have
not undergone significant deformation or ridging

Young Ice: Young ice is newly formed sea ice that has not yet reached its

maximum thickness or strength.

Open Water Ice: describes areas of sea ice where the ice cover has
become fragmented or broken, leaving patches of open water exposed.

Sentinel-1 SAR imagery provides all-weather, day-and-night capability,
allowing for continuous monitoring of sea ice regardless of atmospheric

conditions or sunlight. By analyzing Sentinel-1 SAR images, researchers
can monitor changes in sea ice extent, thickness, and movement over
time, providing valuable information for climate studies, navigation, and
environmental management. Additionally, these data can be used to
detect and monitor other features, such as icebergs, ice floes, enhancing

our understanding of polar environments and their role in the Earth's
climate system.

Sentinel-2 satellite imagery is also valuable for mapping ice due to its
high spatial resolution and multispectral capabilities. By capturing detailed
images of ice-covered regions, Sentinel-2 facilitates the monitoring of ice

extent, ice type classification, glacier movement, and changes in ice
dynamics over time.



2.1 Study area and data used

For this exercise, we will use Sentinel-1 GRDH image and Sentinel-2 L2A

image over the Straight of Denmark between Greenland and Iceland,

downloaded from the Dataspace Copernicus Open Access Hub

[@https://dataspace.copernicus.eu/].

Part A: Sea ice mapping with Sentinel-1

2.2. SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open downloaded Sentinel-1

GRDH product by double click on it. The opened product will appear in

Product Explorer window. The Worldview window (at the bottom-left

corner) shows the coverage of the image opened. Double click on e.g.

„Intensity_HH“ band within Bands folder to visualize it.

S1A_IW_GRDH_1SDH_20230217T193310_20230217T193335_047280_05AC96_9AFD.SAFE.zip
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2.3 Pre-processing

We need to apply identical pre-processing steps to our scene:

Apply orbit file

Navigate to Main Menu > Radar > Apply orbit file

In the I/O Parameters tab, select the opened product. By default, the

output target is set to the same directory and appends „Orb" to the

filename. There is no need to save the output as BEAM-DIMAP (we will

save the time this way).

In the Processing Parameters accept the default settings and select the

option „Do not fail if new orbit file not found“

Thermal noise removal

Navigate to Main Menu – Radar > Radiometric > S-1 Thermal Noise Removal

In the I/O Parameters tab, select the product with applied orbit file. By

default, the output target is set to the same directory and appends „tnr" to

the filename. There is no need to save the output as BEAM-DIMAP.

In the Processing Parameters keep both HH and HV polarisations and make

sure that the “Remove Thermal Noise” option is selected.
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The image should then look something like this (view e.g. Intensity_HH):

Create subset

There is no need to process the whole image, instead, we can begin by

narrowing down the scene to a more manageable size – creating subset.

This approach will decrease processing time in subsequent stages,

especially when the analysis is concentrated on a specific area rather than

the entire scene.

5

Select the last product with

applied Thermal noise removal.

Go to the Subset tab and at

“Pixel Coordinates” set:

Scene start X: 5500

Scene start Y: 3000

Scene end X: 17300

Scene end Y: 15100

Now, the image is prepared for

classification. Open the final

product, e.g. Intensity_HH to

see the output image.



2.4 Image classification

Today we will perform a random forest classification. For this we will create

some training data by identifying polygons containing the different ice

types:

– Deformed Ice

– Level Ice

– Young Ice

– Open Water

Select the last subset product by clicking on it. Navigate to Vector > New

Vector Data Container.

Create four new data containers – separate for each type of ice mentioned

above.

Start with creating the data container for, e.g. deformed_ice“ and repeat this

step for other three types.
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The newly created four vector data containers for each ice type should

appear under "Vector Data" in the Product Explorer.

Now let´s start creating training polygons for these different containers on

ice type using the Polygon drawing tool:

Open both HH and HV polarisations to better identify different types of

ice.by double clicking on them.

Then, click on the icon Tile Horizontally (or navigate to the main menu -

Window and select this option).
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Deformed (Pink), Level (Violet), Young ice (Green) and Open water (Blue)

Sea Ice Polygons. Save the final product with your created vector data

containers to your folder.
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Random Forest image classification

Navigate to Raster > Classification >

Supervised classification > Random

Forest Classifier

• In the ProductSetReader tab select the

saved product with your training data.

• In the Random-Forest-Clasiffier select

the classes/training vectors (all our

sea ice polygon vector containers)

and feature bands (select both

Intensity_HH and Intenisty_HV

polaristaions) that you’d like to include

into image classification.

• In the Write tab by default, the output

target is set to the same directory and

appends „RF" to the filename.

•Click RUN.



2.5 Post-processing

The final product should now appear in the ProductExplorer. Visualize this

output classified image and classes by double-click on the layer

„LabeledClasses“ under Bands folder in the Product Explorer.

Navigate to Colour Maniulation tab to change the colours of individual sea

ice classes and exlore the frequency of these classes through the classified

image and table.
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Part B: Sea ice mapping with Sentinel-2

2.6 SNAP - Open and explore product

Open SNAP Desktop, click Open Product and open downloaded Sentinel-2

by double-clik on the metadata „MTL.txt“ inside the unzipped folder (or

click on Import Product). The opened product will appear in Product

Explorer window.

S2A_MSIL2A_20230221T140211_N0509_R010_T25WER_20230221T185001.SAFE.zip

Select (by clicking on it) the product in the Product Explorer window. The

Worldview window (at the bottom-left corner) shows the coverage of the

image opened.

Now, let´s visualize the image using True colour composition:

• Right click on the product.

• Open RGB Image Window.

• In the pop-up window select ‘Sentinel 2 MSI Natural colors’ (Red: B4;

Green: B3; Blue: B2)

Now, let´s visualize the image using False colour composition:

• Right click on the product.

• Open RGB Image Window.

• In the pop-up window select ‘Sentinel 2 MSI False Colour-Infrared’

(Red: B8; Green: B4; Blue: B3)

Now, let´s visualize the image using another False colour composition:

• Right click on the product.

• Open RGB Image Window.

• In the pop-up window select ‘Sentinel 2 MSI Atmospheric-Penetration’

(Red: B12; Green: B11; Blue: B8A)

Tile Windows, e.g. Horizontally, to explore the Sentinel-2 image features.
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2.7 Resample

Resample the bands to the pixel size of the VIS bands:

In the main SNAP menu, select Raster > Geometric > Resampling

In the I/O Parameters tab, the source product is set to our only product

in the SNAP, change the name of the target resampled product if needed

Do not save the output product - disable the box “Save as:” (if selected).

In the Processing Parameters tab, use e.g. B2 with 10 m resolution to

resample all the bands to 10 m as output spatial resolution.

2.8 Normalized Difference Snow Index

Next, we will calculate Normalized Difference Snow Index (NDSI) in

SNAP.

The Sentinel-2 NDSI is a ratio of two bands: one in the VIR (Band 3) and

one in the SWIR (Band 11). Values above 0.4 are usually snow. The

Sentinel-2 NSDI can be used to differentiate between cloud and snow

cover as snow absorbs in the short-wave infrared light, but reflects the

visible light, whereas cloud is generally reflective in both wavelengths.

Most potential cloudy pixels have NDSI values in a range between -0.1

and +0.2.

To calculate NDSI, select the last subset product, navigate to the main

SNAP menu and select Raster - Band Maths (deselect the box “Virtual”).
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SNAP menu and select Raster - Band Maths (deselect the box “Virtual”).

Click on Edit Expression to calculate the NDSI using the equation below

and click OK:

ρ(VIS) – ρ(SWIR) / ρ(VIS) + ρ(SWIR)

ρ = Top of atmosphere reflectance

VIS = Visible band (0.56 µm)

SWIR = Short-Wave Infrared Band (1.6 µm)

Replace the bands in the equation with the corresponding bands for

Sentinel 2:

ρ(B3) – ρ(B11) / ρ(B3) + ρ(B11)

Open the output product in the Product Explorer by double click on the

new raster NDSI within Bands folder.

Go to Color Manipulation tab and go to Table – set the thresholds of

slider to three values – minimum value, up to 0.4 (usually pixels with no

snow), higher than 0.4 (usually snow pixels) and maximum value.
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Explore the image: values above 0.4 are usually snow pixels (shades of
grey for the lowest probability of snow and shades of white for the
highest probability of snow). The Sentinel-2 NSDI can be also used to
differentiate between cloud and snow cover as snow absorbs in the

short-wave infrared light, but reflects the visible light, whereas cloud is
generally reflective in both wavelengths.

Most potential cloudy pixels have NDSI values in a range between -0.1
and +0.2. Add 4 new sliders and change their colour to e.g. red to

highlight these values of potentially cloudy pixels.

For more information, see the lecture: 8. SAR and Optical remote sensing

for mapping snow
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THANK YOU FOR FOLLOWING THE EXERCISE!

https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_08.pdf
https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_08.pdf

