UNIVERSITY COURSE APPLIED RADAR REMOTE SENSING

EXERCISE 6 —= TUTORIAL

Crop Classification with S1 time series data using the
SNAP software
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1 | Exercise outline

In this exercise,we will:

e Use radar Sentinel-1 data to classify and analyse time-series for
different types of crop fields

e Data pre-processing will be perfomed, an then the crop types will
be estimated by classification of the data, based on the Random

Forest algorithm

e Land crops growth and health will be observed using RGB
composites and backscatter values of different crop types using
time series
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2 | Background

Crop classification using Sentinel-1 time-series

Crop classification using Sentinel-1 data involves the analysis of radar
backscatter signals to differentiate between different types of crops based

on their unique radar signatures.

Sentinel-1 data, with its frequent revisit times and all-weather capability,
is particularly useful for crop classification as it provides consistent and

reliable information regardless of weather conditions.

Crop classification using Sentinel-1 data relies on the radar backscatter
sighals obtained from the satellite. The backscatter intensity, polarization,

and texture of the radar imagery are analyzed to distinguish between

different crop types.

These images show the same multi-temporal radar composite acquired over the
Flevoland test site in the Netherlands. The grainy appearance of the left image is
characteristic of radar images and often a limiting factor in using them at high
resolution. The right image demonstrates how a new mathematical technique
based on multiple images, which was improved in the campaign, can dramatically
enhance the appearance of the image and data quality.
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2.1 Study area and data used

For this exercise, we will use three Sentinel-1 images to explore fields in
Orleans, France, downloaded for year 2023 from the Dataspace
Copernicus Open Access Hub [@https://dataspace.copernicus.eu/].

‘ OPErmicUs  En Katarina Onagillovi < Q, orleans I ¢
BROWSER

§ 257302 km? il a2
VISUALIZE SEARCH . 5t 5 0 zoem X @ W 2 O &

SEARCH CRITERIA:

Product name

DATA SOURCES:

SENTINEL-1 Filters >
C-SAR

Level-0 RAW
Level-1 SLC

Level-1 GRD
Level-1 GRD COG
Level2 OCN

ETAD

Ausliary Data File

Immediate ©
SENTINEL-2 Fiters =
SENTINEL-3 Filters =
SENTINEL-5P Fiters

SENTINEL-S o]

TIME RANGE:

From:

< 20230101 > nh 00 $:mmoo &

Until

< 20230731 > nh23 - mmse ¢

Filter by months

Jan Feb Mar Apr May Jun
Jul Aug Sep Oct Nov Dec
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2.2. SNAP - Open and explore products

Open SNAP Desktop, click Open Product and open three Sentinel-1 GRDH
downloaded products with HH and HV polarizations acquired on 11 July
2023 by double click on the zipped folders. The opened products will
appear in Product Explorer window:
S1A_IW_GRDH_1SDV_20230308T174046_20230308T174111_047556_05B5EA_6563.SAFE

S1A_IW_GRDH_1SDV_20230519T174049_20230519T174114_048606_05D890_2249.SAFE
S1A_IW_GRDH_1SDV_20230730T174053_20230730T174118_049656_05F897_BEA3.SAFE

SNAP

File Edit View Anal)isis Laxer Vector Raster Qgtica| Radar Tools Window Help
ﬁ% va:,:"\’j_J"lh ‘5 i«.l‘ .Eﬁ‘\\ij‘P'lel@[@Lf\fz

Product Explorer X l Pixel Info I =
@& [1] S1A_IW_GRDH_15DV_20230308T174046_20230308T174111_047556_05B5EA_6563
@& [2] S1A_IW_GRDH_1SDV_20230519T174049_20230519T174114_048606_05D890_2249
-6 [3] S1A_IW_GRDH_1SDV_20230730T174053_20230730T 174118_049656_05F897_BEA3

Navigation - [7] LabeledCl Colour Manipulation - [7] LabeledClasses World View X —_—
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3. Pre-processing

3.1 Create subsets

There is no need to process the whole image, instead, we can begin by
narrowing down the scene to a more manageable size - creating subset.
This approach will decrease processing time in subsequent stages,
especially when the analysis is concentrated on a specific area rather than
the entire scene.

Go to the Subset tab and at “"Geo Coordinates” set:

North latitude bound: 48.10
West longitude bound: 1.40
South latitude bound : 48.20
East longitude bound : 1.50

Note: There is no need to wait till thumbnail image will be created when
entering coordinates.

Save the output subsets to your folder — we will need them for the next step.

B specify Product Subset >

Spatial Subset Band Subset Tie-Point Grid Subset Metadata Subset

P
Pixel Coordinates Geo Coordinates
Morth latitude bound: 43.10 5
West longitude bound: 1,40 =
South latitude bound: 48,20 =
East longitude bound: 1,50 -5
Scene step X: | =
Scene step ¥ | =
Subset scene width: 20393.0
Subset scene height: 2367.0
Source scene width: 26167
Source scene height: 16675
[ ] Fix full width
Uze Preview
[ ] Fix full height
W

Estimated, raw storage size; 184, 1M

Ok Cancel Help
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3.2 Build a pre-processing graph
Use the graph buildertool to create workflow for data processing:

Go to Tools > GraphBuilder
Right click and add, in the order below, each of the preprocessing steps:

« The first tool is Read

« Add>Radar>Radiometric>Calibration

« Add>Radar>Speckle Filtering>Speckle-Filter

« Add>Radar>Geometric>Terrain Correction>Terrain Correction
+ Add>Raster>Data Conversion>LinearToFromdB

* The last tool is Write

Click on each tool, and connect them by dragging the red arrows from one
tool to the next, respecting the order above.

B Graph Builder x

File Graphs

Calibration Terrain-Correction

LinearToFromdB

Target Product

MName:
subset_2_of 51A_TW_GRDH_15DV_20230730T174053_20230730T174118_049656_05F397_BEA3_Cal_Spk_TC_dB

Save as: BEAM-DIMAP v
Directory:
Z:\Projekty\2023_ESA_EMEUMYO? ucebne_materialy\Aplikacie_DPZ\practicals\exercise_&

g_ e U [ o
E\ Load {/ Clear Mote ) Save @l Help [ﬁ_: Run
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Leave the default parameters for individual tools, except Speckle-Filter:
- here, select Filter: Lee

Then got to File>Save Graph to save the workflow as a XML file
~Crops_graph".

B snaP - save Graph *
Save in: exercise_g w = ER-
:\:,f_‘ . Mazov Velkost' Typ polozky Datum dpravy
"-"J subset_2_of S1A_|W_GRDH_15DV_20230711T050035_20... Priecinok si...  29. 2. 2024 20:24
Maposledy p...

-' File name: crops_graph. xml
Pracovna plo...

ymS Files of type: | Graph (= xml) V Cancel

Batch processing

Navigate to Tools > Batch Processing:

Using the Add opened symbol select the files you want to process.

B atch Processing e
File Graphs

10 Parameters

File Name Type Acquisition Track Orbit '=|'_,1='
subset_0_of_S1A_IW_GRDH_15DV_20230308... |GRD 08Mar2023 59 47556 —
subset_1_of S1A_IW_GRDH_15DV_20230519... |GRD 15May 2023 59 43606 +
subset_2_of S1A_IW_GRDH_1SDV_20230730... |GRD 300ul2023 59 496556 =
]
(&)
®
3 Products
Run remote Load Graph Run Close Help
Using the Load Graph button, load the .xml-file you just saved
B Batch Processing >
File | Graphs
Load Graph
i Type Acquisition Track Orbit '=ﬂ='
View Graph XML
S e YT IsDv_20230308... |GRD 08Mar2023 59 47555 —
subset_1_of S1A_IW_GRDH_15DV_20230519... |GRD 19May2023 59 43605 *
subset_2_of_S1A_IW_GRDH_15DV_20230730... |GRD 30Jul2023 55 49655 —
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Adjust the output folder, click Run.

E Batch Processing : crops_graphxml x
File Graphs

IO Parameters  Calibration Speckle-Filter Terrain-Correction LinearToFromdB  Write

File Namg Type Acquisition Track Orhit oR
subset_0_of S51A_IW_GRDH_15DV_20230308... |GRD 08Mar2023 59 47556 —
subset_1_of 51A_IW_GRDH_15DV_20230519... |GRD 19May 2023 59 48606 s
subset_2_of 51A_IW_GRDH_15DV_20230730... |GRD 300ul2023 59 49656 —

foa
(=57
P

3 Products

Run remote Load Graph Close Help

Note: this step might take several minutes to run.

When the process finishes it opens all of the output products in the Product
Explorer window.

Product Explorer X | Pixelinfo | -
[1] S1A_IW_GRDH_1SDV_20230308T174046_20230308T174111_047556_DSBSEA_6563

[2] S1A_IW_GRDH_1SDV_20230519T174049_20230519T 174114 _048606_05D890_2249

[3] S1A_IW_GRDH_1SDV_20230730T174053_20230730T174118_049656_05F897 BEA3

[4] subset_0_of S1A_IW_GRDH_1SDV_20230308T174046_20230308T174111 047556 _0SBSEA_6563

[5] subset_1_of S1A_IW_GRDH_1SDV_20230519T174049_20230519T174114 043606_05DE90_2249
(6] subset_2_of S1A_IW_GRDH_1SDV_20230730T174053_20230730T174115_049655_(5FS97_BEAZ

[8] subset_1_of S1A_IW_GRDH_1SDV_20230519T174049_20230519T174114 048606_05SD890_2249_cCal_Spk_TC_dB
[10] subset_2_of S1A_IW_GRDH_15DV_20230308T174046_20230308T174111 047555 _0SB5EA_6553_C

MY G G G Y i

Create stack

Go to Radar > Coregistration > Stack Tools > Create Stack

In the Product-Set-Reader tab select the last three products from the
previous step.

&

1-ProductSet-Reader 2-CreateStack 3-Write

File Name Type Acquisition  Track Orbit ':E:'
subset_2_of S1A_IW_GRDH_15DV_20230308T 174046_20230308T174111_047556_05B5EA_6563_Cal_Spk_TC_dB  |GRD 08Mar2023 |59 47558
subset_1 _of 51A_IW_GRDH_1SDV_20230519T174043_20230519T 174114 048606_05D890_2243_Cal_Spk_TC_dB  |GRD 19May2023 |59 436086
subset_2_of 51A_IW_GRDH_1SDV_202307307174053_20230730T 174118_049656_05F897_BEA3_Cal_Spk_TC_dB  |GRD 300ul2023 |59 49656 =k
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In the CreateStack tab, select Product Geolocation as Initial Offset Method
(Note: we did not use apply orbit file function, but the product geolocation
is accurate enough for the purpose of our analysis)

@5 Create Stack >

1-ProductSet-Reader 2-CreateStack  3-write

Reference: subset_2_of S1A_IW _GRDH_15DV_20230730T174053_20230730T174118_049656_05F897 BEA3_Cal Spk_TC_dB

Resampling Type: MOMNE =
Initial Offset Method: Product Geolocation i
Cutput Extents: Master w

Find Optimal Reference

In the Write tab, adjust the stack name if needed, adjust the output folder
and click Run. This step will might take few minutes.

After the process is finished, we can see the new final ,Stack™ product in
the Product Explorer window.

Display RGB time series

Now we can look at some RGB composites of this time series

Right-click on the last ,Stack" product — Open RGB Image Window and
select different band combinations to see the change of backscatter
between one-day acquisition.

Firstly, we can look at polarimetric composite of the same day. For this,
select:

Red: Sigma0_VV_db_mst_08Mar2023

Green: Sigma0_VH_db_mst_08Mar2023

Blue: Sigma0_VH_db_mst_08Mar2023-Sigma0_VV_db_mst_08Mar2023

B B Edit Blue Expression X
Profile: Product: |{11] subset 2 of S1A TW GRDH 2023 Stack P
T Data sources: Expression:
vj& B W :
""" %11.Sigmal_VH_db_mst_08Mar2023 @+@ $11.8igma0_VH_db_mst_08Mar2023-
Red: |$11.8igma0_VV_db_mst_08Mar2023 o |[] | [511.Sigma0_VV_db_mst 03Mar2023 @-@ §11.8igma0_W_db_mst_D8Mar2023
$11.Sigma0_VH_db_siv1_19May2023|
«
[ fixed range min max 511.5igmal_V_db_siv2_19May2023 e'e
7 s o VH b © 08Ma2023 511.Sigma0_VH_db_shv3_30Jul2023 @@
veen: |811.5igma0_VH_db_mst_D8Mar kel [511.5igma0_wv_db_siv4_30Jup023 @
[] fixed range min max Constanizh
Blue:  $11.8igma0_VH_db_mst_08Mar2023- $11.Sigma0_\W_db_mst_08Mar2023 “ I:‘ Operators... >
Functions. S
[] fixed range min max
Show bands
Expressions are valid
Show masks
[[] Store RGE channels as virtual bands in current product Shonepont s : = . .
Shaw single flags LEE @ 0Ok, na errors.
Cancel Help Cancel Help
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B [11]rGB x| v O

Another RGB composition we can generate is to look at images of the same
polarisation but for different dates:

Right-click on the last ,Stack" B sectroamegeChennes X
product - Open RGB Image o
Window and select different band v|e B il
combinations to see the change res: [s11sigmao_vH_do_mst_osmarz023 V=
of backscatter for different e B max
acquisitions. For this, select: Green: |$11.Sigma0_VH_db_slvi_19May2023 -
Red: [] fixed range min max
Sigma0_VH_db_mst_08Mar2023 Blue:  |$11.Sigma0_VH_db_slv3_30Jul2023 v [
Green: [ ] fixed range min max
SigmaO0_VH_db_slv_18May2023 Expressions are vaiid

[] Store RGB channels as virtual bands in current product

Blue:

Sigma0_VH_db_slv_30Jul2023
Cancel Help
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B (1ree x| [111RGB () X|

Time Series Analysis (using single scenes, not a stack)
Tool cannot use a stack, it needs single images instead

Navigate to View > Tool Windows > Radar > Time Series to open the Time
Series tab at the bottom left of your SNAP window.
Click on Settings (top right of Time Series tab) and add individual (pre-

processed) images. Click Apply.

Navigation - [11] RGB | Colour Manipulation - [11]RGB | World View | Time Series X | — | B Time Series Analysis Settings *
1]
Sigma0_vH_db .
=LA E\f Ehiei &7 7] Shaw Legend
=51 [% Graph 1 A
= \ff] File Hame Type Acquisiton  Track  Orbit
NELE A || lsubset 2 of 514 1w _6RDA 150V 20230730... [6RD 301ul2023 59 45656
H 8, | | subsel Lo S1A TW SRR 15OV_202305 ... [GRD 19May2023 |59 48608
£ 5] £~ ||| sibset_2_of 51A 1W_GROH_150V_20230308... [GRD o8Mar2023 |59 47556
20 [=
v
& < >
-25 T T
19Feb23 26Apr23 02Jul23 075ep23 -
Acquisition Dare ? Ei
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Select also polarisation for which you want to explore time-series and dick
OK.

Navigation - [11]RGB | Colour S[11RGB | World View | Time Series X - -[111RGB | Colour -[11]1RGB  |World View | Time Series X -
100 o
Sigma0_vH_db ] ) Sigma0_VH_db )
[ Time Series Filters x| ] g
= Bands} vectors |[§/J = [§/J
E T | 2,3
3-‘ Sigmal_VH_db o 3‘ o
n 50+ W
8 [ sigmao_wv_db. \/)Q" H \ﬁ
£ » [|€157 N
=] [}
o | | BB £
‘ — & &
0 T T 1 -25 T T
19Feb23 26Apr23 02)ul23 075ep23 19Feb23 26Apr23 021ulz3 075ep23
Acquisition Date 2 Acquisition Date ?

Using the time series tab, hover your mouse over the area to see the
behaviour of single pixels over or use Pin Manager (View-Tool Windows-Pin
Manager) to see the behaviour of the selected Pins.

B 10Rree x|[@ (1R (D) X v o

Product Explorer X | Pixelinfo | — ||[E [RGB X =
-6 [1] S1A_IW_GRDH_ISDV_20230308T174046_20230308T174111_047556_0SBSEA_6563 3
©-65 [2] S1A_IW_GRDH_ISDV_20230519T174043_20230519T174114_048606_05D890_2249 &
-6 [3] S1A_IW_GRDH_ISDV_20230730T174053_20230730T174118_049656_0SF897_BEA3 =
-6 [4] subset_0_of S1A_IW_GRDH_1SDV_20230308T174046_20230308T174111_047556_0SBSEA_6563 ]
G168 [5] subset_1_of S1A_IW_GRDH_1SDV_20230519T174043_20230519T174114_048606_05D890_2249 =
-6 [6] subset_2_of S1A_IW_GRDH_1SDV_20230730T174053_20230730T174118_049656_0SF897_BEA3 -~
-6 [7] subset_2_of S1A_IW_GRDH_1SDV_20230730T174053_20230730T174118_049656_0SF897_BEA3_Cal_Spk_TC_dB =
(&) [8] subset_1_of_S1A_IW_GRDH_1SDV_20230519T174049_20230519T174114_048606_05D890_2249_Cal_Spk_TC_dB 2
-6 [10] subset_2_of S1A_IW_GRDH_1SDV_20230308T174046_20230308T174111_047556_0SBSEA_6563_Cal_Spk_TC_d8 =
-6 [11] subset_2_of S1A_IW_GRDH_2023_Stack H
2
ion - [11]RGB | Colour Manipulation - [11]RGB | World View | Time Series X -
L] = =
Sigma0_VH_db B =
z
Y 3
3
8
] 3 2
s 5 £
N4
%‘l-l 0 vz
[
£ 5] Pin Manager X =
i ||[x Y ton tat Color Label [ Y
950.684  328.711 1.460895  48.170379 N [}? ﬁ
o] 367.383  428.613 1408496  48.161405[ | potato S I R
1298.054  410.820 1492099 48.163003 N &
y
@ =
- | | "<
19Feb23 26Apr23 02Jul23 07Sep23 2
Acquisition Date g
x -y — | lat —lon - | Zoom — Level — Pixel Spacing: —-m —m @

Explore backscatter values of different crop types within the time range.

For more information, see the lecture: 6. SAR and optical remote sensing
for precision agriculture 2

THANKYOU FOR FOLLOWING THE EXERCISE!
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https://uge-share.science.upjs.sk/webshared/ESA_ENEUM/Applied_Radar_RS/Lectures/Lecture_06.pdf
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